Alfa Romeo Forum banner

rev

  1. Alfa MiTo
    Hi guys I hope you can help My mito will only rev up to 4000 rpm even with the clutch depressed any ideas why? Many thanks
  2. Alfa 147, 156 & GT
    Hi all, hoping you can help. I have an issue where the rear left hand light stays illuminated but very dim after turning off the engine and locking the car. after having a look around the forum I believe this could be a faulty Rev counter? on the display when i dont have my lights on i have a...
  3. Alfa Giulietta
    Hi to you all. I was looking everywhere in the web to find any document stating where the rev limiter kicks in at giulietta 1.4 multiair, but i couldnt find anything. Does anybody have found a table showing the rpms for rev limiter in each gear for manual 170 multi G? If so i’d like to have a...
  4. Alfa 147, 156 & GT
    Hello! I have an Alfa 2.5, 166, but I posted here because I see more activity, and I need a fast response. I changed the sparks myself, and when I started the car, all was good until I pressed the acceleration. The car is not revving and I don't know why. I let her idling and a beautiful...
  5. Alfa Giulia
    Hi everyone, I've done about 3000miles in my Veloce - loved every second of it! Had a bit of a strange sound coming from the engine since I picked the car up nearly 2 months ago now. Seems to happen when the engine is on or under 1500rpm. It's like a low rumble which eventually goes away after...
  6. Alfa 147, 156 & GT
    Hi Guys I recently changed my engine into a 2.0 Twin spark Was running smoothly until last Friday I lost power and when parked on the side of the road, I floor it and it doesn't rev above 1 RPM I had to tow it back home and been ubering to work since Parts of Troubleshooting I disconnected...
  7. Alfa MiTo
    I have a Mito Veloce yr 2009 which I bought 5 months ago, it has been lovingly cared for however I do have a little (hopefully) problem, symptoms are DNA not working and the engine warning light came on yellow with the message check engine. The engine light stayed on for a couple of hours but...
  8. Alfa 159, Brera & 946 Spider
    09 159 2.4 JTD m,TI, automatic, 135 k km, Starts OK, will not rev, happened suddenly. Only fault codes showing up are P1723 and P1724, which are transmission codes? But goes into drive OK and reverse OK but not enough revs to go anywhere!!! No EML, could be ERG? Help please, thanks
  9. Alfa 147, 156 & GT
    Done a search on this - lots of people with the same problem but can't find a guide which shows how to fix it Mine has the drivers side rear sidelight bulb glowing very dimly but not when the ignition is off so no battery drain I need to figure out how to get the carpet out to get at the earth...
  10. Alfa 147, 156 & GT
    I've only been an alfa owner for a few months now and it is really testing me lol. The car was running fine (only prob was sticky windows) and I hit a bump and knocked the exhaust into the sump and dumped its oil, my own fault. Repaired the sump and built it back together and it was running...
  11. Alfa 164 & 166
    It's happened to me three times now. First time, after getting close to 7k RPM she just conked out and wouldn't re-start. Had the RAC out who said it was the fuel pump. Changed fuel pump and all good, although the injector light has been on ever since. Second time (same stretch of road) after...
  12. Alfa 159, Brera & 946 Spider
    Hi all, having spent much time driving my 159 around recently (this makes me happy) ive noticed in carparks and sometimes when pulling away from standstill, the car is somewhat graunchy and irregular. The car has only ever been fueled with shell v-power under my ownership, so fairly sure...
  13. Alfa 147, 156 & GT
    Hi all have the tail light proplem on my alfa 156 2001 selespeed 2.0 ts. got a scond hand rev counter but turned out to be out of an early model than mine. so am i correct in asuming that if i replace my 2001 2.0 ts robootizza rev counter with one i aquired which is a 99 2.0 ts robootizza every...
  14. The Classic Alfa Romeos
    I think my rev counter is a bit sick. At 80kph it indicates 1600 revs whilst in 5th gear. Any thoughts pls?
  15. Alfa 147, 156 & GT
    Evening folks! My mate bought my old 156 off me after I experienced the dreaded "bonnet flip"!!! It's now been fully repaired and is ready for its MOT. However when he went to run it.... It now won't rev! :rolleyes: It'll tick over ok but refuses to rev! Where's the best place to start...
  16. Alfa 147, 156 & GT
    Hi All, I've diagnosed a faulty rev counter on my 156 Q-System (battery drain!) so now need a replacement. Does anyone have one for sale, or know where I can source one at a reasonable price? Alternatively, just the PCB will do! (Will have to be for the Q-System V6 though) I'm also wondering if...
  17. The Classic Alfa Romeos
    Just been in my car, running well. The rev counter works but seems to read much lower than the engine sound. I pushed the car and I can't get it about 3k rpm. Not the end of the world, ideas pls? Thank you.
  18. Alfa 147, 156 & GT
    Its only happened once, but a couple of days ago it wouldn't go over about 1200 rpm. No warning lights, just no guts in it. I stopped, turned off the engine and re-started and all back to normal, although I have detected a hint of a delay when I press the accelerator peddle. I had a similar...
  19. Alfa 147, 156 & GT
    Ok folks further to a previous post, rev counter stopped working, I thought this could have been due to jump starting it , but it may just be coincidence? The speedo, lights , everything else all still works as should, but after jumping it I've noticed it ain't working? It was ok 2 days ago? I'm...
  20. Alfa 147, 156 & GT
    Hi guys, Occasionally first thing on a cold morning i'd find the car would take a while to crank; i now think this the is glow plugs but that's by the by. I replaced the battery, as it was old, and at the same time took the earth strap, the 2 which goes to the side of the car and the gearbox...
Top