Alfa Romeo Forum banner

radio or nav

  1. Annoying radio/nav display

    Alfa 147, 156 & GT
    Hi everyone. Does anyone out there know how to make the radio/nav display go to wherever it was when i last turned on the ignition, i have to press a button to get it to either the radio info or trip, hope all that makes sense i know its a really petty little thing but its really annoying me...
  2. Rearview camera on original Radio/Nav

    Alfa MiTo
    Recently purchased a Alfa Mito with the original Radio/Nav this one > https://i.ytimg.com/vi/H1knk6Lb-ek/maxresdefault.jpg Because of the small rear window, I'm considering installing a rearview camera. Can this be used with the original Radio/nav? I'm not sure if it has a video input for it...
  3. Radio/Nav Code

    Alfa 159, Brera & 946 Spider
    Had to put in a replacement battery today in my 56 plate 159 2.4 diesel. This has now meant I need to put in the code for the radio/satnav/etc. Unfortunately, I don't have it. Any ideas?
  4. RadioNav in a Giulietta - Anyone got aux in?

    ICE & Blue&Me
    Hi there, Yet another aux in question I'm afraid ! I have a 2010 G, with the integrated RadioNav pop-up SatNav unit, and Blue & Me. It has only the USB socket in the glovebox, no 3.5mm aux-in. I'd really like to add one, however the solution on here to use the Yatour won't work as the RadioNav...
  5. Battery change kills radio/nav

    Alfa 147, 156 & GT
    Just changed the battery on my 156 2.4 JTD SW. The radio worked before and is now dead. 10A fuse in mounted on the radio is OK and an alternative radio works when plugged in. Could the battery change cause the problem? Looking at the radio, there does not look to be much on it that could be...
Top