Alfa Romeo Forum banner

problems

  1. Starting problems

    Alfa 147, 156 & GT
    Hello to all Alfisti! My beloved 156 1.6 is acting weird these days. When cold it starts normally. When hot, if I shut off the engine for , lets say, 10 minutes and then try to start it again, it will crank several times before starting if not at all. Otherwise the car is normal after startup...
  2. alfa 147 jtd acceleration problems

    Alfa 147, 156 & GT
    Hi I am having some issues with my 147 purchased about a month ago. All of a sudden while driving the revs drop to idle and I cant do anything about it. I leave it for 10 minutes and its fine again. Searched the threads in here but couldn't find anything. Happened 4 times so far completely...
  3. Track rod end problems

    Alfa 159, Brera & 946 Spider
    Hello everyone [emoji112] Took car in today for 2 tyres and tracking. Two Avon's fitted very nicely but followed with a chat from the person fitting. He didn't bother doing tracking due to play in the inner tie rods. Thought that was fair enough asked there hourly rate and it was £45 an hour...
  4. Smoke problems

    Alfa 147, 156 & GT
    Hi , the problem on my car is white smoke but not the wholl time . When i go on a freeway and drive a constant speed after around 30km my car starts to smoke alot , white smoke but when i turn of the car and turn it on again it stops smoking and some times whit that smok if i reve it up to...
  5. Clutch problems

    Alfa GTV & 916 Spider
    Does anyone have any clue why this is happening My clutch is sticking and especially when the engine is of Alfa Romeo Spider 916 by 3.0 2002 Clutch has been converted to a solid flywheel and clutch Apparently the rod has been lengthen a tad as per the mechanics experience (see short video) it...
  6. QH thermostat and temp sender problems 2.0 ts

    Alfa GTV & 916 Spider
    Thought this thread may be of interest and I hope to get some experienced comments by return. I acquired another TS GTV and set about sorting some running problems. I had a cold running problem which I fixed by changing the maf and repairing a hidden air intake pipe split. But MultiEcuScan...
  7. Hi, cousin fiat in problems :( transmition/dualogic

    Alfa 147, 156 & GT
    Hello, I am David a mechanical engineer from melbourne Australia, I have a fiat punto 2006 1.4lt dualogic that has an enigmatic issue. I'll try to explain the best and most direct way possible. THE PROBLEM: every time the car changes gears, the car would successfully change the gear (or at...
  8. Few problems when brake

    Alfa MiTo
    Hello I m new to the forums and I have problem in which if you guys help me I d be grateful. I recently bought an Alfa Mito 2012. I realised that when I brake AC stops working, when I release it starts again. When I am holding down the break I can’t turn it on/off, feels like the button is...
  9. Rosso Competizione color mixing and respray problems

    Alfa Giulia
    Hi guys, I'm the onwer of 2016 Giulia QV in Rosso Competizione color. I believe the code of the is 361/B 3-layer coat. Wish to respray some parts on my car, but the paint shop couldn't find the info how to mix the ink and how the layers must be apllied on the car. They spent almost 3 weeks, but...
  10. Electrical problems.

    Alfa MiTo
    Hi Guys. iv posted earlier about a possible problem with my car however after some inspection this has now been cleared up however today iv had the - EBD fault check handbook - power steering fault check handbook. all the while the full dash is flickering on and off intermittently every few...
  11. Throttle potentiometer problems

    Alfa GTV & 916 Spider
    I am having issues with a Phase 1 Twin Spark. The error code coming up is N1 and the wording is Throttle Potentiometer Angle greater than maximum limit. Engine fault code is on and clearing the fault works but comes back when the engine is started. I have cleaned the throttle body and the unit...
  12. Spider Mechanical Fuel Pump Problems

    The Classic Alfa Romeos
    Very sadly "Cinderella" didn't make it to the annual Alfa Ball today near Bicester, due to a fuel feed problem. She had been backfiring a bit for a couple of weeks then we noticed difficulty in keeping her engine running/idling, suggesting that she wasn't getting enough fuel. The fuel level in...
  13. Problems with A/C however no temp reading also

    Alfa Giulietta
    Hiya! This has probably been asked before so apologies, I have read other threads but just wanted clarification. I have a 2015 giulietta which I’ve just bought. The air con is very intermittent with none more often than working however I did notice that at first the temp reading (above the dna...
  14. Alfa 1.4 Giulietta progression problems.

    Alfa Giulietta
    I just bought the car but I have some problems. And I need help to cure them please. 1) The millage keeps flashing. 2) Get this error message on Multiecuscan ( Convergence Telematic Node(L1 and L2) 3) Rear window feedback 4) Wiper rear cam 5) The rear wiper stops at any place when you switch it...
  15. JTS selespeed problems

    Alfa 159, Brera & 946 Spider
    Hi all my local Alfa dealer in Sydney advised me to that the Accumulator on my 2008 159 JTS selespeed was faulty so we changed that. Got the car back and drove it home about 12klms all going well and when down to my garage and in 1st gear it nearly stalled the engine before a clunk and went...
  16. Intermittent ABS problems

    Alfa GTV & 916 Spider
    Morning all, I've been having some issues with my ABS warning and Handbrake warning light coming on in recent weeks. The car is a 2000 V6 Phase II (CF3) Spider. The lights are not always on, I start the car in the morning and can drive normally for a number of hours and they remain off...
  17. Shifter Problems Alfa 159 2.2 litre manual

    Alfa 159, Brera & 946 Spider
    Please disregard, sorted it out.
  18. 159 1.9jdtm turbo problems help please ???

    Alfa 159, Brera & 946 Spider
    I have just recently bought a 159 Ti in red to replace my 147ti in red and having boost issues. Watching the gauge on full throttle it boosts all the way up to 1.5 - 1.6 bar but then drops to 1.0 ish but will try to come back onto full boost but won’t. Had a loose intake pipe onto the turbo but...
  19. GT Stereo Aux Cable problems

    Alfa 147, 156 & GT
    Evening All, I have bought an AUX cable to plug into the back of my stereo however I cannot get it to work. This is the stereo I have AlfaStereo by M F, on Flickr And I have the Aux lead plugged in here (Blue connector) DSC_0597 by M F, on Flickr The Pin out label shows that the "data in"...
  20. Problems with scanning ABS sensor error code

    Alfa 159, Brera & 946 Spider
    I had the ABS, hill holder, stability control lights pop up a couple of weeks ago. I'd bet that it's due to one of the ABS sensors failing after a proper car wash. Tried to figure out which sensor is exactly causing the problem today by connecting MultiEcuScan to the car using a regular cheapo...
Top