Alfa Romeo Forum banner

misfiring

  1. 2.0 ts misfiring and cutting out at idle when cold

    Alfa GTV & 916 Spider
    went to start the car yesterday morning (cold and frosty) and the car wouldnt tick over and threw an engine light. once i had daylight and it had warmed up used MES to read codes P0100 - Air flow meter and P0170 Lambda Sensor integrator. reset codes and the car ran fine just went out to use the...
  2. Another issue with my veloce! Misfiring

    Alfa Giulia
    My Giulia, is going back in late September on business contract hire. As much as I love the car and I do truly do. It is now suffering from misfiring! It's been into the dealership already with a software update, but this has not solved the issue. It happens on start up from cold. Sometimes...
  3. Cylinders #2 and #3 misfiring on S3 Spider

    The Classic Alfa Romeos
    Have had this Alfa for several years and only put a couple of thousand miles on it annually. Sometimes it starts a bit rough but always runs well after warming up for 1-2 minutes. A few days ago it started very rough and warming up did not help. It runs but not with enough power to really drive...
  4. S2 Spider Misfiring on light throttle

    The Classic Alfa Romeos
    At lower revs 1800 the spider was a bit hesitant - thought I wasn't going to make it home. Seemed OK if I ragged it though. Any ideas? Thanks
  5. GT 2.0 JTS misfiring

    Alfa 147, 156 & GT
    Hi all, My GT is misfiring in cylinder 4. I’ve replaced the coil pack and all 4 spark plugs but no joy. The motor system failure keeps coming up on my dash too. I was wondering if it could be an injector problem or wiring? Would it be worth trying injector cleaner before a replacement as...
  6. Engine misfiring on motorway?

    Alfa 159, Brera & 946 Spider
    Hello out there, My 159 2.4 JTDM has recently started to misfire and you get the feeling its dragging aswell(lacking power), mainly on the motorway at around 2 -2.5k rev range. If you floor it it will pick up again, but then start again when settled down. Sometimes after a short spell it...
  7. Spluttering/ Misfiring, Loss of Power, Cutout at Idle

    Alfa 75, RZ, SZ
    My 1988 Alfa Romeo 75 3.0 V6 hasn’t been running for around 5 years and we’re struggling to get it working. It starts first time and runs. However, it sometimes runs rough at idle (more often when cold) and cuts out, with a simultanous rattle from around the back of the car as the revs are...
  8. Cylinders 2 and 4 misfire

    Alfa Giulietta
    My son’s Giulietta (multi-air lusso TB 1.4 petrol) broke down at relatives on New Year’s day; running very rough with engine light on. RAC diagnosis initially was “suspect coil” because of following fault codes. DTC: P0304,Ignition malfunction cylinder 4 DTC: P0300,Ignition faulty DTC...
  9. Alfa Romeo Giulietta 2.0 jtd tcp misfiring in the cold

    Alfa Giulietta
    Evening enthusiasts! This morning was freezing and my beautiful G started acting strange! Whist pulling off at a junction it started misfiring for 100 meters or so then went back to normal! There was no engine warning light displayed. Does anybody know what the problem could be? Thanks in...
  10. Help!! V6 Brera misfiring and power loss

    Alfa 159, Brera & 946 Spider
    Hi everyone I hope you can help me!! I'm having an issue with my Brera When doing long trips, after about an hour or so, the engine misfires, the power drops, and the engine starts to cough and splutter with the light flashing on If I pull over to the side of the road, stop the car and...
  11. 3.0 V6 misfiring on overrun

    Alfa GTV & 916 Spider
    Hi Guys !:jester: Thanks for your time for reading this. I've been stuck on a problem lately as my GTV misfires under overrrun (at arround 2200 RPM and below ) Its more pronounced when it's cold.. My Car is 1997 PHASE 1 3.0 v6 24v ( with throttle cable ) I've got a lot fixed already, but I...
  12. Misfiring on cylinder 3&4 2000 156 TS manual

    Alfa 147, 156 & GT
    Hi everyone, wonder if anyone can help. I have a 2000 156 TS manual. I've only had it for about 3 months and it has run like a dream. Recently it's started misfiring on cylinder 3&4. Just wanting recommendations on what to check first as there's no warning lights on so I'm thinking it can't be...
  13. misfiring

    Alfa 164 & 166
    On Saturday I gave the engine and under bonnet area a loverley de-grease and clean up.. Didn't rinse with high pressure or anything like that, just a trickle from hose. Anyway, took a trip to Horsham on Sunday (150 miles round trip), car ran fine. Then went out to George and Dragon about half...
  14. P0141 and some misfiring

    Alfa 147, 156 & GT
    Hi, I have a 2002 156 1.8TS The fault code P0141 (O2 Lambda Sensor Heating Circuit) keeps coming on. I reset it a few times with the OBD2 , but it comes back after about 2 days or 50km. P0136 fault code came on once as well.(Same sensor) I have changed the MAF sensor, and there are no vacuum...
  15. 1.9 jtd 16v 'misfiring' when cold on occasion

    Alfa 147, 156 & GT
    Hi Guys, sometimes on cold engine my 1/9 jtd 16v seems to 'misfire' somewhat when demanding power / during 'sudden' acceleration. The fuel supply seems to be cut off itermittendly (engine starts to shake / shutter). I do have a scan tool but an heads-up would be great :inlove: p.s. I already...
  16. Sounded like a misfiring old tractor on start up!!!!!

    Alfa 159, Brera & 946 Spider
    Hi There, Twice over the past 8 months I have had the same problem when starting my 1.9 Ti Sprotwagon (58 plate), diesel. I insert key and press the button, the engine starts but sounds like it is only firing on 2 cylinders. The car vibrates and sounds awful thumping and shaking. I press the...
  17. 2003 156 2.0 JTS Misfiring

    Alfa 147, 156 & GT
    Hello, This is my first post here, though i have been lurking here for a while reading all the jts misfire threads to try and find the cause of mine. I have a facelift 156 2.0 JTS Lusso, it misfires while idling and when you give it some power but slowly building the revs after 2000rpm it's...
  18. 159 TI 1.9jtdm 16v misfiring

    Alfa 159, Brera & 946 Spider
    Hi guys, I'm new to this website after purchasing my alfa 159 TI 2009 I've just had a full service and cambelt change on it after purchasing it last week, but car has been misfiring since I purchased it. It has done 141,700 miles and I thought service might cure it, it misfires on pick up in...
  19. Alfa 147 1.6 TS Misfiring

    Alfa 147, 156 & GT
    I have an alfa 147 giving me misfiring problems in cylinder 4 i can not seem to figure out where the problem is coming from, i have replaced the coil for that cylinder,checked spark plugs all is fine but still not firing. I have given up on trying to figure out the problem and I am just...
  20. TS misfiring following fuel run out

    Alfa GTV & 916 Spider
    unfortunately got caught out and ran dry again - misfiring, clearing, misfiring..... where is most likely area for fuel debris to gather to cause above? - Last time it did clear, however if convenient would like to take a look (ie accessible filter)
Top