Alfa Romeo Forum banner
misfires
21-26 of 26 Results
  1. Alfa 147, 156 & GT
    About two weeks ago now my cam belt went on my alfa 156, 1.8ts, 52 plate, after lots of calls to garages and getting quoted silly prices, i then decided to buy a second hand engine from a scrap yard. Me and my brother fitted the engine and it runs, but, the engine management light stays on...
  2. Engines (TS, JTS, JTD & V6)
    Hi all. Looks like a good frorum here guys and girls! i wonder if you can help this newbie out...! I own a 1999 3.0 GTV and today i washed my car. I have just gone out to start it and it starts but will not rev over 2000rpm and it is misfiring all over the shop. I do remember getting some...
  3. Alfa GTV & 916 Spider
    Hello anyone!!!!! I need some help, My GTV has started misfiring yesterday and all day today, only happens at low revs once you get to about 3.5k everything kicks in and away we go!!! any thoughts on why this might be happening i read some place that could be spark plugs? any help would be...
  4. Engines (TS, JTS, JTD & V6)
    Hi all, Sorry for annoying once more, My Alfa 164 Super 3.0 24V has just had its Injectors professionally cleaned and its Timing Belt Replaced. However just after taking the car back home I started to feel a certain knock or hesitation like a misfire. It got so bad that after a while I...
  5. Alfa 75, RZ, SZ
    Hello again.My 75 t.s does the following annoying thing.About a month ago,when the car was running perfctly fine,it started to misfire.....As i accelerated ,suddenly the car would slow down and then start working fine again...The mechanic changed the spark plugs...The car went fine for a couple...
  6. Alfa 147, 156 & GT
    Hi, I'm new to Alfas and this site so bear with me. Through web research I knew about the problems these cars suffer from before i bought it, but after a test drive they didn't put me off! It's a 2000 2.0 manual with clim control and 68k miles. Some days it is fine, smooth with no misfires...
21-26 of 26 Results
Top