Alfa Romeo Forum banner

misfires

  1. 156 JTS misfires, coils P0351

    Alfa 147, 156 & GT
    My 156 is giving me the runaround… Has had odd MSCF errors - seemed to be transient fault on coil 4 (P0354) Then it threw fatal coil failure P0301 on cylinder 1, along with P300 (Generic misfire) & P0430 (Cat 2) - I assume the latter two make sense with a coil failure. To check it really was...
  2. engine misfires P0302 P0300

    Alfa MiTo
    Hi All, Have a problem with my mito. Yesterday on the way back from work my mito started to run rough and it disconnected dynamic and start stop. it started to run on 3 cylinders i think. Read codes and I get P0302 and P0300 engine misfires on cylinder 2 and random misfire. Replaced all spark...
  3. Misfires - 2004 2.0 TS

    Alfa 164 & 166
    Hi, 2004 facelift 166 2.0 TS hasn't been running well in recent months. Symptoms started out as low power/stuttering when cold. However, when the engine warmed up, it ran well. It has got a lot worse over the past week with the car running badly all the time. A scan showed misfires on two...
  4. 3.2 V6 Multiple cylinder misfires

    Alfa 159, Brera & 946 Spider
    I have a 3.2, 90k miles, threw a misfire cylinder 1 error (and it was noticeably misfiring). Took it in and had a coil replaced (I had one burn out last year), threw the same, Spark plug and injector have been replaced and it's cleared and now there is misfires on 2, 3 and 6 along with a...
  5. 156 v6 slightly misfires on idle

    Alfa 147, 156 & GT
    SOLVED ! 156 v6 slightly misfires on idle Hi guys. Recenlty i've encountered a problem with my v6. Fuel consumption went up, idle is kinda erratic and you can hear the engine slightly misfires.. This happens mostly when the car is hot, otherwise it pulls well and runs good. I guess it's...
  6. Fault code - misfires

    Alfa GTA
    Had a few issues lately where car didn't quite sound right on tickover, sounded a bit rough, and occasionaly mcsf would flash on and off. Then more recently mcsf came up and stayed on. Multiecuscan gave the following errors (see next post for picture).... P1135 - states this is 'fatal'...
  7. GTV CF2 V6 Misfires

    Alfa GTV & 916 Spider
    Hello, Advice please. Went to start my GTV but battery flat. Recharged battery and reset the alarm which off course went haywire when reconnected battery. Started car with no issues and idled for a few minutes. Went to increase rpm and engine will rev to 1500-1800rpm but then misfires very badly...
  8. GTV 3,0 V6 misfires

    Alfa GTV & 916 Spider
    Hi Alfaowners, I have a little problem with my GTV. A couple of months ago I decided to give my GTV a refurbishment. So the car was disassembled for painting and I dismounted the rocker covers, intake manifold and had them painted too. I changed the spark plugs at the same time. (think the back...
  9. TS misfires after warming slightly from cold

    Alfa GTV & 916 Spider
    problem just suddenly started - seems fine when you first drive for ten mins then starts to go flat with a misfire any similar experiences? - Not sure but thought had similar before when i wash it pouring water down screen into engine bay?
  10. engine ecu reporting misfires

    Alfa 147, 156 & GT
    have an issue with ecu reporting misfires on cylinders 3 and 4 but i cant feel or hear the misfires only fitted new plugs last week do you think its correct plug wells where dry oil free etc new plugs seems ok under throttle conditions any ideas
  11. Multiple misfires

    Alfa 147, 156 & GT
    Hi guys, You may re call: 2004 2.0 JTS.4 Charged battery off car.Engine control failure before xmas.Looking for fault.Local read it as multiple misfires.Local changed all 4 plugs and now if that fails change all 4 coil packs. Misfire fault returned after 200 miles.How much should I pay for...
  12. brera 1750tbi misfires

    Alfa 159, Brera & 946 Spider
    Hello to all the community here :) i own a '10 alfa brera tbi with aboutt 100.000 km on the clock , i have gone with custom ecu remap and custom full exhaust , also put a free flow filter in the stock box . The man who remaped the car has changed the revlimiter fro 6050 to 6600 the pressure...
  13. After Red line car misfires badly

    Alfa GTV & 916 Spider
    hi everyone my 3.0 V6 seems to have a problem that only happens if I push the car to red line if i only rev to 4000rpm there is no issue but if i go beyond to 6000 the car will start to chug and miss fire badly and then I straggle to get to 40mph, there are no error lights on the dash that...
  14. GT & misfires cil.2 :(

    Alfa 147, 156 & GT
    Hello :) I'm new to your forum and can not get by with the best English language .. If I missed some rules let new members send me some :) Thus I present my problem for which you are all mostly heard ..I have a Misfire cyl. 2 and occasionally on CIL. 4 .. I did: - Clean injectors- Checked coil...
  15. Alfa 166 3.0 - Serious misfire

    Alfa 164 & 166
    Hi Alfa owners Hope someone can assist : my alfa suffers serious misfire, exploding noise from exhaust is so frequent. The car now has no power and struggling on uphill road. I have replaced mass-flow sensor, spark-plugs but things are getting worst now. A mechanic used diagnostic system and...
  16. Timing Belt and tensioner replaced - now multiple misfires?

    Alfa 147, 156 & GT
    Hi all, Timing belt + water pump was replaced 6 months ago (customer supplied the parts, no tensioner) the tensioner gave way and belt was about to slip off but luckily all timing marks still lined up so fitted a new tensioner and belt. Fired her up and now bringing up motor control system...
  17. GTV Misfires when warm!

    Alfa GTV & 916 Spider
    Hi I've got an Alfa GTV TS , which apart from the usual maintenance has been fine , Its a great car, I love it. However it has been parked up for a few months and putting it back on the road she was fine ........................for the first 5-10 mins. Then the car misfired badly , It isn't the...
  18. Engine misfires 156 JTS

    Alfa 147, 156 & GT
    Ive had occassional cylinder misfires (diagnosed by my Sealey EOBD) over the last couple of months. Engine hesitates for about 2 secs, warning appears and then engine runs fine. Car has done 115k but well looked after. I guess ignition coils need replacing. However does a good spray of WD40...
  19. 156 JTS misfires and cuts out ?

    Alfa 147, 156 & GT
    156 JTS misfires and cuts out - SOLVED!! *** SOLVED - check thread **** Hi guys, Need help on this one… My 2005 156 JTS misfires and cuts out at moderate acceleration and the notorious Engine failure message comes on. Problem is not consistent, sometimes everything is fine. Make a quick stop...
  20. 156 2.5 V6 misfires in the morning

    Alfa 147, 156 & GT
    Hi all, my 156 2.5 v6 recently started misfiring every morning it does this for aprox 15min then it gradually returns to normal, I tried unplugging the MAF this morning but that seemed to make it even worse, any ideas anyone??
Top