Alfa Romeo Forum banner
misfire
1-20 of 337 Results
Advanced
  1. Alfa MiTo
    I have a misfire on cylinder 3. had theAA out today, as car was misfiring and lacking power. After checking Plugs, coils (moving around) he confirmed issue with Cylinder 3 question is. Where in Sheffield can I take car to that will know what they are doing and not cost me a fortune. A garage...
  2. Engines (TS, JTS, JTD & V6)
    Hi all, I'm new here but I've been lurking for a while. I've recently become the proud owner of a facelifted Alfa 166 fitted with the venerable 3.2 unit. I bought the car as a laugh as it has over 300 000 miles on it (on its second engine, but original 'box) and zero rust. One of the previous...
  3. Alfa 159, Brera & Spider
    Hi everyone! Can you please help me pick the right injectors for my 159 1.9 JTS? This is a complete nightmare for me at this point as I've been looking for an answer for weeks... Here's what I know so far: One of mine failed (as they usually do at a certain point) and I want to replace the...
  4. Alfa 164 & 166
    Hello everyone! Now before i start taking the engine apart, plase have a look at this: I got this 2003 2.5 V6 petrol Alfa 166 for free and i'm trying to bring it back to working order since it looks so damn good on the inside and outside. Its been sitting for a while, and i've found a rat's nest...
  5. Alfa 147, 156 & GT
    Greetings everyone, this is my first time posting but this forum has already helped me fix the umpteen issues that have come up in my two year adventure in owning an Alfa. I've got an '08 147 1.6 TS that recently passed the 60k mark. A couple of months back I found a water leak was coming from...
  6. Alfa 164 & 166
    hi, after fitting a new crank sensor, everything seemed ok, but the engine misfires pretty bad when on the move, only when up to running temperature though? but never cuts out and idles fine., although the sensor was bought for a 164 3.0 24v , could it be that it's the wrong one? does anyone...
  7. Alfa 147, 156 & GT
    Hello, I've a 2.0 JTS GT 2004 since beggining of 2018. I've made 25000 Km with it. I've decided to clean up the head so it was taken off the car, cleaned (admission + valves), valves seals etc. I took off all 4 injectors and the ramp and took it to a specialist for check and refurbishing. Now...
  8. Alfa GTA
    I've been experiencing an intermittent misfire of sorts for the past few months now, but as the car has only just come back from its winter break I want to get it sorted. It only ever happens at high revs, just as I'm about to change gear at full chat between 1st-2nd or 2nd-3rd. It feels like...
  9. Alfa GTA
    Hey guys haven’t been on for a while but just as I was to begin getting my gta back on the road getting misfire. Some background the car has been off the road for a while but have been giving it a little drive now and then, thinking of the problem now I do remember feeling a very slight misfire...
  10. Alfa 159, Brera & Spider
    Hi and many thanks to all who contribute to the forum. Having been a 'lurker' on here for a while and gained many useful insights as how to solve the many problems I have had with my various Alfas over the years, I am stumped with a problem on my Brera. I purchased the car blind on ebay and was...
  11. Alfa GTV & 916 Spider
    Hi guys my v6 is punishing me for leaver her parked up for 6 months, I started her up the other day and after a few seconds she counked out, started her back up again after a few attempts and now sounds really rough I think it’s misfiring, if I try and drive it..... the car just conks out. So...
  12. Alfa Giulietta
    2012 Giulietta Multiair with software. Car has 100 000 miles on the clock. I've been having a strange issue the past few months. Occasionally under load in mostly 2nd, 4th or 6th gear, the car will cut power and bog down. After a second or so it drives as normal, albeit with the Stop/Start...
  13. Alfa 159, Brera & Spider
    Hi, I am having an issue with my 2.2 Brera, I have my ECL on, differeintiating between flashing and on constant, It is misfiring both on idle & under acceleration and is becoming quite annoying now as i cannot find the issue! I have replaced Spark plugs, coil pack & Battery, i also had my...
  14. Alfa Giulietta
    Hello all, have a problem with my Giulietta QV. Fitted a new downpipe without a cat. Went on the motorway then all of a sudden engine light and no power. Managed to get it home after being safely guided off the motorway by the RAC. Only code that have come up are the p0300 - p0304 codes for all...
  15. Alfa 164 & 166
    My starter motor didn’t engage/turn the engine. Pulled right front wheel, inner wheel arch and rotated the engine a fraction by the lower main timing belt wheel. Now starter motor engaged, engine started hesitantly and have been idling rough since that. Error shows misfire on 4, 5 and 6. Can...
  16. Alfa GTV & 916 Spider
    My v6 seems to have developed a hesitation at idle, almost sounds like a little cough and when cruising at low rpm you can feel it stuttering. Also think my thermostat is knackered as it constantly reads 0 but creeps up slightly in traffic. Don’t know if that’s related Going by the book it had...
  17. Alfa 147, 156 & GT
    Just returned home from abroad to my beloved Alfa 156 JTS 2.0 and found myself having some issues. - Engine light comes up every 3rd start after deleting them, codes are P0161 and P1161. They have been there for some time now, not sure if it's related to the other issues. - The car hesitates...
  18. Alfa MiTo
    I've put the one fault reader on the car and it comes up P0304 cylinder 4 Misfire, I know all the things it could be. But has anyone else had this problem with a common remedy
  19. Alfa 159, Brera & Spider
    I have had my 159 TBI for nearly a month now and it's had a couple of niggley issues to sort out. The most annoying issue for me is a misfire/lumpyness that occurs up to about 2500 rpm. The car was purchased having just been fully serviced, cambelt replaced and spark plugs changed. Initially...
  20. Alfa 159, Brera & Spider
    Hi all, I wanted to share information on the fixes I've discovered relating to the problems I've had over the last few months with my Alfa. The first issue was a misfire which caused poor idling on startup, poor MPG and very slow acceleration due to loss of power. Diagnostic codes related to...
1-20 of 337 Results
Top