Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-19 of 32 Results
  1. Alfa 147, 156 & GT
    Bugger. Driving in heavy, stop/start, traffic on the motorway last week our 1998 V6 156 just cut out - I hadn't noticed but the temp gauge had gone off scale. I assume that there is an ECU function that cuts the engine if it gets stupid hot. Turns out one of the heater hoses had sprung a leak...
  2. Alfa Giulietta
    Hello, I hope you may be able to help. We have an 11plate giulietta 1.4 muitair with 35k on the clock and full main dealer history. 3 days ago my partner was driving to work and was about 4-5 mins into her journey, when the car started to misfire. As she continued (she was only 3-4 mins from...
  3. General Motoring Discussion
    This poor guy lost his Scuderia an hour after pickup, Police say he wasn't speeding, what a mess. Ferrari crash: Newly-bought supercar gone in 60 minutes - CNN.com
  4. Alfa GTV & 916 Spider
    Owned the car for nearly a year now and this is the first time it wouldn't start. Left car at work today and started fine when I returned 6-7 hours later, drove 5 minutes to a garage and switched ignition off then when I went back it wouldn't start (or sound like it would turnover) for 10...
  5. General Motoring Discussion
    Before giving a ticket to illegally parked vehicles in england.... Wonder if they will continue to hide around the corner and pop a ticket on your windscreen as before....10mins gives them time to eat a pie while they wait :p
  6. Alfa GTV & 916 Spider
    runs fine when you set off then heavy misfire starts after 20 mins or so and has little pulling power, still with momentary bursts of perfect running ( odd second or two) Usually fine when you go back and drive later and may be 90 to 100 percent ok until after 20 mins or so have a fuel smell...
  7. Alfa GTA
    Guys n gals a little help reqiired, the GT V6 isnt getting much running at the moment, once a week or so when the elise doesnt hawve enough seats, and when I first start her up the first few mins of driving on the estate is hellish kangerooey. Basically no codes or lights, part throttle low...
  8. Alfa 147, 156 & GT
    Just recently bought a 147 1.6 lusso and the sterio only comes on when it actually feels ready, usually about 4 or 5 mins into a journey. I dont touch it, it just comes on when ready. If I put just the ignition on then the radio usually comes on straight away. I did notice yesterday that the...
  9. General Alfa Discussion
    Reckon a big tub of Isoflex here on day and I could have made a fortune......Where did the guy get the background music? ......defo a Jag and a Peugeot in video that think they are GT's ....has to be the worst videography ever and might put you off Gt's forever....please don't let your children...
  10. 147

    Scottish Italian Car 2004. Craigtoun Park St Andrews Fife.
  11. Alfa 147, 156 & GT
    Zender body kit on ebay....... Be quick http://www.ebay.co.uk/itm/170702488185?ssPageName=STRK:MEWAX:IT&_trksid=p3984.m1438.l2649&autorefresh=true
  12. Alfa 159, Brera & Spider
    Hi guys. Last week I had an issue where the brakes appeared to fail for the first couple of minutes of my journey. After a couple of minutes it seemed as if they had "warmed up" and were back to normal. This happened every morning for four days, but bizarrely it is all fine now..>!! The...
  13. Alfa 147, 156 & GT
    As above. Is this indicative of a gearbox on the way out, one that needs more oil in the box or the clutch is going and needs replacing? When I say hard to get into gear I mean literally won't go in unless engine is off - it will grind if I try to push it into gear. If I start in gear with...
  14. Alfa GTV & 916 Spider
    Morning all, Can l pick your brains (AGAIN) my blowers come on only after running for 5 mins?! So when l 1st jump in the car l have to use a dimister cloth till the blowers decide to work. Any onesle had over come this problem?! Many Thanks.
  15. Alfa 147, 156 & GT
    hi all, i need help, my alfa 156 2.0 tspark on a 02 plate, has been great, then on friday it cut out and would not start again and 10 mins later started again and drove fine without any management lights. it has done the same again twice today and always cuts out on a busy lights junction...
  16. Alfa GTV & 916 Spider
    http://cgi.ebay.co.uk/ws/eBayISAPI.dll?ViewItem&item=180416471536&ssPageName=STRK:MEDWX:IT I have been offered this for a very low price.No burgendy key,but how much would you say its worth??i have 30 mins to decide.Any input wanted:eek:
  17. Alfa 147, 156 & GT
    Hi i drove to morisons today only a 10 minute drive, did a little shopping and then tryed to start the car. It just turned over and would not fire. I thought it would be a fule pump fuse so i swappped it around with another in the engine bay, this did not work, i swapped again and after a few...
  18. ICE & Blue&Me
    As above, my 156 (2001) has always had a aftermarket headunit, I recently purchased a original Alfa radio/cassette headunit and fitted it. All works fine except................... ......after 20ish minutes the headunit switches off, now I appreciate its not the end of the world but it is...
  19. Alfa 147, 156 & GT
    strange? perhaps coil? you can rev through it hard though? only when it starts to get warm
1-19 of 32 Results
Top