Alfa Romeo Forum banner

loss

  1. Loss of power but no warning lights

    Alfa Giulia
    Yesterday the car suffered a significant loss of power. Started up cold and immediately when pulling away it just wouldn't pull. Not like limp mode but there was a definite loss of power. It initially sounded like it had dropped a cylinder, quite a gruff noise but that cleared. Anyway this...
  2. 2.2 Coolant Loss

    Alfa 159, Brera & 946 Spider
    My 2.2 Brera S has lost a little coolant over the last couple of weeks - still just above the minimum line and not a huge amount, but a definite drop. I’ve already had both bleed screws replaced with metal screws/screw housing (brain isn’t functioning, I’m sure there’s a proper word). Cannot...
  3. 2.0TS loss of power

    Alfa GTV & 916 Spider
    I've got a 1996 GTV with the CF1 2.0TS engine. It's developed an issue where it loses power when it gets up to operating temperature. When it's cold, it accelerates fine, but once the engine is warmed up, it loses power. Eventually in 1st gear it takes 4-5 seconds to reach 6k rpm. Foot to...
  4. Scary Loss of Power

    Alfa Giulia
    A weird and scary thing happened to me the other day... Cold morning, just set off from home and waiting to pull out on to a busy 'A' road. Saw a gap in the traffic and endeavored to pull out - No Power!! Car crawled to the centre of the road with cars bearing down on me Engine still running but...
  5. Loss of power

    Alfa 159, Brera & 946 Spider
    Hi all. I was driving this morning into work and my 159 2.4 JTDm decided to go into what felt like limp home for about 20 seconds. The same thing happened this evening pulling away from some lights. Any ideas would be appreciated I do have a P0111 fault (AIT issue) that I'm waiting on a MAF...
  6. Power loss on motorway

    Alfa 159, Brera & 946 Spider
    Yesterday I drove to Prescott for the hill climb ,a two hr mostly motorway run , my 07 1.9 diesel as usual ran beautifully cruising at about 80 . On the way home all was well for the first 5 miles or so until I felt a little hesitation while traveling at about 40 mph it only lasted a couple of...
  7. power loss

    Alfa 147, 156 & GT
    Hi all, My 156 2.o twin spark (1999) occasionally suffers a brief but complete power loss. This always happens whilst accelerating from lowish speed. It lasts a few seconds and the injector light comes on, then the power comes back as normal. Local Alfa specialist (Alfanet) has had a look but...
  8. Memory loss

    Alfa 159, Brera & 946 Spider
    Need to by a new wrench tomorrow for the Accessory Belt Tensioner Release on the 159 2.4 JTDm and for the life of me can't remember what size it is. Anyone got a better memory than myself?
  9. Alfa 159 Ti - Short power loss

    Alfa 159, Brera & 946 Spider
    Hello all, strange problem so apologies for the long post.... Car is a 2009 159 Ti, 1.9 Jtdm 16v on 140., I've owned it for around 6 months, did the cambelt and waterpump and soon as I got it, I also cahnged teh MAP sensor and cleaned the MAF. The previous owner has removed the dpf, fully...
  10. 159 ti 2008 juddering and loss of power

    Alfa 159, Brera & 946 Spider
    Hi I bought 08 159 ti 4 weeks before and drove fantastic. Then last week i experienced juddering and loss of power and she didnt respond to accelrater and was getting power over 2000 rev when i first started my car and was fixed itself after 1 minute. Then after 2 days when i was driving in...
  11. Coolant Loss

    Alfa MiTo
    LizR arrived home tonight with steam behind her and a temperature gauge reading 120. There was no coolant visible in the tank. I waited and topped up - steam and massive coolant loss. Looking at the engine from the front the loss is on the right hand side and below where the coolant hose goes...
  12. Sudden loss of all power on 1.9 diesel... and then it fixed itself

    Alfa 159, Brera & 946 Spider
    Hi Yesterday I had an odd thing happen to me while driving. At about 70km/h, I got a check engine light come on. Then moments later, I lost all power. The car didn't rev correctly, and couldn't maintain its speed. While coasting to the side of the road, engine cut off, I lost power steering...
  13. 2.4 power loss is defeating me

    Alfa 159, Brera & 946 Spider
    A plea for guidance. 2008 on a 57 2.4 which has done 70K miles. Started getting episodes of total power loss when pulling away, nothing at all whilst the revs built painfully towards 2,500 then woosh, off she went. That happened very occassionally. Fast forward to the last few weeks and that...
  14. Coolant loss update....

    Alfa 159, Brera & 946 Spider
    Well the replacement pressure tester arrived. Pressurised the system tonight and its definitely losing pressure. No external leaks and I checked for internal leaks from the EGR cooler none.... Put it all back together and it hydrauliced. Fortunately these must have a cut out as the starter...
  15. BMW making a loss.

    General Motoring Discussion
    “The automaker reported its first loss in a decade in the main automotive division in the three month through March, after booking a 1.4 billion euro provision ($1.6 billion) for potential European Union fines over collusion. Even excluding this charge, the unit's return on sales dropped to the...
  16. Coolant loss is doing my head in!

    Alfa 159, Brera & 946 Spider
    Ever since I've owned my 159 1.9 JTDM it's been slowly losing coolant. So far I've traced and eliminated a couple of small leaks and recently replaced the header tank and cap as I was unsure about it. It's still slowly loosing coolant. I've checked everywhere I can think of for leaks but...
  17. Loss of power

    Alfa 159, Brera & 946 Spider
    Hi all, hoping for a bit of help. Recently I've had loss of power at low revs and the engine stutters. Turbo seems to boost normally on the gauge but the power isn't there? 2.4 JTDm 200bhp TIA
  18. Loss of power and gear change arrows

    Alfa Giulietta
    Hi, As the title suggests, I have a strange problem with my Giulietta. It’s a 2011 jtdm 140. The issue I’m having is quite strange. The car pulls and drives well, but occasionally, the gear change arrows stop working and the car looses power. It’s not in limp mode and there are no codes on the...
  19. Changed my exhaust - power loss?

    Alfa Giulietta
    I recently changed my 1.4 MA downpipe due to the old one being built improperly. I had a 76mm downpipe leading into a 63mm midpipe and then into the stock exhaust from the centre resonator. Car ran well, no issues. The downpipe broke off on a weld recently and I had a new pipe built. To save...
  20. Loss of RPM and smoke at the head

    Alfa 147, 156 & GT
    Hi guys, your help please. I have received the cylinder head back from the engineering and fitted everything. I started the engine but after a about 2 minutes the engine started loosing power and smoke started to appear from between the head and the exhaust manufault. I switched the car off and...
Top