Alfa Romeo Forum banner

losing

  1. losing coolant

    Alfa 147, 156 & GT
    Hi, The coolant level on my 156 TS has been going down quite often lately, sometimes as much as from Max to Min level from only an hour of driving. This is the 4th time this has happened, twice on the original engine and once on the current engine, every other time a couple of weeks went by and...
  2. losing coolant-only in winter?

    Alfa 159, Brera & 946 Spider
    For quite a while I've noticed my coolant level drops,up to a couple of cm in a couple of weeks, it seems to be only sometimes though, I've come to the conclusion that when I'm using the heater more the level drops more. Last summer for example it hardly lost anything. There are no obvious signs...
  3. Losing coolant very quickly!

    Alfa GTV & 916 Spider
    This may seem odd but on my gtv cup I’ve been having issues with the heater not working sometimes. I was out a drive and the heater was working at first but quickly ran cold. My temperature gauge sat at 80ish driving normal and the fan came on when it reached 100 as it should. After I got home...
  4. Losing oil?!

    Alfa 159, Brera & 946 Spider
    So normally I don't need to touch the oil for about 10k ( and then only need half Ltr), however recently it's started to drop a bit more quickly, having had to fill it the baseline on the dipstick, it's now down 2-3 bars on the display ( and down 40% of the dip stick) in around 1-2k. Looked...
  5. Losing the faith...

    The Classic Alfa Romeos
    My S2 has refused to run properly all summer - the fuel seems to run back to the tank and the electric fuel pump - brand new - cannot pull the fuel out of the 2\3 full tank. If I get underneath and manually pump the fuel to the pump, it's fine. The problem is that when I start the car it fires...
  6. Seem to be losing coolant in my Brera?

    Alfa 159, Brera & 946 Spider
    Looks like the beginning of my Alfa ownership journey... When I first picked up my Brera a week ago, I'm pretty sure the coolant was upto max level. I drove around 500 miles since. Now my coolant is below the min level. Sometimes the Brera lets off white smoke from the exhause on start up which...
  7. NSF Damage after losing a wheel on Motorway

    Alfa 159, Brera & 946 Spider
    Unfortunately for me a couple of weeks ago, the passenger side front wheel of my 159 ti came off my car on the M5 motorway - thankfully nobody else was involved and nobody got injured. I've been left with the dilemma of fixing my car now - after having it recovered to a garage and having the...
  8. seem to be losing coolant

    Alfa 159, Brera & 946 Spider
    Hi All, I have a 159 2.4 qtronic SW. Couple of weeks ago the bleed valve on the water pipe running across the front of the engine disintegrated and rapidly emptied my coolant all over my engine bay in a comical spray. I noticed because the fan seemed to be on alot so had a nosey around and my...
  9. Losing oil alfa gt 1.9 jtdm

    Alfa 147, 156 & GT
    I start today to lose oil in front corner driver side . A rubber something. any ideas !?
  10. GT losing a little coolant

    Alfa 147, 156 & GT
    My daughters petrol JTS is losing a little coolant. Not much and I'm not too worried as water is cheap like my old man used to tell me. I fitted her a new thermostat when she got it as the old one was kaput and it was all good for a few months. It's eleven years old so I'm guessing that the rad...
  11. Losing front/back end

    Alfa 147, 156 & GT
    Over the last few weeks I've noticed when going round corners, my wheels are losing control and skidding. I've got brand new tyres and they're inflated correctly. Can there be an underlying problem with the steering etc? Has anyone come across this? I'm not travelling fast and it's a worry...
  12. Losing brake fluid - clutch slave cylinder???

    Alfa 147, 156 & GT
    Hey All, Hopefully someone can give their opinion here as to what might be happening. I have an '06 156 1.6 (running fine on LPG). On cornering, normally, the low brake fluid warning alarm has begun to come on. Checked and the reservoir is low - but not dangerously! Car is running fine so...
  13. Is AO losing its Appeal?

    Alfa 164 & 166
    Hi All, Just thought i would ask, There doesn't appear to be lot being said at the moment, Is AO losing it's appeal? I'm on the AlfaOwners Facebook page and that is non stop. I hope AO isn't losing its appeal as it gives out some great info. :-(
  14. Speakers Losing Bass Intermittendly

    The Technology Section
    As above.....every now and again on my TV stereo sound system i lose bass and either have to turn the power on and off or else turn the volume way up to get the bass back. My question...must be a simple fix....what connection is going wrong ?? Thanks Ronan
  15. 3.2GTA losing coolant

    Alfa GTA
    my windows are misting up inside and I'm losing coolant - presumably from heater matrix?? I'm told its a big job to replace on the 3.2 GTA Sportswagon, can anyone advise?
  16. Losing my mind! Help me on decide to buy or not this beatiful 166

    General Alfa Discussion
    Finally, bought the 166 (updated) Edit: Start on post #11 I've been searching for a nice Alfa since I killed my beloved 156. Most of what I find are too expensive, too trashed paint / damaged / horrific tuning mods, or too basic (i.e hubcaps and crappy cloth seats). I never really liked the...
  17. Twinspark keeps losing power 24 hrs after washing car

    Alfa 147, 156 & GT
    Hi got a 2000 1.8 SW - after I wash it can jump in the car and runs fine. A day later loses power, revs, power steering, engines stops etc. restart and it happens again about 10 times in a row. Not sure if keeping high revs cures it or not. Feels like it does but might be just me. Happened...
  18. Turbo losing boost in 4th at high RPM

    South Africa
    I noticed something weird today. I was in D and was pushing my G for a bit of fun and down a long straight I held it in 4th and let the revs climb. At around 4,500 RPM I noticed the boost meter showing a loss of boost (I could hear it too). On the boost meter it drops down by 2-3 bars. I'm not...
  19. 147 losing oil! (I'm new, please bare with me!)

    Alfa 147, 156 & GT
    Hi, so I know there's tonnes of stuff on here about the common Alfa niggles and I know oil loss can be one.. It seemed that my sump plug on my 147 2.0 lusso had worn so I was getting drops on the driveway right above the sump. Now my problem is, after the oil pressure light came on and I left...
  20. Brera suspension woes....HELP im losing it

    Alfa 159, Brera & 946 Spider
    So my 2.2 jts has squeaks and clunks, so my investigations led me to replace the following all in the last couple months. 2 x engine mounts drivers side drop links axle lower control arms axle upper control arms axle tie rod ends axle I still have...
Top