Alfa Romeo Forum banner

loosing

  1. loosing my mind

    South Africa
    i ordered swirl flap plugs in Jan when i finally figured out what the f it was rattling on the intake, after reading a couple of posts about a funny rattle found that that is the sound when a flap breaks of and is bounding around the intake on its way to visit the piston so when i heard a funny...
  2. Loosing coolant fluid

    Alfa Giulietta
    Hi guy's, i've just noticed that i'm loosing coolant fluid from expansion bottle, i've checked all over for any leaks but can't seem to find any, had car upto running tempreture and got pressure in system but can't see any leaks from anywhere at all, anyone got any idea's or am i missing...
  3. Alfa 159 2.2 loosing power

    Alfa 159, Brera & 946 Spider
    Hello, I own Alfa 159; 2.2; 2006. engine is loosing power below 1000, abowe 1000 wokrs normaly. Diagnostic has shown a problem with camshaft sensor. I had replaced it but the problem is same. Could somebody advice about it. Thank You
  4. Alfa 159 2.2 loosing power

    Alfa 159, Brera & 946 Spider
    Hello, My name Giorgi. I have Alfa romeo 159 2.2. 2006. Engine is loosing power below 1000. Abowe 1000 works normally. Diagnostic has shown the fault of camshaft sensor. I have replaced it , but the problem is the same Thank you for an advice
  5. Kenwood loosing settings

    ICE & Blue&Me
    I've fitted a Kenwood replacement head unit to my 2008 Spider as the old sat nav unit had many problems. The sound is great, but it looses settings, stations, etc when turning the ignition off. Ive tried switching the red and yellow live and switch wires, but with them crossed I just loose the...
  6. Using or loosing coolant 2012 Guilietta !.6 Deisel

    Alfa Giulietta
    Had a notice come up on the dash a few weeks ago saying "Change the Oil". It's the daughters car so never looks under the bonnet. Went to the garage that looks after the car (last 30 years) when the bonnet was lifted I noticed that the coolant was at the bottom of it's container just above the...
  7. 156 JTD16V loosing oil

    Alfa 147, 156 & GT
    So here am stranded in a pool of oil in tesco car park. Had a low oil pressure warning when moving and have discovered the drivers front wheel arch is sprayed with oil. In fact, the whole drivers side of the car is! Oil is still dripping from in front of the drivers side front wheel arch. So...
  8. loosing power at 3-4000 refs after major engine work

    Alfa 147, 156 & GT
    :mad:I had top done after burned valve. Had rings and bearings replaced. Had cams ,tension-er and belts done. New plugs and service. Car was running smooth for month. Currently cut out in first gear at 3500 rpm, second gear cut out at 3500 rpm, third gear fine till 4000 rpm, and on wards...
  9. 06 Brera. New steering rack?!!!! WTF! Im loosing patience!

    Alfa 159, Brera & 946 Spider
    After 7 years of trouble free motoring in my trusty 147, I opted for a Brera and o Boy do I regret it now! I bought the 56 reg Brera with 40tho on the clock and a full S/H so I thought I couldnt be going too far wrong. Its just not the car that the 147 was :((( Ive been forced to spend on...
  10. Alfa GT loosing coolant slowly

    South Africa
    2005 Alfa GT 3.2. The water bottle consistently drops to below the minimum mark. I will fill it up to maximum and around 400 - 500 km later same thing. I would guess it loses around 200 ml ? Anyway no leaks under car even if parked for two weeks, no sign of water in oil and visa versa. And the...
  11. iPod loosing charge when in car

    ICE & Blue&Me
    Hi, Have an old iphone 4 set up as an iPod, plugged in to the usb slot in the glove box. it has no phone signal, just an iPod feature. If i use the music function, it starts and stops with the car, charges whilst driving and stays charged when parked up. But if i use the spotify function, it...
  12. 1986 Spider Still loosing Power

    The Classic Alfa Romeos
    Hi My Spider is Still Loosing Power. When cold, Car starts up and runs fine. No miss. Took it for a ride and still ran well at first. Then after abut 10 min of driving it happens ( 175 degrees). Under a load ( reeving up to 3K) the engine boogs down and looses power. Not completely. It will...
  13. How long can I disconnect the battery without loosing Connect NAV config?

    Alfa 159, Brera & 946 Spider
    Hello all! I have to replace the battery's ground wire because it is somewhat loose. My fear is, will I loose the original Satnav configuration (voice commands for the phone, agenda, etc and, above all, the CODE (I don't have the card)? The garage owner is not keen on connecting an auxiliary...
  14. loosing power or limp mode 156

    Alfa 147, 156 & GT
    my 156 2 litre decided after going on a long run that its gonna loose power everytime i hit a bump in the road, its almost like limp mode, but you go over another bump and powers all back again. the engine lights on and fault codes bring up airflow meter and tps, ive changed airflow meter and...
  15. how to remove slave cylinder fluid without loosing brakes??

    Alfa 147, 156 & GT
    i was wondering if i remove my slave cylinder pipe will i loose my brakes as i need to take off for to take out my gearbox?? my car is alfa 156 1.6ts slave cyclinder is inside the gearbox
  16. 2006 gt 1.9jtdm loosing screen wash from headlight washer

    Alfa 147, 156 & GT
    hi i have 2006 1.9 jtdm with winter pack which seams to have a leak from the n/s headlight washer ,have removed jet and cleaned it out but after operating headlight washer it then has a small weap which leaks from behind bumper and then runs down indicator lamp and black plastic grill next to it...
  17. Loosing spark?

    South Africa
    Been struggling with my Giulietta's engine, which seem to run on 3.5 cylinders for a while now. I had a look now, in the dark, to see where or if the leads loose spark. Nowhere can I see a definite spark, like you would from the end of the lead to a ground point. What I do see, is 'glow'...
  18. 147 randomly loosing fuel

    Alfa 147, 156 & GT
    Hi I got my alfa just over a week ago and am noticing the first problems setting in., my car is a 55 plate 2L t spark 147. My main problem im concerned about is the fuel indicator is either wrong or i'm loosing massive amounts of fuel. This has happened a couple of times. This eveningI parked...
  19. Alfa 156 1.8 no speedo and loosing power

    Alfa 147, 156 & GT
    hi People First time on here so hoping for the best Well i have an alfa 156 1.8ts and ive just put a new enigine in it but im having a few issues 1. battery doesnt seem to hold charge 2. Speedo does not move 3. Loses Power sometimes (wont let me get bast 4000 rev only sometimes) 4. Hand break...
  20. loosing my MiTo

    Alfa MiTo
    well only during the week , the wife will be using it for her trips to work as i start a new job in two weeks time and is only a 3 mile trip so my wife is trading in here 3 year old seat Ibiza for a ex demo smart car which i will use in the week as the 3 mile run will not be good for the mito...
Top