Alfa Romeo Forum banner

lambda

  1. Help: 2.5 V6 weird problems with idle and throttle

    Alfa 147, 156 & GT
    Hello everyone, So, first thing to get out of the way, I have been having a problem with the v6 since I bought it and it seems it is getting worse. The issue is that it sometime had a slight missfire on idle and it misses a beat when blipping the throttle on idle but is fine up the rev range...
  2. No clicking when testing the lambda heaters in MES

    Alfa 147, 156 & GT
    Hi everyone I am having issues with my car throwing lambda codes, the codes are P0161 and P0141. I plugged it in and checked with MultiECUScan and when testing the heaters for the lambdas I didn't hear a single click. Anyone know why?
  3. Lambda sensor OEM numbers for 2.0 jtdm 170hp

    Alfa Giulietta
    Hello team, I have had some issues with my lambda sensor 1 bank 1 and had it replaced. The original part I had was Bosch №: 0 281 004 123, my mechanic replaced it with an available Bosch №: 0 281 004 050. They both appear on the search for the OE number 55202582 ...
  4. 2.0 jtdm Lambda 1 signal upstream

    Alfa 159, Brera & 946 Spider
    Hi! I was driving and suddenly an error appeared in my dashboard. Using ALFA OBD with an Android smartphone I had this advices. So I supose that something is wrong with Lambda 1 wich is under the cover of the engine, Am I right? It seems a wire broken or a short circuit in the sensor but...
  5. Lambda Sensors for Alfa Romeo 166 - 3.0 V6 - 2005

    Alfa 164 & 166
    Hi All Need your assistance, I'm the happy owner of Alfa Romeo 3.0 V6 24V - 2005, and I'm interested with replacing the Lambda sensors.... It's not that I have a reject, just it's about time. Not sure which Lambda Sensors I should order, is anyone have the par number for the sensors I should...
  6. 159 TBi P1135 - preheating resistance 1 above catalyzer

    Alfa 159, Brera & 946 Spider
    Hi All, So my first post here. I've had a look through the forum but couldn't find the info I need on this code. I am getting the "P1135 preheating resistance 1 above catalyzer" engine management come on. It's been cleared twice so far. Car drives fine, however, the mpg has dropped to around...
  7. Lambda 02 sensor

    Alfa 159, Brera & 946 Spider
    Hi guys I need to have my sensor changed is there a GM alternative which would presumably be cheaper than the OM part, suggestions for the best place to purchase this would be appreciated and is it necessary to change both sensor's
  8. 147 1.6 TS lambda sensor

    Alfa 147, 156 & GT
    Got a mcsf light this afternoon. MES says it's the Lambda sensor pre-cat. Seems like a fairly simple replacement. I do have one question, though. There are four plugs at the back of the engine bay, red, white, blue and black. Am I right in thinking the black one is the one I need to pull? Cheers.
  9. Lambda Sensors

    Alfa 147, 156 & GT
    Morning all Quick question this time I found a guide on cleaning lambda sensors on-line. It involves soaking them fully submerged in petrol overnight and giving them a light brush with a soft tooth brush the next morning before re-fitting. As I've had a previous fault which I have turned off...
  10. Help P0130 - Lambda & P0335 Sensor No Signal Fatal ! Engine Won't Start

    Alfa GTV & 916 Spider
    Hi All, this is an odd one. I have a 1999 TS CF2 Spider (113K Miles) and last weekend I did a 40 mile drive and parked it up outside in the sun for a few hours and then I decided to put it in the garage and the engine would turn over but not fire up, as the engine was cranking the injector...
  11. Lambda

    Alfa GTV & 916 Spider
    Hi, does anyone know if my car has one or two lambda sensors. I have found and replaced the one above the cat.
  12. Motronic 3.7.1 ECU Lambda Problem

    Alfa GTV & 916 Spider
    Hi all, I have a problem with my Spider ECU. The Lambda Voltage in the connected MultiECUScan shows 240mV but a multimeter says it is 950 mV. But first: The car is a Spider from 1996 3.0 V6 12V. The ECU number is 0261203510 The problem is: The ECU "thinks" there is not enough gasoline and...
  13. Lambda sensors strike again 156 3.2

    Alfa 147, 156 & GT
    Hello everyone, I have recently bought a 156 GTA with the 3.2. The car came with an engine light on, the previous owners claimed that it is on because the cats have been removed. I took it to an exhaust shop and they fitted cat foolers on the midpipe, I cleared the code but after +-50km the...
  14. OEM Part number for Lambda Sensor?

    Alfa Giulietta
    Hi can anyone help me out with the correct part number for the lambda sensor for my 2012 2.0 JTDM 170BHP G? Thank you!
  15. Brera 3.2 Bank One Sensor One lambda sensor part number?

    Alfa 159, Brera & 946 Spider
    OK guys anyone shed some light which sensor I need for bank one sensor one lambda, seems to be two different part numbers for the 3.2, assumiung the pre cat and post cat lambdas are different? Which part number do I need for sensor one... 55204059 vs 55204058 perhaps there is no difference...
  16. Think I might have a Lambda problem.. P1135 & P2260

    Alfa 159, Brera & 946 Spider
    Hi all, Been a while as my Alfa has been reasonably trouble free. Recently got an engine light up and the diagnostic report is the following; P2260 - Secondary air injection system control B circuit high P1135 - Which I think is HO2S lean mean bank 1 sensor 1 Being the 3.2 it has a lambda...
  17. No Lambda readings in Multiscan

    Alfa 159, Brera & 946 Spider
    Hi all, In an effort to overcome my 159 2.4Jtdms recent MOT failure on emissions, I have a new DPF (original removed) and POST Lambda sensor fitted. I checked the Lambda readings in Multiscan whilst resetting the DPF counts and I get nothing, no reading at all. I also noticed that there only...
  18. MES lambda readings

    Alfa GTV & 916 Spider
    P1 TS spider. Using mes the lambda is switching from lean to rich every 4 seconds. I'm getting conflicting info on the web, some saying this is too slow others not. Anyone tested their lambda using MES? Lambda age is unknown but is a Bosch. Car always struggles through MOT emissions test and...
  19. Which lambda sensor faulty?

    Alfa 164 & 166
    On my 2002 3.0l V6 I had the engine light come on and had it checked on Multiecuscan. This indicated the problem was with "lambda sensor 2 pre-cat". Anyone know which one this is? Having checked previous threads I understand the 2 on the manifolds are difficult to replace while the one on the...
  20. 1999 156 cf2 3.0 v6 Q System Lambda Probes

    Alfa 147, 156 & GT
    Hi all, I'm currently running my 156 3.0 q system with stock maf, injector with gta inlet runners and pipes. I'm currently undergoing the process of renewing all the worn out items like spark plugs, MAF, crank sensor and lambda sensor. I have questions on the lambda probe as I have 2 lambda...
Top