Alfa Romeo Forum banner

lack

  1. Alfa Giulietta
    Quite a few times I've passed those roadside speed indicators and suspected they were a bit oversensitive as they will read 32 - 33 when the speedo is spot on 30. Occasionally they read 30 when the speedo says 25 (ish). Recently I was reviewing some dashcam footage and thought "I'm sure I...
  2. Alfa 159, Brera & 946 Spider
    Evening Less than a week with my 159 TI 2.0 JTDM and it really feels like it has a lack of oomph below 2500rpm and no real push from the turbo above that (I am coming from a 1.9PD VW 140bhp and a 159 1.9 Ti before that). It wasn't something I particularly noticed when test driving, but I'm...
  3. Alfa Giulietta
    Hello happy Alfa Owners, well my first glitch on my G, the AC is not getting cold. I had it serviced last year and it was working fine, the car is not used much and yesterday it just refused to blow out any cold air. I have put on Multiscan and I cannot hear the Are con pump relay clicking in or...
  4. Tuning & Upgrades
    Hello everyone.... I need help....When I installed the new bigger front intercooler i noticed the car is responding on bigger rpm ,slower than before....the car used to increase in power after 1700RPM before... now I noticed that the car does not accelerate as before, I installed new standard...
  5. General Alfa Discussion
    I just spent 3 nights in Milan, a great city with lots to see, however I was expecting to see plenty of Alfas around the streets but didn't hardly see any. There were a few Mitos and Giuliettas but they were pretty well used and and nothing of merit. Didn't even see a QV. Or even a Ferrari...
  6. Alfa 159, Brera & 946 Spider
    Morning everyone. I have a 2010 159 2.0 JTDM (170) Ti. It has always seemed to have an intermittent flat spot around 3500 rpm mainly in 3rd gear on wards. I disconnected the MAF and it seemed to run better so have a new one to fit. This morning however, I was on my way to work, and I...
  7. Engines (TS, JTS, JTD & V6)
    Hello AO a few weeks ago I changed my turbocharger for a reconditioned one and my Bravo is running well, although recently I have noticed a slight lack of power as soon as my temperature gauge hits 90, there is also a very noticeable lack of torque, it's not a lot but surely enough to notice...
  8. Alfa MiTo
    Hi, I have had my car for 2 Years now and this hasn’t happened before. Basically my car has a lack of power when I put my foot down, and the dynamic mode doesn’t work. I was leaving trouble with it last night when I put my foot down it would lag and then shoot off. However this morning the...
  9. Alfa 159, Brera & 946 Spider
    After some help please! Got a 2007 159 1.9 jtdm 16v on 130k miles Just had a re-con turbo fitted ( old one was whistling away loudly and on it's way) Car ran fine prior to fitting, no issues. Since new turbo, she's lacking power up to just over 3000rpm then she will boost fully and takes off...
  10. Alfa MiTo
    I suppose this has been done to death, but of all the UK frequent posters of reviews on YouTube on cars there are virtually none within the last year or two for the Mito, so difficult to gage opinions on newer versions. Yes there may be written reviews, but of the filmed reviews, they go back...
  11. Alfa Giulietta
    Hi all, I got my Cloverleaf last night and it's wonderful in every way, apart from one of my front washer jets is literally spitting out a tiny amount of Screenwash, we are guessing it's just gunked up, however, with where they are positioned and with the large size of them, I don't know how to...
  12. Alfa 145 & 146
    I guess i probably know what replies will be but I have the chance of an alfa with no history 85k miles 1.6ts how much to change cam belt roughly these days , am new to this forum apologies if in wrong section. Anything else i should watch for or should i walk away due to no history ?
  13. Alfa 147, 156 & GT
    Alfa 147 1.9 JTD 16V , 140HP, year 2003. Car is mechanically fine ,except for a stuck open thermostat and an EGR valve that the last owner has probably never cleaned, since he wasn't even aware what It was. Oil will be changed tomorrow to full synthetic. 1. Yesterday I got myself in some street...
  14. South Africa
    maybe one of you can help me with this mystery, I cant seem to work my way around this one.... So after the engine replacement last year at Sandown CC, I had a number of issues... which were never attended to despite the emails I sent. I then went to William Simpson Newlands for the next...
  15. Alfa Giulietta
    Hello everyone. If any of you follow the Uconnect 6.5 sav nav on going saga and saw my comments on the "tct recall" that my dealer updated it has given some very odd results. i wanted to know if anyone else has experienced the same outcome (1.4 MA's) as this just isnt right. Alfa screwed up...
  16. Alfa Giulietta
    Hi, Searched the forums but can't quite find the same problem - any ideas? Since I've had the car, when accelerating after changing into 2nd/3rd gear there is often a little 'boost' to the acceleration, most noticeable when coming off roundabouts/junctions etc. As of yesterday, instead of...
  17. Alfa 159, Brera & 946 Spider
    My 159 2.4 has suffered this a couple of times. The car usually lives in rural France so seldom spends time in traffic. Since having the dpf removed by AHM the car has been transformed but this strange behaviour in traffic has only happened since the dpf removal. Any more than 20 mins in slow...
  18. Alfa GTV & 916 Spider
    I've had my lovely twin-park for for months now. Very pleased with it but for lack of sound, aren't twin cam Alfas meant to sound alive? It had a k&n cone fitted which hadn't done the maf any good - runs much better with the standard air box. I believe that the resonator box does nothing but...
  19. Alfa 147, 156 & GT
    Hi i have buyed a 147 jtdm 140 bhp. it don"t start since 2 years, 118.000 km, broken clutche. so i have done water pump, timiung belt, clutch etc.... started at the first try, run fine, smoke a lot. no leaks , everithing is ok. on the road , the car is slugish.... the first kilometers , no...
  20. Alfa 147, 156 & GT
    Hi guys. Just recently I have notice a drop in power below 2750 rpm with my 2004 GT 1.9 JTD. It is really flat and then the power/boost comes surging in! I have cleaned the EGR very thoroughly (although I though it an unlikely cause as I had it switched off some time ago.) and checked the vanes...
Top