Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 28 Results
  1. Alfa 164 & 166
    My 166 has developed a weird fault. On low-speed right hand turns, the traction control will sometimes cut in, applying the brake on the front left wheel. When this happens, the traction control light on the dash flashes. It only ever happens on right hand turns, and only affects the left...
  2. Alfa GTV & 916 Spider
    I need a bit of advice here please. The car is a CF3 24v V6 Spider; the cooling fan does not come on for the 1st stage but both fans kick in together on the 2nd stage. I have changed the resistor and that has not rectified the fault. I am guessing, therefore, that it could be either the relay...
  3. Alfa 147, 156 & GT
    Hi all have some ongoing problems with my rediator fan.I putted in new fuses and relays and last week I bought an new resistor I a ecu check and nothing found.I even changed the thermostat last year.pleas any help will be greatly appreciated.
  4. General Alfa Discussion
    Alfa Romeo 4C Spider review | Auto Express :( (At least the photos aren't mocked-up. )
  5. Alfa 164 & 166
    Anyone got two of these 16's kicking about? http://img37.imageshack.us/img37/9919/20120716202727.jpg Was supplied two with my 75, would like to try them on it as a set.
  6. Alfa 147, 156 & GT
    I've just purchased a 156 selespeed 2.0 twin spark which appears to get a little warm on tick over in traffic. The low speed fan isn't kickin in and its getting to well ova 100 degrees before the high speed fan kicks in. After reading several posts on this site I purchased a new resistor, and...
  7. Alfa GTA
    BMW130i vs Audi A3 vs GOLF R32 vs Alfa147GTA vs Integra Type-R - YouTube But I do think the XXX did make a mistake somewhere to drop so far back.
  8. Alfa 147, 156 & GT
    Hello, there! Yeah, it's a bit shameful that my first post is about a technical problem, to be honest. Anyway, I bought An 156 1.6 TS (2001) in July, this year and found out that the engine was in a very poor condition. The head gasket was burnt and the cylinder head was deformed and so on. By...
  9. Alfa 164 & 166
    I've just tried to do an ECU reset this evening. I noticed that during the 15 mins of idling, the temp gauge went slightly above 90. Now I should add that last week I had the radiator and thermostat replaced. When I got back home and let it idle on the drive, the temp gauge nearly entered the...
  10. General Alfa Discussion
    Not for my driveway but for the GT meet in April ....Thought it would draw attention for members arriving on the Saturday morning .....A few GTs sitting together will most likely not be missed but thought it would be rather cool ....:cool:
  11. Alfa 147, 156 & GT
    Hi all, I know there are a few posts on this type of problem, but I didn't fully find an answer to my situation ... so here goes. I have Alfa 156, 2.5L V6. My radiator fan stage 1 does not kick in unless I use A/C. I have fiddled with the relays and they look fine. Drove car to spare parts...
  12. Alfa 147, 156 & GT
    There's a few threads on this problem in the forums, but there don't seem to be many positive fix responses so I thought I'd post my recent experience. I recently bought a 2004 147 in lovely condition, a few weeks ago it started flagging a VDC/ABS error and disabling the ASR. It usually reset...
  13. Alfa 147, 156 & GT
    Hey everyone The fan on my:confused: 156 is not kicking in, the temp runs over 90 degrees and still nothing, can it be the fan relay by any chance?, also when I put the aircon on the fan does not kick in..very worrying as I do not want her to over heat, any advice would be hugely appreciated...
  14. Alfa 147, 156 & GT
    Hi, can anyone help, i have a 147 2001 that keeps cutting out when driving. dash shows immobiliser error code. i was told to find the fuse for central locking and it would stop the immobilers from working but it still keeps cutting out after 5 mins or less.
  15. General Alfa Discussion
    its odd, there was a lot of talk about Alfa killing off the 169 project...but two different websites have run stories on Alfa's new RWD 169.... Alfa Romeo 169 to Use Dodge Charger Platform - autoevolution Alfa Romeo 166-Nachfolger: Alfa 169 kommt wieder mit Heckantrieb - auto motor und sport
  16. Alfa 147, 156 & GT
    Hey guys, I had a problem a while back where my car overheated. I've been trying to find out why the fan doesnt kick in these last few days. I give the fan motor a direct feed off the battery and it spins. So I'm guessing its the switch thats buggered. This was hanging from the fan housing...
  17. Alfa 147, 156 & GT
    The car is getting to around 110/120 at idle in traffic and the fast speed seems to kick in right at the last minute. If I hit the Air Con button the fan will engage and bring it back down to temp, but this is less than ideal. Is there a way I can join the connections on the fast speed...
  18. Alfa MiTo
    An owner of a diesel writes in to say he hates his, it gets a dishonourable mention as a car overal in COTY but the multi air engine gets an honourable mention. Overal, 1 out of 3 :(
  19. Alfa GTA
    Hi, as I said in my introduction I was on the search for a 147 GTA. Well, I finally got me one!!! It's from end 2003 with 60.000km (About 37.000 Miles), new cambelt, tensioner, pulleys and waterpump (metal impellor) and I have a question, because I have the feeling the thermostat is broken...
  20. Alfa 147, 156 & GT
    Hi anyone had th eproblem of the AC compressor not working? I've checked all of the fuses and I think the correct relay but it just doesn't work. The system was regassed and checked last year. The AC light cones but the compressor doesn't. There is pressure in the system so I'm sure I've not...
1-20 of 28 Results
Top