Alfa Romeo Forum banner

issue

  1. Alfa Mito 1.6 Jtdm start up issues

    Alfa MiTo
    Hello everyone, I'm a new Alfa owner and new to the forum. I recently bought an Alfa Romeo Mito 1.6 Jtdm 85 kW. Car had slight issues while starting since I bought it but nothing too worrying (about 2 seconds of crank and it would fire up and work perfectly). In the winter as temperatures...
  2. Turbo issue

    Alfa MiTo
    So the other day I was on the dual carriageway doing about 65mph in 5th, pushed the clutch in to change to 6th and there was a loud "pop" noise from the engine bay. Pulled over, opened the bonnet, the entire air intake pipe to the turbo had detached itself. I pushed it back on, drive home...
  3. rear window switch issue

    Alfa 159, Brera & 946 Spider
    hey,guys, I have an issue with the switch for one of the rear windows (the one on the drivers side). when operated from the switch on its own door it works fine. But when operated from the drivers switch, it only goes down no matter if you pish or pull.Any advice?
  4. Help! Wiper issue

    Alfa 147, 156 & GT
    Hi all, I bought my first Alfa this week, several times over the weekend the windscreen wipers have stopped working and won't start again until I turn off the engine and restart the car. Any ideas anyone. It's been an awful weekend for rain here in South Wales and this is a very dangerous issue...
  5. Cruise control potential issue

    Alfa Giulietta
    Hi all. The cruise control on my 2014 1750 Giulietta seems to occasionally not engage. Typical scenario will be; cruise control is turned on all of the time, as in green dial is illuminated on display, but approximately 1 time in 10 when I go to push the lever up to engage, when driving at the...
  6. 1.6 diesel power steering issue

    Alfa MiTo
    Hi All, My daughters 2010 1.6 diesel has developed the dreaded power steering failure! at the moment it resets if it is turned off and then back on, I recently bought her the car from a garage where it had sat around for a good six months. my first thought is the battery, just had a look and it...
  7. Oil Filter Housing Cap Issue

    Alfa 159, Brera & 946 Spider
    Hi All, I was completing an oil change on my Alfa 159 3.2 and all was going well until I went to change the filter. When I tried to remove the cap, the nut at the bottom broke off which left a crack/hole on the cap. I ordered a replacement on ebay but it doesn't fit. Anyone have any ideas of...
  8. Dual zone climate control issue

    Alfa Giulietta
    Hello, my dual zone climate control runs different temperatures even though the dials indicate the same setting. The drivers side is cool and the passengers side is hot, you can feel the difference. All started when I had my pollen filter changed, also the heated seats have stopped both sides...
  9. 1997 916 Gtv coolant issue

    Alfa GTV & 916 Spider
    Hello.. well I recently acquired.. well rescued a 1997 GTV destined to be gutted for its interior by a mini owner.. anyway on pick up.. the header tank cap was not sealing... you could basically pull it straight off.. so had to be towed home. Got it home and quickly set about trying to see if...
  10. Giulia Veloce stop/start issue

    Alfa Giulia
    Hi all, Good news. The stop/start didn't work when I bought the car about a month ago so it's had a new battery under warranty. It also had a new interior light unit so the alarm sensitivity could be dialled down. It also had any relevant software updates completed. All done at Monday Sport in...
  11. GT electrical issue

    Alfa 147, 156 & GT
    Evening everyone, I was wondering if anyone has any ideas on this. On starting my GT, when I put the dipped beams on, the instrument cluster illumination sometimes goes out. Or flickers on and off. When this happens, if I switch the main beams on, the dipped headlights and the instrument...
  12. Alfa 166 3.0 2003 - seat motor issue

    Alfa 164 & 166
    Really lazy post here in case anyone has been here done this and I can save an hour or two... There's a sporadic short in a driver's seat motor which sounds randomly for a few seconds as I'm careering along. Any ideas welcome!
  13. 147 2.0ts Selespeed idle issue (too much vaccuum)

    Alfa 147, 156 & GT
    Hello Everyone! I recently got myself 147 2.0ts 2001 Selespeed, with some issues ecu code regarding "P1654 Modular Manifold ". although the car worked perfectly and no idles issues. Im using Multiecuscan software. So Recently removed all parts related to the intake including the modular...
  14. 147 GTA selespeed issue

    Alfa GTA
    Hoping someone can help. Have a 2004 147 selespeed, always leave in neutral when not used. Has an intermittent issue which if not used for a while when started and select 1st gear , 2 shows on the display but the car is actually in reverse , if you try and select reverse then the car goes into...
  15. idling & power issue

    Alfa 147, 156 & GT
    Hi all, Sorry if this has been discussed already, couldn't find anything on this ongoing issue. Alfa GT Blackline, 57 plate, 55k So, the engine won't idle properly and fluctuates between 900-1100 rpm and then stalls on occasion. I also intermittently get a sudden judder or loss of power...
  16. Timing belt Issue

    Alfa 147, 156 & GT
    HI On a 1.9 JTD diesel (european vehicle left sided Wheel) It broke, so I need to replace it, but I am not sure what position should the camshaft be. My reference is when the piston at the left is at the top position... Or any other position?
  17. Sportronic/drive axle issue

    Alfa 164 & 166
    Lots of things sorted, next problem occurs... When driving over small bumps, there was an obvious “clonk”-noise. I have been trying to figure out what it was, changing suspension components, only to find out that the noise is from the axle coming out of the diff. See the video here: Any...
  18. First issue with my folding soft top

    Alfa GTV & 916 Spider
    Follow alfisti, my soft top has a cracked plastic gear on the hatch opening which prevented the roof from opening ..I've since replaced the gear and now I've observed that the motor doesn't release the hatch when I press the centre opening closing switch .i can hear all motors working as it...
  19. My Alfa, the dealer Experience and that handle issue

    Alfa Giulietta
    Hello - after many years of reading various posts on here both positive and negative I felt it is now time to express my Alfa experience. I have been a Giulietta owner for 6 years and currently on my 2nd, a 2016 Speciale 1.4, which is by far the best car I have ever owned. It has never missed a...
  20. Another Mito, same issue

    Alfa MiTo
    Hi, I have just upgraded my 60 plate Cloverleaf for a 15 plate QV. Love the car, however.... The deafening squeek upon braking is still happening, had them stripped and cleaned, changed all the pads and all the discs but still a horrendous whistle echoes when braking. Any help as always...
Top