Alfa Romeo Forum banner

idle

  1. Help: 2.5 V6 weird problems with idle and throttle

    Alfa 147, 156 & GT
    Hello everyone, So, first thing to get out of the way, I have been having a problem with the v6 since I bought it and it seems it is getting worse. The issue is that it sometime had a slight missfire on idle and it misses a beat when blipping the throttle on idle but is fine up the rev range...
  2. Brera 2.2 JTS unsteady idle

    Alfa 159, Brera & 946 Spider
    Hi, Was driving to work today and I noticed that my Brera was not returning to idle RPM(900 usually) like usual but would hover around 2000 - 1500 RPM and then return slowly to 900 RPM. No check engine is showing up. I am yet to find my OBD scanner so not sure if anything has been recorded...
  3. Mito Idle Speed 700rpm

    Alfa MiTo
    My son has a 135 multi-air and idle is about 700rpm. Whilst it is not and obvious judder, to me it feels like it has a misfire at idle or the idle is too low and therefore makes the engine vibrate but it is a very small amount. I'm sure a lot of people wouldn't notice but I am sensitive to...
  4. 2.0 ts misfiring and cutting out at idle when cold

    Alfa GTV & 916 Spider
    went to start the car yesterday morning (cold and frosty) and the car wouldnt tick over and threw an engine light. once i had daylight and it had warmed up used MES to read codes P0100 - Air flow meter and P0170 Lambda Sensor integrator. reset codes and the car ran fine just went out to use the...
  5. New 0.9 TwinAir owner - vibrations at Idle

    Alfa MiTo
    Hi there, First post so here goes. Just acquired a 64 plate 105hp TwinAir and its a pleasure to drive with one exception. At idle there is an obvious vibration (felt through the steering and seat in particular) that goes away once you apply the accelerator. Seems to be present around 700-800...
  6. Guilietta QV vibration on Idle

    Alfa Giulietta
    Hi All, I have just purchased a 2014/15 guilietta QV with 48000kms. It is in mint condition and has a full service history, it has been very well looked after and I have purchased from a reputable dealer with the normal 3 months warranty (in Australia). I have just taken it home and realised...
  7. P1688 - Motorised Throttle (2nd idle learn)

    Alfa Giulietta
    Hi All Had the engine light come on and after reading the codes (MES), I had the above come up. I've cleared it but obviously I need to address the issue. Looking on the 147 GTA forum this was fixed by unplugging a clip, cleaning it and then plugging back in. Does anyone know if this is a...
  8. 156 fault codes and rough idle

    Alfa 147, 156 & GT
    Hey everyone, I have a 2001 156 TS that's had a couple of the same issues over the few years I've owned it. Specifically having seen the fault codes P0103 and P0104, which was thought to be from using a non-Bosch MAF sensor, however this got swapped out for a Bosch one with minor improvements...
  9. 2.0 JTDM engine stalls at idle under warmup

    Alfa 159, Brera & 946 Spider
    Alfa 159 2.0 JTDM Have a strange periodical Issue: Under warmup-period by Idle (waiting for green trafficlight) it starts with a irregular Idle, then when trying to drive at green trafficlight, the engine stalls, and it is not possible to start the engine again. When trying to start, It sounds...
  10. 147 2.0ts Selespeed idle issue (too much vaccuum)

    Alfa 147, 156 & GT
    Hello Everyone! I recently got myself 147 2.0ts 2001 Selespeed, with some issues ecu code regarding "P1654 Modular Manifold ". although the car worked perfectly and no idles issues. Im using Multiecuscan software. So Recently removed all parts related to the intake including the modular...
  11. 159 3.2JTS Rough Idle & Flashing Amber Engine Light

    Alfa 159, Brera & 946 Spider
    Hi all, I've owned a couple of Alfas but I'm new to AO. My 2013 159 3.2JTS has been running rough when I start it from cold, lots of vibration and a little rattle ifrom the engine bay. This morning the engine light began flashing in amber as I started the car but went off quite quickly. The car...
  12. Alfa 166 - 2.5 V6 engine idle

    Alfa 164 & 166
    Well, hello! This is not a problem itself, I'm just curious how many revs per min. your car stays. Because is curious that mine is shaking and is not stable, vary from 800 to 1000. Was bad from when I bought it. Failures, shaking like crazy, burn oil smell. Story begines when I wanted to see the...
  13. 2.0 TS Idle Drops Dangerously Low With AC On And Speeds Higher Than 30KPH

    Engines (TS, JTS, JTD & V6)
    What the title says really. And this only happens with the AC on. If I depress the clutch to come to a stop while the AC is on and at speeds over 30kph the idle drops the nearly zero before settling regularly. The issue doesn't happen with the AC off at all, and if I slow to under 30kph before...
  14. 159 JTDM 2.4 New owner. Vibration at idle and hard cold start.

    Alfa 159, Brera & 946 Spider
    Hi there, I have just bought a new 2.4 JTDM and think its great. It has low mileage and is in good condition. I had it checked over by a local mechanic (not an Alfa specialist, it was in a rural location) and everything seemed fine. However, I did notice on the test drive a slight vibration...
  15. Idle drops to nearly zero when coming to a stop from over 30kph/18mph

    Alfa GTV & 916 Spider
    What the title says really. And this only happens with the AC on. If I depress the clutch to come to a stop while the AC is on and at speeds over 30kph the idle drops the nearly zero before settling regularly. The issue doesn't happen with the AC off at all, and if I slow to under 30kph before...
  16. 2.0 TS Idle Drops Dangerously Low With High Electrical Load

    Engines (TS, JTS, JTD & V6)
    I recently replaced my idle speed actuator (and reset it through diagnostics) to cure my idle hunting issue, but now I have another idle issue! When I've driving around normally, with no lights on, no radio, no AC, when I depress the clutch to come to a stop the idle drops to around 500rpm then...
  17. Has anyone successfully tried the wonky idle fix by cutting ABS wire?

    Alfa GTV & 916 Spider
    Here's the original thread for a 156 TwinSpark whose problems are eerily similar to what I and a ton of fellow GTV owners have been having: Has anyone managed to implement this? I haven't found a similar wire in the GTV's instrument cluster wiring diagram, but perhaps a GTV-specific fix has...
  18. Starting / idle dropping to 0 / stalling

    Alfa GTV & 916 Spider
    Last couple of times I've started my GTV from cold (proper cold - a week of not being used), she's stalled pretty quickly - revs drop to near 0, injector light comes on, quits. If I hold some revs on with the accelerator pedal she settles down in a minute or two, though sometimes the injector...
  19. Idle drops when AC is one & what is a Q20 sensor?

    Alfa GTV & 916 Spider
    So, the thread is pretty self-explanatory. I had an idle hunting issue that a new (to me) idle speed actuator solved and without the AC on the car idles and drives perfectly, but the moment I turn the AC on it starts to hunt for idle when coming to a stop. The revs drop to nearly 0 then bounce...
  20. Idle Speed Actuator Reset - still behaving weird with AC on and best way to train it

    Alfa GTV & 916 Spider
    Hi all! I replaced my knackered Idle Speed Actuator with a used unit and reset it. It's gently 'finding its feet' but I'm curious what your experiences were like when you reset its parameters - how long did it take to idle fully normally? With the AC off it's 95% great, but with the AC on it's...
Top