Alfa Romeo Forum banner

hunting

  1. Alfa GTV & 916 Spider
    Hi all, I’ve got an interesting one this evening. I’ve noticed the GTV (2.0 TS) starts idle hunting when I’ve got the clutch depressed and I’m coming to a stop, but then idles just fine when actually at a complete stop. Any idea what this problem could be? I’ve recently replaced the RPM sensor...
  2. Alfa 159, Brera & 946 Spider
    Afternoon all, so as the title suggests, my brera hunts for rpm. But only on a cold start for about 1-2 seconds, if the engine is started while still warm it does not hunt at all. anyone able to shed any light on if this is the start of a problem or just another one of those alfa things...
  3. Alfa Giulia
    Hi, I wonder whether anyone of you has an access to parts catalog for Giulia? I have been trying to find a part number or just part's name for a bracket holding a bumper(as per picture attached) . Unfortunately, I have managed to pull my bumper off few times by parking over a kerb so it was...
  4. Alfa 155
    Hi I've got a 1998 alfa 155 2.0 16v. I think its the later engine that was taken through to the 156 and GTV. After the car is warm, at rest the revs rise from 1000 to 200 and back constantly. Also when I take my foot off the accelerator the car slows gradually but sometimes jolts slower still as...
  5. Alfa Giulietta
    Hi all, I am quite new to the forums, but I'm hoping to get some advice from other Giulietta owners. I bought my G TCT QV Line 170 MA in September last year and my partner and I absolutely love the car, but it has recently developed some niggling issues, and one of them making the car annoying...
  6. Alfa 159, Brera & 946 Spider
    Having read the "one year on" thread, it just reminds me (as if I need it!) how much I'm missing having an Alfa! It's been too long since the 156. Still looking for a 159 TBi Lusso (pref) sportwagon... Anyone seen one (last I saw was a little high on the miles from lovealfa that I didn't get...
  7. Alfa GTV & 916 Spider
    Sharing my experience finding the OBD connector on my 1998 Phase 2 Spider 916. I know there are existing threads on this but it seemed to be a commonly asked question. Just bought the Multiecuscan software and cable package from Gendan, so will post my experiences with this kit later. Have an...
  8. Alfa 147, 156 & GT
    Alfa 156 hunting on idle? Just got my Alfa 156 out of the shed after a lay off of a year or so and the idle is now irregular, hunting on idle. Was perfect before. Idle runs up and down . Changed the air-flow sensor and no change. Any ideas?
  9. Alfa 147, 156 & GT
    Hello all. I have a 2004 156 2.0 JTS. I have had the head fully recond and injectors refurbished. Put it all back together and no 3 injector failed. New injector installed and now its all good except it hunts or run rough on idle, then comes good, then rough etc. It also hunts when decelerating...
  10. Alfa 164 & 166
    i keep writing these posts about things wrong with my 164 but its just because i am a bit of a perfectionist when it comes to my own cars, just had the cambelt and waterpump, now she seems to run cold, like between 60-70 degrees Celsius at 50-60, mph but will hit 90-100 degrees when idle...
  11. Alfa GTV & 916 Spider
    Hi All, I am looking for a nice convertible as a third car and considering either an Alfa Spider or MX-5. I don't want to spend too much on it as it is really a toy so looking at older cars. Whereas the MX-5 is uber reliable, its main foible is rust. Conversely, the Alfa Spiders, despite the...
  12. Alfa Giulietta
    Hi, This is my first Alfa, had it for just over a year without issue and I'm the second UK owner from new with 80,000 miles currently on the clock. I've noticed that occasionally when I'm in DNA mode and I put my foot down (joining from a slip road etc) the car seems quite slow to respond to...
  13. Alfa 147, 156 & GT
    My twin spark has started to rev itself on idle (hunting is technical term, I think?). It will fluctuate between 800 and 1300 rpm. Anyone know what's up with her? Thanks
  14. Engines (TS, JTS, JTD & V6)
    Now then.. following a terminal engine-wreck (Twin-Spark 1.8 metal head - water pump failed and trashed the cam-belt) I have rebuilt the cylinder head and plugged everything back in. :) The beast started first turn of the key... :thumbs: but apart from a massive blow in the exhaust...
  15. Alfa Giulietta
    Guys, Do I need to worry about this? Yesterday morning I only drove about 3 miles and while stopped at traffic lights I noticed my RPM needle 'hunting' badly. I then gave it a blast for another mile and it seemed to have rectified the problem but should I get it looked at? Cheers.
  16. Alfa 147, 156 & GT
    quick question guys,ive been hunting for a variator , but cant seem to find it any cheaper than what ive been coming up with which is £150ish. All other parts are quite easy to find online for a decent price but this seems to be the only one that isnt , any advice ?
  17. Alfa 147, 156 & GT
    Hi, when I start my 1.9 gt it thumps if that makes sense, sounds like a loose engine mount...is that common. Also when I start it after it's been running so warm it 'hunts' for a bit until I rev it a few times...would this indicate a dirty egr? Thanks
  18. Alfa 159, Brera & 946 Spider
    Ohhhh ****... As you know I had the timing belt done a few weeks ago, and it ran much better... And it was nice being in the Alfa It's done a few thousand miles since then...heathrow and back to Leicester. However last few days it's been dropping boost, low boost anyway like from one notch on...
  19. Alfa 159, Brera & 946 Spider
    Hi again guys Along side the rattle from the engine I reported on not too long ago (which still hasn't been diagnosed yet and is getting worse......a trip to Alfa Workshop is imminent), the engine is now got a very unsteady idle, which is also translating into a pretty jerky low speed...
  20. Alfa 147, 156 & GT
    I am new to Alfa but totally hooked on these cars. I have a 98 model 156, 1,8ts. I am getting terrible fuel economy and trying to rectify this. First test showed 1.3 L/10klm (21MPG). Changed the plugs to NKG Platinum, new air filter and made sure there were no issues in the air intake. Next...
Top