Alfa Romeo Forum banner

helpplease

  1. Introduce Yourself
    Hi, have bought an Alfa Romeo Giulietta 2011, jdtm-2 140bhp, for the first 5 months no problems, enjoyable motoring. Since then have had issues, the latest of which involved the engine cutting out completely and the red oil light coming on. The cambelt and water pump was changed by alfa, less...
  2. Alfa 147, 156 & GT
    Hi guys, Need some help please, yesterday my 156 ( 1.8ts ) required a little extra cranking before it fired, which was quite unusual.... went out and it started fine after that. Then this morning when I went to start its just turning over making no attempt to fire?? The only thing that has...
  3. The Classic Alfa Romeos
    The alternator on my Alfetta GTV 2.0 is starting to show signs of failure and I have been told that they are no longer available? Can anyone point me in the direction of possible options please? Thanks Andy
  4. Alfa MiTo
    Right... So I go to the dealer to sign docs today... I get there...read the docs...they managed to put £10 a month on the figure...Don't know how...but I told them that it was wrong and not what agreed... They re-printed and I skimmed them this time... Signed... Got home this afternoon...
  5. Alfa 147, 156 & GT
    Hey guy's, Need help. Need to disconnect the rev counter on a 156 tspark 01, Can some one let me what to do, i know in the dash you have to take the one screw out, but after that i aint a breeze, Please please help, would really make my alfa day!
  6. Alfa 147, 156 & GT
    Hi, I drive an Alfa 156 Selespeed (I hear the gasps already) but I am most pleasantly surprised with the quality and reliability of the car; given that it's a wonderful drive that overcomes the shortfalls of 'sluggish-until-warm' etc etc. That was until today, travelling for a pre-Xmas visit to...
Top