Alfa Romeo Forum banner
help me
1-18 of 32 Results
  1. Alfa MiTo
    Hey, I own an Alfa MiTo Lusso, 1.4 16v, the non turbo one my old dipstick rusted and snapped, fortunately I got it out, however it wasn't until yesterday when I checked my oil with my new dipstick, I couldn't see any on the dipstick (car was still war after 20 mile drive). I added less than a...
  2. Alfa MiTo
    Hi all, 1.6 jtdm2 owner here. Slight, but serious issue. My wipers will raise to the top of the screen, but not come down again unless I push them. The motor is buzzing, but they will not go back down without a push. If I slightly push them when on full whack they will return to the bonnet and...
  3. Alfa 147, 156 & GT
    Hi Alfa 147 Magneti Marelli/navigation (master code) 500101110141440 735329871 help please
  4. Alfa 159, Brera & Spider
    Hello everyone, Im having some annoying problems with my AR 159 1,9 Jtdm. None of the workshops I've been to can help me, but hopefully this forum will. I've read some of the threads about this problem without really getting any proper answer, so im making my own. The problem is at gentle...
  5. Alfa MiTo
    Hi all, My Mito 1.4 Veloce (2009) ran out of petrol on the motorway the other day. I managed to get some fuel but had left the hazards on which had flattened the battery so I had to get a tow home. Have now completely recharged the battery but the car won't start. I'm baffled as to what could...
  6. Alfa 159, Brera & Spider
    Hi, I've been having a major problem with my 2007 159. When the engine gets upto operating temperture, it has an issue changing between 2nd and 3rd gear. It seems to disengage the second gear and fails to shift up into third for a couple of seconds. In this time the revs go up quickly and then...
  7. Alfa 147, 156 & GT
    My 2006 147 Turbo diesel started coming up with VDC error, motor control system failure and generally running rough. I thought i would have a look under the bonnet (i have no idea why as i'm not a mechanic) and noticed that this bit had come loose. It appears to sit on 4 little black plug...
  8. Alfa 147, 156 & GT
    Hey guy's I was wondering if any of you could help me find out whats wrong with my JTD I'll tell you what's been happening.. Rightttttt Firstly I filled up with fuel and less that 500 yards the car just died on me and wouldn't start back up, Called out the RAC and he said it was my fuel...
  9. Car Detailing
    Hello everyone, How is everybody on this fine Friday? I'm in a bit of distress.. and I don't know if I should post this in the Mito subforum or this one, so here goes. I've managed to break half a bottle of CG Hybrid V7 Chemical Guys Hybrid V7 overnight. It was in a box in the boot (half full)...
  10. Alfa MiTo
    I've done something incredibly stupid. :o I didn't even realise I'd done it at first. I snapped the plastic head off the dipstick and the metal bit is still in situ an inch or more down the tube with nothing left to grip. Having checked the oil in MrsJim's 1.4MA it needed a top up for the...
  11. Alfa 147, 156 & GT
    Hi I have just checked my selespeed reservoir and it doesn't appear that there is any oil in it !! :( I had read that the oil is held below a plate so may not show but is this correct? Also I am unable to get to the Alfa dealer until monday and wanted to top up the oil incase (i have read that...
  12. Alfa 147, 156 & GT
    Hello I want to give my boyfriend a grill badge and a rear badge for Christmas. But when I search for the rear badge there are to possibilities. There are a boot badge with and without housing and I dont know what housing is. And if I need the housing to change the rear badge? Can anyone help...
  13. Alfa MiTo
    Hit some debris in the road this morning, got an annoying rattle on engine load coming from underneath car. Took a look when I got home .... This doesn't look normal .. looking on eper I think Its the suspension reinforcement bar? Think it's tapping the exhaust under load Any thoughts? ...
  14. Alfa 147, 156 & GT
    hi folks allrite now then please help I own alfa 156 1.8 tspark done 140k big end shells bad on cyl 4 due to an oil shortage started as a little rattle under torque but progressed to a knock so stripped down sump off and all that got to cyl 4 big end with quite a bit of play removed shells found...
  15. Alfa 159, Brera & Spider
    Hi All, Im hoping i can call on the collective knowledge of the group and get some ideas on why last night my Alfa 159 all of a sudden would not start. I have a 2007 ALfa Romeo 159 ti Selespeed which i purchased about 2 years ago. To date it has not given me any significant trouble. Until...
  16. Alfa 147, 156 & GT
    Hi, I need help , Im lookingfor the code of my alfa 147 autoradio . My autoradio is a connectnav wich brand is magneti marelli.The are several number write on the radio. IMEI:500101110123380 Other number :735329871 Thanks for your help
  17. ICE & Blue&Me
    Hi all, I have an Alfa Mito with the Blue and Me upgrade and would love to play my iphone 5 music through my car. However, when I plug it into the USB slot by my gear stick, it for some reason doesn't get recognised. I am currently using a USB stick as this is the only thing that seems to...
  18. Alfa MiTo
    Hi all, I've had my diesel Mito for what must be nearly 7 months and haven't had any problems until now. I'm not sure if this is actually an issue or if it is meant to be making these noises but.......when in what seems to be only 6th gear, and travelling over 60mph there is a loud whirring /...
1-18 of 32 Results
Top