Alfa Romeo Forum banner
heating

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 186 Results
Advanced
  1. Alfa Giulietta
    I have a problem with my heating, it is very weak with no hot air coming out the driver side whatsoever and luke warm air coming out from the passenger side only with recirculation on. I have tried the usual, checked the coolant, flushed the matrix, checked the resistor pack and like someone...
  2. Alfa MiTo
    Hello, I have a MiTo from 2009 with a 1.4 turbo engine ... and no interior heating. The problem is the outlet pipe on the heater matrix is cold, the inlet is very hot (after the engine warms up), the heater flap actuator is working, the engine warms up quickly and doesn't overheat, there is no...
  3. Alfa 147, 156 & GT
    hello every one .have a nice 147 2.0 ts 2003 .no problem at all.in the city with ac turn on with 38 degree out side very fine . only over heating when i go uphills any suggesting i'll be thankful
  4. Alfa 147, 156 & GT
    Hi guys I have a GT 3.2 V6. It just started overheating and engine cuts out. Have to wait until it cools before driving again, but only 2-3 min the same happens. My electric fan has also stopped working because of this. Help?
  5. Alfa 159, Brera & Spider
    Hi all Got a warning saying Pre heating glow plugs not available. And check engine light. With four fault codes P2014 P2620 P0045 P0403 Has anyone encountered this before. Or would the know the codes. Thanks for the help.
  6. Alfa 159, Brera & Spider
    I’ve noticed that the cabin heater doesn’t give out much heat, if any? Could someone point me in the right direction as to cause? I can set it at full chat but no heat comes out of the vents, sat at 22 deg for last 105 miles but never got to that temperature inside the cabin? Anyone had this...
  7. Alfa 147, 156 & GT
    I had the aircon regassed in my 156 2.0 TS last week, but the interior fan decided not to work whilst it was in the garage so they were unable to test the system. They've told me I need a new heating fan resistor, but at £193 plus labour, thought I would try and search for it myself. However...
  8. Alfa 147, 156 & GT
    Wonder if anyone could advise .....have done a search in here but can't find anything similar. Bit of background ..bought the car end of last year and it basically sat over winter. Now back on the road. One thing the previous owner advised was that temp was unreliable - engine running cool on...
  9. Alfa 164 & 166
    So I'm tracking down the temp control issues on my 164 (pretty sure its the stepper eeeeek) as the mixer flap lever on the blower motor housing only moves about an eighth of an inch from hot to cold and it also makes that classic broken stepper clucky noise! Anyway, I have replacement steppers...
  10. Alfa Giulia
    Hi! Is it normal that the rear window heating does not heat the top 10-15 cm of the window? Heating "lines" in this part of the window are also differently (more) spaced than the ones lower (why?). See the attached photo, the foggy top is where snow/ice stays unmelted when heating is on.
  11. Alfa 164 & 166
    Hey guys... does someone maybe have pointers where to search for electric problem... In one moment heating died (all ventilation - ICS says 'momentary connection to air condition faulty'), but as I noticed also electrics seats, seat heating and rear window heating don't work... Heating would...
  12. Alfa 159, Brera & Spider
    We got in the car yesterday to find an alarm error message on dash (alarm not available) and no power at all to heating console, also the odometer is flashing. Everything was working the previous evening. The alarm doesn’t work on keyfob now either but keyfob does lock the car. Any ideas would...
  13. General Motoring Discussion
    So......I have pondered this for a while, as I was reluctant to post the question for fear of sounding certifiable. I keep my Spider in one of these Carcoon-type jobbies - a sealed, indoor tent affair which cossets said car from the ravages of the Welsh “climate”. To keep the humidity vaguely...
  14. Alfa 147, 156 & GT
    Hi, I have a alfa 147 facelift model. The seat heating no longer works :( I checked the fuse. The fuse was OK only i dont have 12v here. Does anyone know if there is another fuse for the fuse box?
  15. Alfa 159, Brera & Spider
    Arrrgggghhh, definitely wrong time of year for this to happen hopefully you guys can help. A couple of months ago the heating system in the Brera started playing up where it would only blow air out of the front vents. This would happen sporadically then everything would go back to normal. Now...
  16. Alfa GTV & 916 Spider
    Hi everybody sorry to sound totally clueless but my dad has just bought a ALfa romeo spyder and he knows it needs a new Rio stat. Description from my dad was “ like a switch on the electric motor”. Just wondering if anybody knows the best place to source a spare one. Thanks for not taking the...
  17. Alfa 159, Brera & Spider
    Hi all. Not posted in a while but have a climate issue. Can select Auto and get air on Feet, face etc. Can select just face or windscreen and all OK Try to select feet and nothing happens - this is both driver and passenger. Any ideas
  18. Alfa 164 & 166
    I have a strange problem with my 166 2004 3.0 cabin heating. It heats up only when racing :-). If going normally and not revving much, it won't heat up normally. If not driving at all, just engine running, the cabin fan won't start blowing at all. Outside temperature is not very low (0...
  19. Alfa Giulietta
    Hi all, New Alfa Giulietta owner but experiencing a few issues, who'd have thought? So firstly my tailgate lights on one side are not working but it appears that is likely down to the loom based on my search! Another issue however which I havent been able to find anything on is that the dual...
  20. Alfa 159, Brera & Spider
    So i found a small bracket in the drivers side foot well. A small bent elbow piece with a ball and socket end. since this has popped out i have no heating on the drivers side just cold air. is this an easy fix, where do i re-attach as i can see any simple fix. Thanks
1-20 of 186 Results
Top