Alfa Romeo Forum banner

fuel or starting

  1. Losing Power while driving in my 89 spider graduate

    The Classic Alfa Romeos
    I am a newbie and like to think I can fix and solve problems but now I am losing it on trying to solve this issue in my 89 spider graduate which I have owned for 12 years. The issue/problem - Car runs great, starts up and goes, sometimes I can drive it 20-40 miles and no issues then this past...
  2. HELLPP!! Fuel problems...

    Alfa 147, 156 & GT
    Hi, I have a ALFA ROMEO 147 2.0 5DR TS LUSSO... I have just had a problem that has happened once before that I brushed off as an electrical problem. The car was parked on a hill, got in and attempted to start and it juddered and stopped. Second attempt to start, it did perfectly but the fuel...
  3. not too technical but useful fuel/starting advice

    General Alfa Discussion
    so the alfa gt costs me £££££ for the third time in four months, now it has to go! but before i get shot of the poorly put together lump of italian sh*t!! a word of advice for those who have had intermittant issues with cutting out or non starting, I had issues with "lumpy" running and the odd...
  4. 156 V6 runs and cuts out

    Alfa 147, 156 & GT
    Hello Guys I am scratching my head about this one, don't even know where to start! My 2003 Sportwagon 2.5 cut out yesterday. I pulled away in traffic, it hesitated, I released the clutch and the idle slowed right down and the engine didn't respond to the throttle. when I switched it off anf...
  5. 156 jts 2.0 Engine Died & Won't Restart

    Alfa 147, 156 & GT
    I was going up a ramp in a multi-storey car park yesterday, and just after I reached the top, the engine slowly died and wouldn't restart but turns over fine :cry:. It felt just like running out of fuel but I know there is fuel in the tank as I put £20 in that morning. The fuel gauge was reading...
  6. Alfa 145 TS fuel/starting problems - help. please

    Alfa 145 & 146
    Hi I'm a newbie to the site and have to thank so many of you for the friendly welcome messages I've received. My 145 has given little trouble over the past couple of years, but this week is playing up something serious. It was running fine, then just died when I was driving. It would crank...
Top