Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-8 of 8 Results
  1. The Technology Section
    How's that?:confused: I'm using a fairly old RF mouse connected to a usb port so I guess it's a vunerable state of affairs? Annoying of course, but I've lived with it for quite a few years now, but I was just wondering if I should get a wired mouse as a replacement? :confused:
  2. Alfa MiTo
    Took my QV for a blast over the moors at the weekend and was amazed by how often the hazard light quick flashy thing was going off under braking.. Does anyone else find this "fun alarm" a bit annoying?
  3. General Alfa Discussion
    Hi, I would like to get a really reliable garage in the south to ensure my car is well looked after for years to come. Dont mind travelling quite a distance so any recommendations are welcome as long as the garage has been trading under the same company for a number of years. Appreciate there...
  4. Poll Room
    Well ...? :confused:
  5. Alfa 147, 156 & GT
    Folks, I recently hear the fan starting frequently even in idle conditions. Its a 04 1.9 JTDM remapped, 61K miles. Note: The temp gauge on the dash always shows and have shown below 70 deg. 1. can someone please tell me why the fan keeps running frequently...? 2. Is it something to do with...
  6. Alfa GTV & 916 Spider
    Would any of you be interested if I were to piece together a thread with a list of FAQ's, things like Heater Problems, window problems and then ask Admin to make it a sticky topic? By this I mean that whenever I come across a thread which seems relevant I would add the link to the FAQ list.
  7. Poll Room
    OK, in my handbook it tells me that it's normal to use a litre per 1000 miles (147 GTA). And as apparently the warning lights on 'some' cars are not exactly good at telling you that you have no oil in the engine! I check mine every weekend to be on the safe side. So how frequently do you do it?
  8. Alfa 147, 156 & GT
    Hi guys, maybe you can help me! The A/C compressor in my AR156 is comming on and off every second, and it sounds like loud clack-clack. Sometimes, when it is not very hot outside, it works fine. The pressure of the gas in the A/C is ok, I checked it. What could that be? Thanks. GFitega
1-8 of 8 Results
Top