Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-16 of 16 Results
  1. Alfa 147, 156 & GT
    Hi everyone I'm 19 and I've recently bought my very first Alfa, it's a 2004 147 1.9 jtd turismo edition, and the car was running great until one day I was driving and thewn suddenly my rev counter went to 0 and I lost all power and power steering and the car stopped and the engine system...
  2. Alfa 147, 156 & GT
    Hi all I've taken ownership of a 2000 'Y' reg 156 selespeed and it's had the engine management light on for the past 3 months and driven like a pig. I've hooked it up through the OBD connection and have the following error codes to report; PO136 PO141 PO150 PO155 PO300 PO302 PO303 P1155 P1178...
  3. Alfa 159, Brera & Spider
    Hi All, I'm new to the forum and have seen this asked elsewhere, but not quite the same as the issue I have experienced. I own a 2006 159 2.2 JTS petrol, lovely car and enjoy every minute driving it. It recently threw up an engine warning and was diagnosed as having a stretched timing chain...
  4. South Africa
    so car went into cargo bedfordview for its serive, great team at this dealer highly recommend service department apart from cramped parking lot. Upon resetting service indicators they picked up a start/stop failure and abs sensor failure. sensors replaced and then BCM(body control module) fails...
  5. Alfa GTV & 916 Spider
    Hi All (and Happy Christmas), On a 2 mile trip returning from the local Sainsburys my engine management light has turned on (amber colour). I have ordered the cable to try and diagnose the issue, but until this arrives I am a bit stuck. I will try and describe the situation as much as possible...
  6. Alfa 147, 156 & GT
    I was driving yesterday evening when the engine undramatically turned off. (There may have been a quiet crunch under the bonnet, but I may have imagined that.) Upon trying to restart the engine, the started motor whirs healthily but the engine does not turn over at all. An engine warning light...
  7. Alfa 147, 156 & GT
    Last night while driving up a hill, the car lurched and the engine management light came on, the beeper went of and Motor Control warning came up on the central display and it started running really rough...like it was on 2 1/2 cylinders. So I have driven it home and parked it up and apart from...
  8. Alfa 147, 156 & GT
    Hi, not been around for about 3 years since I sold my lovely 156 1.6 twinny for a 2008 Leon TDI. Anyway the Leon's been great but the arrival of our first child has meant that my wife needs a bigger car and she is getting the Leon.......so I can get a 156 back! Want a little more poke than my...
  9. Alfa 147, 156 & GT
    I have recently had a replacement engine fitted to my 2005 156 2.0 JTS after a cambelt failure. The engine warning light and motor control system failure warning flashes when the engine is started so the (not alfa specialist) mechanic plugged in his fault code reader to be given a code which...
  10. Alfa 147, 156 & GT
    So today I went to a few garages to try to get my oil/filter changed on my 156 2.4tjd 150. As everywhere was busy, I decided I would do this myself, I thought it might be fun... To cut to the point I ended up filling the new oil 10W40 semi, without fist reattaching the sump 'nut' so I lost the...
  11. Alfa 147, 156 & GT
    Hi Guys, This is my first thread so hi to everyone. I've planned a trip to France starting next week and this happens. Can anyone near Moreton, Wirral run a diagnostic on my car please???? My problem first arose when entering a large round about I lost all power. I thought I'd put the car into...
  12. Introduce Yourself
    Hi all Just a quick note to say hello and thanks for all the posts on this forum. Really helped in my search for a Brera. I think I must have read them all over the past few weeks :) Originally started off looking for a 2.4 diesel but I ended up buying a 2.2 JTS with 41k on the clock and a...
  13. Alfa 147, 156 & GT
    Hi all, Had my old 2002 10v since last September. Bought her for a fair price at 800 quid and in all honesty she goes like a train. She has 156k on the clock (very apt) and does 2 -400 miles every week without missing a beat and even with my lead foot she returns 41mpg's. She has a...
  14. Alfa 164 & 166
    After running out of fuel with my 166 2.4 diesel , the engine management light stays on . I guess it's got something to do with the engine being without fuel . how do i reset this . thanks , Edwin
  15. Alfa 147, 156 & GT
    I washed my engine on Saturday. Since then I couldn't exceed 90kmh. I keep on getting the message Engine Control System Failure. I did a ECU reset with no luck. Today the car wouldn't exceed 1000rpm. I checked all the fuses, and now I get the message Immobilizer failure which I don't have a code...
  16. Alfa 164 & 166
    Hi Alfa Forum. This is my first time on forum. I am danish :) so please excuse my english. I have a Alfa 166 3,0 from 1998. We bought it in december 09, and during winter there was no problems at all, and we just loved every single kilometer, the feeling, the sound - you know :). Then suddenly...
1-16 of 16 Results
Top