Alfa Romeo Forum banner

electrics

  1. Alfa 159, Brera & 946 Spider
    Hi All, I hope you are well. I wonder if anyone else is familiar with my sudden electrics issue, and has any advice for me. I've had a problem this week with no electrics in my 159, meaning I cannot start it and I cannot lock or unlock the car electronically with the fob. The usual dash lights...
  2. Alfa 147, 156 & GT
    Hi. Just picked up a rather nice GT as a project and am experiencing a few odd issues. Hoping some will be linked. Issus: 1. Remote key fob doesn't work. Unlock, lock and boot buttons do absolutely nothing. Installed new fob battery but still nothing. Can still lock doors using key in door...
  3. Alfa GTV & 916 Spider
    Hi, I have just bought a 2003 Phase 3 GTV, and having got it off the trailer into the garage, I have discovered the car is completely dead (it was supposed to have a battery but the battery is brand new and fully charged). When the key is inserted and turned there is no response from the car, no...
  4. Alfa 159, Brera & 946 Spider
    Hello all! So I guess I should introduce myself as I'm new to the forums; I'm Lewis. I bought the Brera in January as the Audi TT got written off by a drunk driver and I'm loving it more than I expected! So I have a Brera 2.2 JTS, and as of yesterday I took the passenger side rear light out to...
  5. Alfa 159, Brera & 946 Spider
    drove my 09 alfa romeo 159 about 2 miles , parked, spoke to someone for 5 mins, tried to start no electrics, key not recognized flashed up, tried and tried and finally it worked, however whilst driving all the electrics went ,guages, indicators, speedo etcnothing at all but engine ran, till i...
  6. Alfa 164 & 166
    A bit random and scary here! If I have the 166 idling, and turn on the wipers or windscreen washer - the car stops dead! Just hope it doesn't decide to do it on the road! Any theories welcome! PJ
  7. Alfa 164 & 166
    Does anyone have a likely tip for this? My cigarette lighter (aka sat nav feed) has power when ignition on and in the ACCESSORY position. But it goes dead with the motor started. This was an intermittent fault for a while, usually cured by stopping, switching off, and restarting. Any ideas...
  8. Alfa Giulietta
    Just wondering if anyone has fitted a towbar to a Giullietta?? I’m fitting one but not sure on the electrics....do I need to fit a bypass kit with a dedicated fused live? I only want to fit a 7 pin connector for a trailer. Any help will be gratefully received....esp wiring diagrams ?
  9. South Africa
    Hi All... anyone come across a dead battery with alternator working... finding fuse 3, cabin fan varying 600mA to 1A, and fuse 4, services 400mA, and driving lights draining power with ignition off. I realise the clock will take some. Still looking.
  10. Alfa 147, 156 & GT
    Hi all, i am new to this site and my first post. I have recently bought a second hand 147, 1.6 T.spark Lusso (its a 51 plate if that helps) and i have discovered a few problems... 1) the rear passenger doors, one of them remains open (all the time!) and the other is permanently locked! and...
  11. Alfa Giulietta
    Edit This thread started with my enquiries regarding wiring towbar lighting to the car but moved on to a detailed description of choosing and installing a towbar at post #16 I have fitted towbars to all my Alfas and just clipped the socket wires to corresponding wires in the rear of the car...
  12. Alfa GTV & 916 Spider
    Two questions on this photo. 1). I found this connector tucked down, it looks like it has been disconnected for a while. Black white wires coming from the engine, two blue wires vanishing off to the left of the headlight. Any idea what it's for? 2). Looks like someone in the past has...
  13. The Classic Alfa Romeos
    I have recently bought a series 3 Spider (1600)and the electrics seem to have a mind of their own. The warning panel has lights flashing, in particular when the wipers are operating. The ammeter does not work and the instrument panel does not light up when the road lights are on. I enjoy driving...
  14. Alfa 147, 156 & GT
    Hi there everyone :) I have just become the owner of my first Alfa and its been a long time coming, couldn't be happier. Its a 156 1.8 T.Spark Veloce x reg which i picked up for a very good price. Unfortunately I have already hit my first hurdle and would like some clarification please. When i...
  15. Alfa 147, 156 & GT
    My indicators don't work and neither does the A/C or any of the windows regardless of whether you do the drivers panel or the buttons on the individual doors. Is there anything I can do in a pinch to sort it? Or is it time to take it somewhere ASAP? Any help would be much appreciated guys!!!!
  16. Alfa GTV & 916 Spider
    Afternoon all, I just signed up to try to get some assistance. I bought a 1998 GTV 2.0TS a few months ago and it's been faultless up to this week. I went to start it (after a few weeks lack of use) and it was totally dead. I tried charging the battery on the car and it was taking a lot of...
  17. Alfa 147, 156 & GT
    so early this evening around 6pm i parked the car up and was kinda warm inside the cabin so i put the windows down.... later on - just after 8 i went back to the car got inside put the key in and the windows wouldnt go up on either drivers or passenger side.... i thought fk it man argh bitvh...
  18. Alfa 147, 156 & GT
    ok so this morning the car was fine working fine. its a 99 156 2.5 v6 now the following has stopped working: Indicators Wipers Air con Electric mirrors probably more checked the fuses both in the car and the large ones on the battery as per the owners manual also had a good look round and...
  19. Alfa GTA
    The track car is pretty much there and just trying to get ready for the MOT. Having gone through a fairly extensive lightening process recently and starting to do some tidying there are a couple of items I need to sort. Having reduced the interior to just two race seats and the loom by about...
  20. Alfa 147, 156 & GT
    hi everyone,new on here,think i may have just posted this in the newbie section,sorry,just bought my second alfa,a 156,51 plate,1.6 twinspark with 59,000 on the clock,bought it as a non-runner,was told it needed a new radiator,got it home on a transporter today,and the battery appeared flat,took...
Top