Alfa Romeo Forum banner
electrical
1-20 of 205 Results
Advanced
  1. Alfa GTV & 916 Spider
    Hey, On my Alfa GTV 2.0 TS (1996) my battery wasnt charging somehow. 1. Bought new battery (everything was the same) 2. Checked for alternator charging (easily 14.5V with max load (lights, radio..)) 3. Checked for battery current draw when car powered off (15mA) Nothing of these was the...
  2. Alfa 147, 156 & GT
    Hi all. New to the group and need help with my 2005 1.9JTD Alfa GT if you could please. Today as I started out driving I pressed the windscreen button on my heating / AC panel to clear the screen. The tempature was reading 15°c on the dash and the heating / AC was set to 19°c. After about 5...
  3. Alfa MiTo
    Hi guys, when I start the car, the rear wiper blade comes on and does several sweeps then stops in the middle of the screen. Does anyone have an idea of what will be causing this? Thanks in advance.
  4. Alfa MiTo
    Hi Guys and gals! At a bit of a loss here with the electrics on my MiTo. Started having warning lights pop up whenever I would press the brake pedal (losing ABS, steering corrector etc) and the car would force itself back into 'Normal' mode. Then the instrument cluster died, which was a blown...
  5. Alfa 147, 156 & GT
    Hello alfa owners, I recently bought a second hand (2006) 147 jtd 1.9 with a lot of kilometers (250 000km), it had a clutch problem that I'm taking care of today, installing a new kit, I suspect electrical problems because when I turn the key, the first 10 seconds I hear noises on the speakers...
  6. Alfa 147, 156 & GT
    Hi Legends, I hit a pothole on a single lane, front suspension bottomed out and scrapped the undertray, now the horn doesn't work when the headlights are on, the indicator relay flashes fast and the drivers side headlight is dim and playing up, see pics. 1st pic is low beam, note dim on drivers...
  7. Alfa 147, 156 & GT
    Evening everyone, I was wondering if anyone has any ideas on this. On starting my GT, when I put the dipped beams on, the instrument cluster illumination sometimes goes out. Or flickers on and off. When this happens, if I switch the main beams on, the dipped headlights and the instrument...
  8. Alfa 159, Brera & Spider
    As the titel says, the right rear lights wont go out when i turn off the lights, and when i turn of the ignition. Where do i start to find the problem? And is there a temporary fix so i wont drain my battery over night? thanks
  9. Alfa MiTo
    Hello to all, I have been wandering around this forum since I bought my first Alfa, 2 months ago, but without any needs for assistance. The time has come. Fyi, mine is the JDTM 1.300cc 85PS Distinctive model of 2013, Diesel, with 59000khm. As I started today, and run for 300mtrs, electrical...
  10. Alfa 147, 156 & GT
    Hi all, 2 days ago had massive rainfall and water got in the bootleft side behind the rear light. And the upholstery is wet. Not sure if it’s linked to my problem... can find anyone in here with the “exact” same problems but I’ll list the symptoms. Dashboard Warning lights Displays... Door...
  11. Alfa 159, Brera & Spider
    So having some issues with my washer jets, they’ve stopped working (the wipers go when I pull the stalk) The tubes are not blocked. Tried replacing the pump the other month only for it to start working again (I put the new pump on, didn’t work, then the old pump back on which then worked). So...
  12. Alfa MiTo
    Hi Guys. iv posted earlier about a possible problem with my car however after some inspection this has now been cleared up however today iv had the - EBD fault check handbook - power steering fault check handbook. all the while the full dash is flickering on and off intermittently every few...
  13. Engines (TS, JTS, JTD & V6)
    I recently replaced my idle speed actuator (and reset it through diagnostics) to cure my idle hunting issue, but now I have another idle issue! When I've driving around normally, with no lights on, no radio, no AC, when I depress the clutch to come to a stop the idle drops to around 500rpm then...
  14. Alfa 147, 156 & GT
    The 147 M Jet TJD 1.9 8V engine looking for the pressure sensor electrical plug to try and stick the box MOD in line. Problem, not 100% sure which one is pulled. I think it's the one at the back of the engine on the common rail, in the middle, although as said not 100%. an ass to get at one LOL...
  15. Alfa 159, Brera & Spider
    Hi all, my first post in a very long time. I have a 2.4 159 Ti, and it's just gone into a bit of a meltdown. I tried to start it this morning and the electricals were flickering aggressively - as if it has developed a short connection. Any help finding it would be a great help! What happens: I...
  16. Alfa 147, 156 & GT
    I've recently had an incident where I have been driving and suddenly all the electrical in my gt 3.2l turn off such as speedometer; a.c.; display screen and all lights. If anyone has experienced this plz let me know so I can diagnose the problem. The car would still be on and driving will still...
  17. Alfa Giulietta
    Hello Everyone, I recently bought a 2014 1.4MA Sportiva Nav TCT. Loving it, looks great, drives great, but have a few strange electrical "features" that I would love to get to the bottom of and would appreciate if anyone could share their experience of similar issues. I couldn't find any posts...
  18. Alfa GTV & 916 Spider
    Hi all I have just bought a GTV with the V6. Haven't been able to properly enjoy it yet as it needs a few bits sorted. The first is the heater/ air con unit. At the moment the blower is on all the time even with the ignition off and key out. The only way to turn it off is to pull the fuse out...
  19. Alfa 147, 156 & GT
    This applies to all 147s, 156s and GTs equally. Now the cars are older, it is quite common to experience multiple electrical faults which are due to the deterioration of electrical connections. Any car with strange faults should firstly have this attended to before looking any further. This is...
  20. Alfa GTV & 916 Spider
    Hi all, waking the spider up after the winter and it won't start, even off another working cars battery. The solenoid clicks but the starter initially turned slowly but then no longer turns. Added to thus the lights do not come onbut indicators do, windows go up and down, blower works but...
1-20 of 205 Results
Top