Alfa Romeo Forum banner
dna
1-20 of 108 Results
Advanced
  1. Alfa Giulietta
    Hello everybody....I am just looking for some advice about my 2012 giulietta 1,4T The DNA system doesn't seem to be working and when I start the car I get notifications for the following: EBD ABS VDC ASR hill holder alarm steering corrector All of these are unavailable....I was hoping somebody...
  2. Alfa Giulietta
    Just taken purchase of my Guilietta which I absolutely love. While out driving the Sussex roads thought I would switch to D to see this performance set up everyone goes on about. The car felt like a different beast which was great. When I switched back to N white smoke started coming out of the...
  3. Alfa Giulia
    I rarely drive in any other mode than D. But every time I switch off and then power up, the selector is in its default N position. Can this be overridden so that the last used mode is remembered upon power up (in my case D)? I know it's a small detail, but would love to know if this is possible.
  4. Alfa Giulia
    Not had my new-to-me Giulia long and been trying out the different modes, had it in D for a while, come to go back to N & it goes straight to A. Doesn't matter which way you turn it, it will only select D or A. Anybody got any tips for an easy fix or is it a trip to the dealer?
    dna
  5. Alfa Giulia
    I'm wondering if anyone else noticed their DNA switch is getting really hot to the touch. Seems weird to me since I can't imagine there is much going on in there to cause heat.
  6. Alfa Giulietta
    Hi I have a Alfa Giulietta 2016. 1.4lt Turbo with TCT. The issue I have is that when i hit a speed of 120KMh, the leaf symbot under the letters DNA in my multifunction display turns red. i have read the user manual but it does not mention "this feature". The service department at my...
  7. Alfa Giulietta
    I picked up a 66 plate Veloce a week or so ago, which had old maps (now updated - thanks!) and a DNA-specific menu option above the eco-mode thing on the U-Connect Live 'app' with lots of extra gauges. The U-Connect app on the phone told me I had to contact the previous owner to access U-Connect...
  8. Alfa MiTo
    I have a Mito Veloce yr 2009 which I bought 5 months ago, it has been lovingly cared for however I do have a little (hopefully) problem, symptoms are DNA not working and the engine warning light came on yellow with the message check engine. The engine light stayed on for a couple of hours but...
  9. Alfa Stelvio
    Hi, The DNA control has just stopped working (not light up and cannot select drive modes) in my Quadrifoglio? Tried ringing the service dept of the dealer it came from but they’ve left for the day.. any ideas what’s wrong? Car still drives ok but guess just stuck in N mode.
  10. Alfa Giulietta
    Hoping someone can point me in the right direction of where to look! A couple of days ago, I noticed that the light on the DNA switch was flickering when in 'N'. I also noticed that the backlighting on the instrument cluster was only part-working (it all works apart from a very specific part...
  11. Alfa Giulietta
    Hi, in the last couple of months i have a general error indicator sign. when connected the car to the fault reader in the garage, they said its a malfunction with the DNA switch and it needs to be replaced (silver switch next to driver seat). i don't have any technical issues, DNA switch is...
  12. Alfa Giulietta
    Hi, I have just bought an Alfa Giulietta 1.4tb veloce 2010 and I love it. But when trying to use dynamic it will select it then go stait back into normal without any warning lights etc. All weather doesn't work at all. I can keep it in dynamic if I hold it but when I let go it will change back...
  13. Alfa Giulia
    This may be specific to the manual Quadrifoglio, which I know would exclude the US and UK owners, but hope someone can still chip in: I find that the exhaust is somewhat droning around 3000 -3500 rpm when in 6th gear (this equates to 150 - 165 kph), and also no discernible difference in sound...
  14. Alfa Giulietta
    Hi, has anyone had the light(s) stop working in their DNA switch? What are the bulb replacements LED? and are they readily available? Is it easy to access? My "N" light has stopped but "D" and "A" are working. Thanks in advance for replies ;)
  15. Alfa Giulietta
    Hi all, New to the forum and had my G a couple of months (64, 2.0 diesel) The other day the engine management light came on just after I selected Dynamic. Then read the message " Check Engine" which then read "start stop unavailable." With the Start stop icon displayed where the DNA usually is...
  16. Alfa MiTo
    Hi guys, I have a Mito 1.3. Since I Bougth the Mito I noticed that the car has no dna switch, no blue&me, the charger does not work, I insert the adapter but seems like the energy does not pass to the adapter. Im just wordering whats the real model of the car, if i can install blue&me and dna...
  17. Alfa Giulia
    Dear All, Did a search and could not find ANYTHING on DNA. Basically when you turn the DNA control from D to N on the display it goes from D to A! Then switching from N to A the display stays on A. Then switch from A to N the display goes from A to D. etc etc etc.. So in summary the N seems...
  18. Alfa Giulietta
    Question for anyone who has had a remap, how does it affect the DNA switch? I've currently got the 150bhp model and i'm looking for a simple remap with no other mods - will the DNA switch still have a difference in power curve as it does currently? If it was stuck in D mode for example it...
  19. Dna

    Alfa Giulietta
    Hello I have just taken possession of a new 175TCT. Absolutely love it. However I had a small issue today with the DNA. It refused to go into the D position and when I knocked it onto A it then wouldn't go back to N!!!! I pulled over, turned the engine off and tried again. It went into N after...
    dna
  20. Alfa MiTo
    Hi everybody, A few days ago I noticed that D–mode (DNA) drops off to N–mode every now and then without any obvious reason. There are no messages in the instrument panel. This time it has nothing to do with the shock absorbers wiring, at least it seems to be so. With MES I got following error...
1-20 of 108 Results
Top