Alfa Romeo Forum banner

dies

  1. Alfa 147, 156 & GT
    Hi there. Ive recently encountered a bit of a problem with my 156. Engine randomly dies after starting up, no matter if hot or cold. Sometimes it dies instantly, sometimes for few seconds it runs very low on revs, shakes and then dies. It has new Spark plugs, new coils, new lambda new maf. What...
  2. Alfa Giulietta
    :smokin: Good day Giulietta enthusiasts. A couple of points to get out of the way before you point to them Batery has been replaced 2 weeks ago The car had a pedal box fitted which I removed soon after experiencing this issue The car has a Unichip fitted I have checked the sensor on the...
  3. Alfa GTV & 916 Spider
    Am baffled, Left my beloved Spider sitting for 6 months and now it starts, runs very roughly for 30 seconds or so, dies and wont start again for hours after. Has fuel and spark. The check engine light on the dash has been coming on sometimes and sometimes not for months now and I didn't have it...
  4. Alfa GTV & 916 Spider
    My 1999 GTV 2.0 tb runs for thirty seconds (exactly) then dies, check engine(injector) light comes on. Restarts immediately, no problem.
  5. Alfa GTA
    As the title says really. Very often when I go to turn it on after it had been left standing over night the revs drop and it almost stalls (sometimes it actually does) for a few seconds. After that everything works as it should. It used to do it only when very cold (around freezing) but now it...
  6. Alfa 147, 156 & GT
    My 156 TS 2.0 -01 die suddenly. It's minus 7 degrees outside. It starts perfectly. After a short while it has no idle. It goes well at higher revs. if I turn it off I can start it again. I drive about 3 km. Motor temperature is between 50 - 75. I slow down and speed is just under 1500. The...
  7. Alfa 159, Brera & 946 Spider
    My Alfa runs great when cold, but once the engine warms up, it looses power and eventually (after about 10miles) stops, refusing to start again. The Engine light comes on and error code P2620 Throttle Pos Output Circ/Open. The car has the EGR blanked out, as well as the DPF replaced with a...
  8. Alfa 147, 156 & GT
    Hi guys, I have owned my Alfa 147 Jtd for more than a year now and the strangest thing has been happening for the last month or so. The battery is completely dead at random times. I took it to my local battery fitment center and they tested the battery and it is fine, according to them. Here...
  9. Alfa 147, 156 & GT
    Hi, 2006 20v 156 The Short..... The car will only fire briefly reaching a max of 700rpm then dies. The low pressure pump is giving good pressure and ive put a new fuel filter in. There are no error codes either. The Long.... Bought in as a non runner, aparently it just died and never restarted...
  10. Alfa 147, 156 & GT
    HI, I have fitted a new battery into my but problem has re-appeared. I use the car just for work so it sits most weekends. The last 3 Mondays the car has been dead and I need to jump start which it does each time. The battery gets up to14.16V and I can it rise to 14.2 when I use the acc pedal. I...
  11. The Classic Alfa Romeos
    Help , my s2 weber carbs 2.0 spider is hating the heat , something is wrong ! The car starts form cold and is a bit rough , but soon settles it will drive smoothly for as long as it is cool and free , but as soon as you stop and it warms up it starts to misfire and lose all power. The engine is...
  12. General Alfa Discussion
    I understand that Western Perth are closing - having lost Saab when they folded, they haven't found a suitable replacement and can't survive on Alfa alone. Their Glasgow and Edinburgh sites are continuing, and they hope to redeploy as many staff as possible - but it'd be a big commute...
  13. Alfa 147, 156 & GT
    Hi Everyone, Got my 147 from a friend in December - been a charm to drive! until the last few weeks.... First off - it started not wanting to ignite... the engine was turning seemed all good.. after 2-3 attempts it started... so I didn't think more of it. I was not consistent but rather...
  14. Alfa 147, 156 & GT
    Hi All, I've bought a relatively low mileage ('04, 80k) straight car with every JTD problem listed on the forums. What I find most strange is that when driving, very carefully as it has lots of other issues, if I lifted off anything but very slowly the engine died and would only start when...
  15. Alfa 147, 156 & GT
    Hello, I was showing the car off to a buyer and during the test drive the original media system(blaupunkt, big screen telephone and such) decided to die out and made a strange sound aswell through the speakers, after a little while the light for the buttons below died aswell... Anyone know...
  16. South Africa
    He was returning from a charity event, he was the passenger in a Porsche GT that left the road and hit a tree.. Happened around 15:30 yesterday RIP :(
  17. Alfa 155
    I've come across what could be a real bargain. The car is super cheap and looks fine as a daily driver. The only info I have on it for the moment is that it starts up and runs for just over a second, then dies again. The owner have replaced the ignition coil and the air mass meter without any...
  18. The Classic Alfa Romeos
    Hi My 1992 Spider regularly loses all power when driving along and I have To restart the engine. It also just fires on three cylinders on some occasion and backfires. I have had the HT cables checked, plugs, points and rotor arm. My garage has tried to find the problem but no luck. Any ideas...
  19. The Technology Section
    I always find the Bose sound quality a bit synthetic but he had a theory Amar Bose
  20. Alfa 147, 156 & GT
    Please help driving to work this morning, cruising along as normal on the motorway doing around 60, for some strange reason the temp gauge goes to spot on 90 quicker than normal, turn the heating on but is cold air, then after a few moment, the engine dies, lose steering, barely get on to hard...
Top