Alfa Romeo Forum banner

cut

  1. Alfa MiTo
    Hi! I have mito qv (2010) i have boost cut and fluctuation on high rpm. During full thorttle the boost going to peak... and... i hear PIISSTTT sound at dv. After going to high rpm (4500+rpm) boost begins to fluctuate (for example 20psi>12psi>18psi>14psi...) I'm using MES and torque pro with...
  2. Alfa 147, 156 & GT
    A few days ago my 1.6 cut out, EML came on and as I had my ODB cable in the car, I checked the fault. It was P0335 CPS circuit malfunction. Car started up again, so I left the fault there and drove home. Checked again and the fault was intermittant (rather than present). I cleared it and it's...
  3. Alfa 159, Brera & 946 Spider
    I have been slowly ticking items off the list as to why my car wont start (2.4JDTM). The fuel pump works when i put power to it, i have checked fuses and relays, created a new earth thanks to a corroded battery earth(although i am struggling to locate any other earths on the engine), flicked the...
  4. Alfa 147, 156 & GT
    Hello all! Ive just purchased my first alfa! And i loved it, until i was driving home tonight and "motor control system failure" popped up in front of me. Followed by a short stint in limp mode and finally coming to a halt.. And now it won't start! It just cranks over on the key. Before this...
  5. Alfa Giulietta
    So I've owned a 1.6 for two weeks now. I was in a queue of traffic so start and stop was working, then at the next stop it said start and stop unavailable as the engine stopped with the oil pressure light coming on. Restarted without problem. Any thoughts?
  6. Alfa 147, 156 & GT
    Hi all, The previous owner of my other halfs 147 cut the wiring loom and I'm having some trouble working out which wire is which. So behind the old radio, you have your 8 speaker wires, then the following wires: Grey Red/Black Green/Orange Black/Pink White/Pink Can anyone help me identify...
  7. Alfa Giulia
    Sodding typical. Stressed out by my father’s continuing decline in his nursing home I curb one of my immaculate wheels when leaving. Is the metal part lacquered or is it bare metal? Is there any way of fixing this with a localised repair? Would have thought the radial grooves would be hard if...
  8. Alfa 147, 156 & GT
    Hi lads, Any help greatly appreciated. My 147 1.6 cut out suddenly while i was driving now it won't start. The fan belt will turn but the timing belt doesn't. All fuses ok. No faults on dash although did have low oil alarm couple of days before and topped up. tried the fuel cut out switch...
  9. Alfa 159, Brera & 946 Spider
    Hi guys, couldn't find anything related to this. Started car today just like normal holding down the start button when all the electrics when dead. Normally it takes a few cranks until it starts up but just went dead on the third crank and didn't start at all, like the battery lost all its power...
  10. Alfa 159, Brera & 946 Spider
    Greetings all, I have checked a few places but can’t seem to find anyone with similar problems, they all mention codes or dash lights, mine has neither. I bought my 159 1 year ago (04/02/17). The engine cut out/stall literally feels like the engine stops, but there are no warning signs, no...
  11. Alfa Giulia
    As title, has anyone got any yet?
  12. Alfa 147, 156 & GT
    My 04 GT diesel just stopped yesterday. I've read the error codes using Multiscan but nothing to give any clues there. It turns over fine but doesn't fire at all. Just read somewhere that it could be the fuel cut off switch. Does the jtd have this switch and where is it. Thanks in advance for...
  13. Alfa MiTo
    HI, Help anyone ! Bought a damaged car, off side suspension damage, done all repairs, everytime I turn the ignition on the right indicator is flashing, I realise I cant reset the fuel cut off until I get the indicators working as I understand thats how to reset it. I bought a new indicator...
  14. Alfa GTV & 916 Spider
    Hi everyone, Big problem with the TB and can' find it. Started a few months ago. At +-4000rpm in 3th gear the engine cut's out and won't start again till after a few hours. Then he drives again without too much problems. Sometimes a bit hesitating when iddle and nearly cutting out. But when...
  15. Alfa 159, Brera & 946 Spider
    Hi there, Would love to have some peace of mind on a problem that's happened to me twice now. Every Friday the traffic is stupidly bad when leaving work. I get stuck in non moving traffic for 15-20 minutes before I can get past the main problem point and actually get going. A couple of weeks...
  16. Alfa 159, Brera & 946 Spider
    So once again I come out to my car this morning after leaving it sat on the drive for about a week only to find the battery dead and doesn't have enough power to start the engine. I've recently changed the battery (about a month ago) after thinking the old battery had given up. I'm losing hope...
  17. Alfa 159, Brera & 946 Spider
    Hi, I wonder if anyone can help? I have recently bought a 4 year old 159 diesel. Has been fantastic, and I drive monthly to Brussels from Manchester and back with no problem, until recently. The engine will cut out at various times-sometimes on the motorway-and the computer displays...
  18. Alfa 159, Brera & 946 Spider
    Recently purchased a 159 Sportwagon 2.4. It has an intermittent problem when pressing the start button, it shuts all the power off completely. Putting a buster pack on battery will solve the problem and it only happens roughly 1-20 starts. Battery tested at Halfords today all good but he did say...
  19. Alfa GTV & 916 Spider
    Hi mates! First some feedback: After 6 years parked in my parents house, I decided to bring back my alfa gtv TS 2.0. I had the cam belt replaced the battery oils and filters. Then I had a problem in the cooling system and the fans where not starting when they should but alfa workshop was able...
  20. Alfa 164 & 166
    Hit a big pot hole yesterday and lost the fuel injection. Lucky I run on LPG so could get home. Looking for the fuel cut off reset button which I thought was under the passenger seat but can't see it. I've checked drivers side to. Any ideas please
Top