Alfa Romeo Forum banner

cooling

  1. Alfa GTV & 916 Spider
    I have just changed a failed thermostat on my GTV Twin Spark, and it has also had a new radiator and water pump so the cooling system should be very effective. Before, the gauge would never move from 50 at idle, and got up to the first mark past 50 during normal driving. After parking up and...
  2. Alfa 147, 156 & GT
    I’ve been driving around in my GT for the last few months with the aircon off (as it wasn’t working). I recently fixed the aircon (leaking condenser) and it now works perfectly. However - now I’m finding that the cooling fan is triggering approx every minute - it runs for a few seconds, then...
  3. Alfa GTV & 916 Spider
    Hi Can anyone point me in the direction of where to find the slow speed cooling fan relay (199) please ? I have a 2001 3.0 24v spider and seem to have lost both my slow speed fans. I'm guessing that if one resistor has gone I would only lose one slow speed fan - surely they wouldn't both call...
  4. Alfa 159, Brera & 946 Spider
    Ignore this ... Solved.
  5. Alfa GTV & 916 Spider
    Looking for some advise please gang? Both fan speeds on my GTV kick in at the correct temperatures, but they only stay on for a matter of seconds. This means that the low speed fans never get a chance to do their job so the temperature rises to the point where the high speed fans kick in, but...
  6. Alfa 159, Brera & 946 Spider
    This afternoon my wife had a critical issue with here 1.75 TBi SW The cooling hose (item 4 in the attachment below) snapped off the quick fit fitting at the left end and dropped a lot of cooling water on the ground. Luckily it happened on a parking lot and not on the move on the highway. Have...
  7. Alfa 147, 156 & GT
    Clearing up cooling fan issues- resolved Some time ago, I noticed my JTS cooling fan didn't run on high speed. The reason is my A/C is removed. Details for micro relay, low speed fan (red, 30 amp, listed as FAN under relay cover: Terminal 86, small blue wire is normally dead (relay removed)...
  8. Alfa 147, 156 & GT
    Hi all, looking for a bit of advice on how to remove the cooling fan relays on the GT. Its the 3.2 Lt V6. Have unscrewed the nuts that hold the relays to the bracket in front of the battery, but for the life of me cannot pull the relays off ?? Any advice would be appreciated.
  9. Alfa Giulietta
    Evening, I have searched the forum but couldn't find a similar post, if anyone knows of one please send on the link. My cooling fan does not come on at all when driving or when sat in traffic, the car has not overheated at all in the 3 years I have had it. Can anyone point me in the direction of...
  10. Alfa GTV & 916 Spider
    Hi all, Just looking for a bit of advice/confirmation. My 2002 Spider 3.0 V6 has its cooling fans running flat out all the time. It also has the red light in the temp gauge on (maybe faintly), but the temperature rarely gets up to 50. Gauge appears to work as after a long drive the temp will...
  11. Alfa 147, 156 & GT
    Hey guys, For those not interested in the circumstances, you can directly jump to the next paragraph. :p I've had a good fear 2 days ago when a cyclist warned me than the car was leaking water and steam. The temperature gauge was normal, but some coolant liquid was indeed dropping. The coolant...
  12. Alfa 147, 156 & GT
    Hi Everyone, About 2 months ago the cooling fan in my AR156 FL 2003 2.0JTS Selespeed stopped working. I know there are many subjects on the forum about cooling fan problems but my case is quite unusual and I cant find a similar one. I searched many forums for possible fix but didnt find any. I...
  13. Alfa 159, Brera & 946 Spider
    About a month ago I replaced my thermostat. Thought I’d got all the air out but on checking the other day the level was low and when I took off the expansion cap loads of air came out and the level rose significantly. I bled a load of air out from the rail near the exhaust manifold. Checked...
  14. Alfa GTV & 916 Spider
    Ph 3 GTV V6 3.2. Only one fan is coming on at high speed at just over 90 c on the dial. Checked the resistors and relays, all seem to be good with multimeter. Also changed over the relays with no change. Switched the inputs and the other fan kicks in fine, so its not the motor. Running out of...
  15. Alfa GTV & 916 Spider
    Hello! This is my first post on this here - although I have been lurking for some time! I needed to change my leaky radiator and there were a few tips out there but no 'how to' guide as such. So, I thought I'd take a few pictures while I did it and put it up here incase it helps anyone out. My...
  16. Alfa 147, 156 & GT
    I noticed that the temperature did not exceed 75 celzius no matter how many kilometers I drive. It's mostly on 70 celzius. This happens with the arrival of cold weather. Suppose it is thermostat issue - it's always open. I found an explanation how to remove thermostat,but I need help about...
  17. Alfa GTV & 916 Spider
    Are there any bleedscrews on the tb? Can't find any. How do i have to bleed the system? Thx
  18. Alfa GTV & 916 Spider
    Hi, The fans don't cut in on my GTV 916 Phase 1 (1997) - apparently, the resistors are shot and I require 2 replacements. Are both resistors the same? Does anyone have any that I could purchase?
  19. Alfa Giulietta
    Has anyone else experienced this scenario, which to me is a little weird. The fan seems to come on under what i consider to be normal circumstances But, it doesn't go off after what I expect to be a reasonable time(often not at all) until I switch off the engine on and off, maybe at set of...
  20. Alfa 147, 156 & GT
    Since my crash ,I repaired my baby. I didn't actually notice that the 16v slam panel has a hole for the air intake and currently I have a slam panel without it. Should I go buy a new slam panel or what actually is the effect of this intake? Can I just route the intake pipe below the slam panel?
Top