Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-16 of 16 Results
  1. Alfa 147, 156 & GT
    Hi all, Have a coolent temperature sensor error code come up and have noticed the temp stays at 50 and doesn’t really rise up to 80, do I need a new sensor and thermostat?
  2. Alfa MiTo
    Hi, so I am convinced I have a coolant leak on my new 09 Mito. 70K. I noticed it sat on minimum a week or so ago so topped it up to max. Its still got the pink paraflu stuff and its sitting a centimetre below the minimum. Is it OK to top this up with normal Water for now until its fixed ...
  3. Alfa 147, 156 & GT
    Having a really weird issue with my 156 at the moment; Every now and then i come across a puddle of coolent under the rad, and when i check the level has either not perceptibly changed, or dropped a little (i topped up with maybe 200ml this morning.) But it may be weeks before the little puddle...
  4. Alfa 147, 156 & GT
    Has anyone had a problem with coolent temp,my 147 has just started to drop when running,usually a constant 90 but just started dropping?? ideas
  5. Alfa GTA
    Hi getting the common problems when it's 2 degrees or below outside the engine management light comes on fans come on and no heat out the heaters, so new temp sensor or thermostat so looking around. Hopping if someone knows if the 2.5 engine uses the same sensor? Also if anyone knows the code...
  6. Alfa 145 & 146
    hello, can any body help me...! model : t.spark 146, 1.8L year : 1997 1. I have fill in 4 bottle of 1.5 litre water to the expansion tank. ( because its not full until I realize something had gone wrong). 2. Then I start my car, all the water came out from the exhaust pipe. can any body...
  7. Alfa 159, Brera & Spider
    I guys, Today whilst in bad traffic I noticed steam coming from under the bonnet. Upon inspection it appears there is coolent everywhere. I've realised no fan came on, but also the temp gauge is normal?
  8. Alfa 147, 156 & GT
    Reason for loosing all coolent from car no leeks that i can see
  9. Alfa 147, 156 & GT
    Hi again. Started the car first time since i got it,has been standing for 2yrs and never run. Ran the engine to see if any faults, after about an hour, turned off, and checked oil and water, all seemed fine, taken off oil filler cap and there is some white cream coloured gunge on the cap...
  10. Alfa GTV & 916 Spider
    Noticed a pipe on the top of my coolent expansion tank on the cap, doesn't seem to be attached to anything? should it be? or is it like an overflow or something? cheers folks
  11. Alfa 33, Sud & Sprint
    Hi I have a 1991 33 1.7ie and the warning light on the dash is showing for the rad, i have checked and there is anti freeze in there and it is full toped up Could it be a sensor fault or somthing any help would be great? Cheers Jochen :p
  12. Alfa GTV & 916 Spider
    Hi All A bit of a daft question, but how the heck do we drain the coolent our of our '97 Spider? and are there hints out there on how to do it? Cheers
  13. Engines (TS, JTS, JTD & V6)
    Hi all again, I need to top-up my Engine coolent but aint got a clue with what. What is it that you put in there?? Is it water and anti-freeze?? Many Thnx
  14. Alfa GTV & 916 Spider
    Can anyone help with the following symptons on my 3 yr old 2.0 GTV JTS. Noticed this morning expansion tank level was about 4 inches below the Minimum mark. Filled up and drove down the Motorway 30 miles. At the other end, lifted bonnet to find the level had gone down about 3 inches! (Absolutely...
  15. Alfa 147, 156 & GT
    Dumb as I am, Can anybody advise me on what coolent is best for topping up the tank ? Thanks
1-16 of 16 Results
Top