Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 66 Results
  1. Alfa MiTo
    Hi all, I’ve recently purchased a Sony AVX-AX100 to replace the standard Blaupunkt radio. To prevent cutting in the existing wires I would like to connect the new Sony with adapters to the cable harness of the MiTo. But unfortunately I don’t understand the function of the original connections...
  2. Alfa Giulia
    Any one knows what this cable is for? Found it unconnected yesterday and there was a fitting connector just a few cm away. Connected it and tha car has not exploded, yet. No errors before or after re-connecting the cable. It is located just behind the left head light on a LHD car. It is a 2017...
  3. Alfa 147, 156 & GT
    Hi, I am overhauling my 147 20 TS Selespeed, however I don't have any records or illustrations of the wiring for the alternator and starter. Any help would be much appreciated. Ryan
  4. ICE & Blue&Me
    I've tried fitting my single DIN into my 159. Upon removing the standard head unit, I was delighted to find that the ISO adapter matched the one I already had for my stereo. Fitted it all nicely, no problems at all with getting it in there. Now I plug it in and the thing won't power up. The...
  5. The Classic Alfa Romeos
    Just got carbs back from the refurb chap...they do look rather good! Need to work out what goes where regarding the coolant pipes we're swapping from single carb. There are two pipe connections on the rear of the manifold, one heater one on the pump and heater flow and return. My Spider has...
  6. Alfa GTA
    Hi All, I haven't been on here much this year but I am having some issues with my 147 GTA which more than anything, require venting on the internet in typical middle class fashion! My car ran great earlier this year and did the Nurburgring trip with no major issues. I have been using it...
  7. Alfa 159, Brera & Spider
    I have the USB media player fitted on my 159, the PO fitted an ipod interface, he said he'd fitted it on the back of the CD changer although he must've meant the connections for the CD changer as I don't have one, I have Blue & me & I think I read it's one or the other. So where would this be...
  8. Alfa 147, 156 & GT
    Hi..anyone i have the original radio for a 156 2.0 2001 TS....it looks like a alpine 932. i'm looking for the wiring diagrams for the 3 connectors at the back of it...actually i'm only really interested in the connector for the CD changer...a dual inline 5 pin rectangular connector. thanks...
  9. Alfa GTV & 916 Spider
    Hi, i recently recharged my battery and forgot to take a picture of the correct connections on the poles. 1: if i put everything on + pole, the car starts and acts normal the indicator lights are on Fully all the time, same with reverse lights. pictures: - pole - Imgur Picture number 2 is...
  10. Alfa 147, 156 & GT
    Hi everyone im in need of help, i have recently bought myself a alfa 147 t spark 04 reg, my problem is that my rear light is malfunctioning, the wire that plugs into it has a small connector on it and it seems one of the holes in this plug/connector has burned out and can i **** find a...
  11. South Africa
    Im looking for a 820-900 hob and a double oven
  12. Alfa 147, 156 & GT
    Hi Forum, A challenging one. Airbag light on - read the airbag how to thread and others and this issue not coevered. Multiecuscan reading airbag error "1A" warning lamp circuit. can't clear it even after removing, cleaning and reconnecting connectors to airbag ECU module and back of dash...
  13. Alfa 33, Sud & Sprint
    Hi, I've rebuilt my brake compensator - the two in / two out type - and have connected it into the dual circuit system. Now I've done it I've had an awful thought !! I connected the inputs in at the bottom and the outputs at the top. What I didn't do was make sure that the outputs to the rear...
  14. Alfa 147, 156 & GT
    Hello all. So I'm wondering if anyone knows what spare electrical connections there in and around a GT roofline. I knows there's one by the interior light that I'm hoping to use to wire up an auto dimming rear view mirror. I've done a search on here and see some have done it on a 147, but the...
  15. Alfa 75, RZ, SZ
    Can anyone offer any thoughts on my question in the ICE lounge? Linky Cheers :thumbs: Aubrey
  16. ICE & Blue&Me
    Does anyone have any information on which wire is which when connecting up a new head unit in an SZ? The wires I have coming out of the dashboard are: Red Blue (could be purple?) Grey and black Red and yellow Grey Black Violet and black SZs have no front speakers - just three mounted in the...
  17. Alfa 147, 156 & GT
    Sorry guys but I have a Fiat Stilo 2.4 Abarth fitted with a Selespeed gearbox. The clutch had gone so had to remove gearbox ect. to replace. Now all back together however although we appear to have connected all the electrics to the solenoilds and pump ect. have one connecter left over without...
  18. ICE & Blue&Me
    Hi, could anyone confirm whether these are the connections in the rear of the connect nav unit - dont have two 4mm thread bolts to remove it at present. thanks in advance. http://www.ouibi.com/pics/alfa.jpg
  19. Tuning & Upgrades
    Hello. Trying to workout my electrics . Does someone know all the connections in the ecu ? I'm making Toyota Mr-s superleggera jtd here :D
  20. Alfa 147, 156 & GT
    HI Occasionally (almost every day) my JTS throws up two Lambda errors: P0134 Lambda Sensor Bank 1 (Pre Cat) P0154 Lambda Sensor Bank 2 Slow Response (Pre Cat) both with "Fault Symptom: No Signal" As clearing them makes them go away for a while, I am assuming I have a dodgy connection...
1-20 of 66 Results
Top