Alfa Romeo Forum banner

broken

  1. Alfa 159, Brera & 946 Spider
    Have just had the experience of my key breaking in my Brera dash, hopefully the picture will upload but the rest is still stuck in my dash key socket. ? Spent ten minutes thinking the lower bit of the key or the black bit had fallen on the floor but upon looking in the key socket I'm pretty...
  2. Alfa 159, Brera & 946 Spider
    Hi all, car is 2.4 159 2008 Menu button is broken and I'm trying to avoid fixing the stalk for the time being. I've read on here that you can set the time with multiECUscan but for the life of me I cant find the setting. Which unit do I connect to? Can anyone help me? Thanks in advance
  3. Alfa 159, Brera & 946 Spider
    The wife, driving to work in the Spider on Monday a stone (?) hit the windscreen, I've never seen a screen crack like this before. You can just see the point of impact in the centre of the crack.
  4. Alfa Giulietta
    Hello, The other day I heard when opening the trunk door like something was moving around. After unmounting the trunk I found this. Can anyone help in telling which cable it is and where should it be plugged?
  5. Alfa 147, 156 & GT
    The top of my handle is starting to be detached from the door card. I almost pulled off the handle today when closing my door but luckily the bottom tip of the handle is still attached. Any other GT owner experienced the same thing before? I assume this is going to be an easy fix?
  6. The Classic Alfa Romeos
    indicator stalk required for Alfetta 1800 Saloon 1975. Can anyone help !
  7. Alfa Giulietta
    Hello Wondering if someone can help narrow this fault down for me. The air conditioning has stopped supplying cold air. Normal fans are fine as is the heat. When the car is started for the first 5 seconds (if the AC is on) the clutch on the compressor can be seen running and then stops...
  8. Alfa 159, Brera & 946 Spider
    Hi all, I'm working on a Vauxhall Insignia 2.0 CDTi which shares the same engine as the 2.0 JDTM, so I hope you don't mind me asking here. I've tried on the VX forum but haven't got much in the way of a reply. I bought the car for £500 with a snapped cambelt. I'm hoping the only damage is...
  9. Alfa 145 & 146
    Hello guys I need some advice. I got my first alfa 2 years ago. It is 146 1.6ts alloy cover (cf1 i think?). I got it with engine light on but I had hard time finding out how to diagnose it. Finally when I was successful i found out that its 08 - phase sensor fault code. So I tried to repair...
  10. Alfa Giulietta
    Hi all, Just wanted to share the following - for those who suddenly experience the following symptoms on 2010 Giulietta Cloverleaf (manual transmission): 1. Dead engine starter motor, not turning at all 2. Rest of the accessories work well (locks, lights, air-con-fan, radio, etc..) 3. When...
  11. Alfa Giulietta
    Well it eventually happened. I broke the old girl...
  12. Alfa MiTo
    Hi, everyone. I have been around this site for a long time, but things have been ok for me problem wise for a while. I previously owned a 147, then a 147 collezione. Then i treated myself and bought a low mileage 2 year old Mito QV. Its been great, i have drove it on the continent many miles...
  13. Alfa Giulia
    That's two in 13 months (18000 miles) and 3 separate cracks in my Amarok pick-up in 3 years (actually 4 but one was a branch falling from a tree - so that was understandable). This is a fairly recent phenomenon for me, are they getting thinner/weaker, maybe to save weight.
  14. Alfa 159, Brera & 946 Spider
    Hi, my 159's power delivery is on the fritz, when I put my down the power delivery isn't smooth. It jerks under acceleration. Its as if the power comes through for a second then no power. Most of the time there is almost no power. It revs fine but no power. I think it could be the petrol filter...
  15. Alfa GTA
    I'm trying to get the parts together to enable the reassembly of my GTA SW. Therefore I need two of these... but I can't find them in ePer. Does anyone have the part number?
  16. Alfa 159, Brera & 946 Spider
    Broken down, just been recovered - Any pointers on the following errors that have all flagged up? Car was running fine, engine management light came on and my Brera died....2.4.
  17. Engines (TS, JTS, JTD & V6)
    Car is Alfa GT 1.9JTD 2006. Drove on the motorway suddenly big smoke engine stops cannot restart. Long story short found that one diesel injector has failed. The tip came off and there is a big hole in it. Anyone seen this before? see added images.
  18. Alfa MiTo
    Hi everyone, haven't been on here for years, the last time was when i had a 147 with a few problems. Really hoping you can help again, i now have a 172 mito. This morning i pulled the release handle and it snapped, no problem i thought. I will just pull the cable. No chance there, so i am now...
  19. Alfa 159, Brera & 946 Spider
    The car told me my R/H sidlelight was out so I set about changing it. Following the manual I got to the step where it says 'press tab' so I pressed this tab I could not see and I felt it give but not in a good way, I just knew it had snapped. What can I do to sort this out? How do those...
  20. Alfa 147, 156 & GT
    Hello, My girlfriend was driving my 147 today and she called me complaining that the 5th gear does not work anymore. And indeed when she came home i tried to check the car and the 5th gear behaves as neutral. You can even select it without pressing the clutch. The rest of the gears work fine. I...
Top