Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-10 of 10 Results
  1. Alfa Giulietta
    Please can someone send me the correct file to plug into the USB port to upload the English language software 😢 I've tried downloading ones I found online but either they are not right or I'm not doing the steps correctly. Any help is much appreciated 🙏 jazyjas2010(at)hotmail.com - replace...
  2. Alfa Giulietta
    Hi, Today my odometer started flashing. And my Blue and Me is not working properly. I have tried disconnecting the negative for a few minutes and that hasn’t made any difference. I still have power to usb and the aux with my media adapter works. Besides the point the flashing odometer is...
  3. Alfa Giulietta
    Hi guys, Recently purchased a 2013 Giulietta. Blue&Me hasn't worked for a while according to previous owner so I went and got a bluetooth adapter to stick in the back of the head unit. Since doing so a No Source message has been showing, the adapter is working as I can connect to it on my phone...
  4. Alfa 159, Brera & Spider
    I'm having a little issue getting my stereo in my 159 back to stock. It currently has a Pioneer set in but I periodically put back in a compatible, original radio I got from Ebay which works perfectly. The issue I'm facing is that I'd like to go back to the original Radio but the Blue & Me...
  5. Alfa MiTo
    Is this black module the Blue & Me unit? It's behind the radio panel, below the radio module.
  6. Alfa Giulietta
    Hi All, Hoping I can get some assistance with a dead Blue and ME in my 2012 Guilietta 2.0 JTDM i.e no bluetooth, steering wheel buttons, and USB not working. First symptom was the flashing odometer. Then discovered Bluetooth not working. So far I've tried 2 second hand BM modules (PN 50525925)...
  7. Alfa MiTo
    Hi, The display on the Media Player has suddenly stopped displaying. Would anyone know if this can be fixed? If not, where would a replacement be sourced? We have a Mito 1.4 Quadrifoglio.2013 year. Thanks
  8. Alfa MiTo
    I've owned a MiTo for 8 years now (the 2010 135bhp version) and the lack of aux connection or Bluetooth connection for media has always been a bit frustrating. Similarly, it took me a while to stumble upon a decent phone holder that does not block an air vent or impair the driver's view out the...
  9. Alfa Giulietta
    Hi folks, I have a 2011 G (owner from new) and still in love with it today as much as I was when I first drove it off the forecourt! My question relates to the blue&me system - and basically how [email protected] it is! I love everything about the car, except the B&Me system - utter rubbish (n) I have...
  10. ICE & Blue&Me
    Hi guys, We just today purchased an Alfa Guiletta (2012). We set up the phone for BT fine and then plugged a USB cable in for the music. We use Spotify so tried this and although the USB port charges the iPhone (8) we get no audio. I tried another iPhone (XR) and it works as soon as you plug...
1-10 of 10 Results
Top