Alfa Romeo Forum banner
behaviour
1-20 of 81 Results
  1. Alfa Stelvio
    Tyre pressure warnings in the Stelvio I’ve come to realise are annoying and odd. Reading the manual, it seems the car knows what pressure the tyres should be and there is no reset or override button , so to clear the msgs I have to ensure the tyres are reinflated to the settings in the manual...
  2. Alfa 147, 156 & GT
    I would be very grateful if some of the 156 jtd facelift owners would check for me: Does their fuel gauge needle jumps to full for a split second once the key is turned and then stabilizes on correct level; And Does the needle stay hovering slightly above 0 at key off but after few seconds...
  3. Alfa 159, Brera & Spider
    I use the keyfob to unlock the boot but everytime I open the boot the alarm sounds. Is this a fault or normal behaviour... can't find anything in the destruction manual about alarm behaviour. Trying to think back to what my 159 did sure the alarm didn't go off when I opened the boot however...
  4. Alfa 147, 156 & GT
    I'm new to this forum so if I post in the wrong section I apologise. I've been driving my 156 Sportwagon Selespeed for a couple of years with no real issues, but today a strange thing happened. I think it was in 3rd gear (manually operated) when the transmission started making a loud whirring...
  5. Alfa 159, Brera & Spider
    Having some issues with headlights; when all are off the indicators work fine. Sidelights seem OK (first picture) although it is a bright day and they do seem a tad yellow. Hard to see in the picture. Dipped beam shows the inner light on both sides but also the outer light on the left...
  6. Alfa 147, 156 & GT
    Hi all! First of all, what a great detailed forum! So many topics on all kind of issues and upgrades. Since November '17 I own a 147 JTDm 150 bhp. After owning some fun fast hot hatches I had to get a diesel, but I wanted to have something different (like I always had ;)). So I picked the 147...
  7. Alfa Giulietta
    Hi Everyone, I'm just a new member of this forum and a six-month owner of a 2011 Giulietta 1.4 170hp with a pop-up radionav feature from Turkey. When I bought the car I upgraded the graphics of my radionav system with one of the latest mods released by Kyto83 which I found in this forum. I've...
  8. Alfa 164 & 166
    Car been layed up for 18 months ,,, usual stuff happ3ned, battery died, fresh battery, re enterd radio codes, odd injector light came on then off,,, all good no2, apart from heater is blowing full all the time.... responsive on ics for functions, ie it scrolls etc, but has the ics fell out , as...
  9. Alfa 164 & 166
    Hi All, Can anyone provide any pointers on troubleshooting an intermittent fault with the wipers on my 166? Symptoms: - Periodically, switching to rain-sensing mode doesn't work - the wipers do nothing - If this happens (and it's happening more and more frequently - maybe 50% of the time) -...
  10. Alfa Giulietta
    Hi, Last Friday I noticed the fuel gauge needle started to drop suspiciously quickly.. too quickly I'd say. It dropped over 1/8 in 38 miles, I could literally see the needle moving down. What is interesting is that the onboard computer claims everything is fine. The estimated range is still 400...
  11. General Alfa Discussion
    Something occurred to me today. I used to be the proud owner of an Opel Manta GTE, you would never ever see a poor example of a Manta on the road. Then one day they all disappeared, you might see the odd ad for a Manta 400 but none of the others. Now I'm an Alfa owner I think I'm going through a...
  12. Alfa 147, 156 & GT
    Hi I have an issue somewhere I'm thinking at a Gnd terminal. If the AC compressor is on and I press brake pedal it cuts off the power (for 2-3 secs) and after that is coming back. If I release the brake I have the same simptoms. Does anyone have any idea why is this happening? Does anyone...
  13. Alfa 164 & 166
    Well this is an odd one... Press either rear electric window switch on my driver's door and both rear windows go down together - not all the way down but just for as long as either switch is operated. Raise either switch and only the window for that side will go up. The switches on the rear...
  14. Alfa 147, 156 & GT
    Hi guys, I've recently bought 05 JTD GT with broken thermostat (car heating was very weak and engine temp needle never moved). After I've replaced thermostat with a new one, engine temp gets nicely to 90°C and stays there, but only until I turn on interior heating. When I turn heating on...
  15. Alfa MiTo
    Hi, I'm putting my two year old MITO QV TCT in for its 27,000 miles service soon. I think that the TCT gearbox is 'not right'. I recall a post that a MITO TCT had experienced smoke probably coming from a clutch. I'm thinking of instructing the dealer doing the service as follows: "Since new...
  16. Alfa Giulietta
    hi guys, my rear wiper went a bit nuts this morning, i can't remember exactly what I did, but I think I had auto wipers on, dipped beams, A/C etc, i turned on the rear wiper to get rid of a bit of dew and it just kept going at full speed, not intermittent but full speed, like it does when you...
  17. General Alfa Discussion
    These VW drivers, cheeky basterds, classic VW move, come really close behind you at the traffic lights (fog lights on of course), then pull up real close, look in the side mirror and then try and overtake, well...not this time chummyboy, you and your Gti can eat my dust. He tried to do it but...
  18. Alfa Giulietta
    Hi Guys, This is my first post and first time Alfa owner, I recently bought a 2012 Giulietta Veloce and the pop up radio/satnav unit has a mind of its own, after turning the key sometimes it pops up and works straight away, sometimes it pops up with a blank screen then the Alfa logo appears...
  19. Alfa 159, Brera & Spider
    Greetings to all, I´m the owner of an Alfa 159 2.2JTS 2011 with the selespeed system.:paranoid: The gearbox works perfectly, all gears are engaged smoothly and everythings is working fine.:smoker: However there is a thing that is keeping me investigating on the web: It´s suppossed that the...
  20. Alfa 159, Brera & Spider
    Hi to all! Is it normal for 2.4 Jtdm 210 bhp's boost gauge to show preassure drop at above 2000 rpm and then to show boost building up again without lost of power when accelerating? I would like to hear some views on that, please...
1-20 of 81 Results
Top