Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-20 of 500 Results
  1. Alfa 159, Brera & Spider
    Hi everyone, I am trying to resolve this problem for almost a year, already replaced many parts and still no luck :( My car is Alfa 159 1.9jtdm, Qtronic 110kw. Issue happens during the first start after car is parked overnight. I open the car, sit inside and start the car: Little longer...
  2. Alfa Giulietta
    Hi All, I’m having trouble working out the correct battery for my 2015 Giulietta QV TCT (not start stop). The battery in there now which I understand is not from factory is an SSAGM55 EU with 750 CCA / 60AH / 12v. I believe this is a start stop battery, even though my car is not start stop. I...
  3. Alfa MiTo
    Hi Guys, I've got a 12' 135 multiair mito and last week after being in dynamic mode, I got an EML and s/s unavailable as I got home I noticed how rough the car was at idling with a juddering when parked. Dreading the worst I expected the multiair unit to be at fault however I got a code reader...
  4. Alfa Giulietta
    Hi, just bought a 2011 g 2.0 diesel. Everything seemed fine but on the way back I turned on my headlights and the battery warning light came up on the digital display.shortly after I lost power steering and got loads of codes. My first thought was a dead battery so I got a new one. This has not...
  5. Alfa Giulietta
    I just bought a 2010 Giulietta and have been having problems with the infotainment/radio. None of the buttons aside from the on/off work. My father recommended disconnecting the battery and letting it sit for a couple minutes. It didnt fix the issue and now the car feels slower than usual...
  6. Alfa Giulietta
    Hi, newbie here. Bought a Giulietta last week (after vowing never to touch an Alfa again after a 147 dropped its crank shaft) and its having its first hissy fit. Disconnected the battery to get to the headlights and after reconnecting the language on the dash is now italian. I've tried to change...
  7. Alfa 147, 156 & GT
    Now then people 👍. Given the GTA isn’t doing that many miles nowadays, I was thinking of getting one of those battery booster packs to avoid starting it up on a weak battery. Like this - https://www.amazon.co.uk/dp/B015TKUPIC/ref=cm_sw_r_oth_api_glt_fabc_N5Y6ZMP1MZHHPB6TZ2MD There’s a million...
  8. Alfa MiTo
    Hi, I recently purchased a Mito (2011 1.4) and have had no problems starting it but the USB/ blue and Me wasn’t working so I seen a thread which suggested disconnecting my battery for 10 mins approx. After doing this, the car has not started. It makes a ticking noise, still has power but just...
  9. Alfa MiTo
    Hi everyone, I have a MiTo Lusso 1.4 Turbo 2009 155hp AXA1B variant which has a lot of extras like heated seats and climate control... The car started experiencing "steering column unavailable" error but when I turn off the ignition and start it again it works fine. Then the daylight error...
  10. Alfa Giulia
    This looks like a great piece of kit. It can safely maintain your battery using its internal battery source and get a flat battery to start in around 15mins. Apparently, it can hold a charge for around 1 year too, bit on the pricey side though... The price of convenience. I can see this being...
  11. Alfa 159, Brera & Spider
    Hi Guys, Something peculiar happened today. While I was driving (nothing seemed wrong) I got the ABS lights on my dash. Something I know happens when voltage is low on the battery. A short while later (1 minute) my radio shut off. At this point I noticed the idle RPM went from 800 to about...
  12. Alfa 159, Brera & Spider
    Hello, After changing battery display between guges is not showing radio station or track on CD or media player it is only showing date and that's it. Does someone have same problem or solution? Thanks.
  13. Alfa MiTo
    Hello Alfisti, Since the beginning of this year I am the proud owner of a 2011 Alfa Romeo MiTo 1.4 Multiair turbo 135 TCT; my first car. However, recently I started experiencing some battery-related problems like longer (cold) starts and weird TCT shifting behaviour (shaking and rough shifts)...
  14. Alfa 147, 156 & GT
    Hi all I have a GT 3.2 LT. Have a problem where it’s struggling to turnover when starting. If I turn off and start up again with a minute or so it turns over ok. But if I wait a few minutes before trying again it struggles ? The battery is fully charged and alternator is charging correctly...
  15. Alfa MiTo
    Hi all, I am new at the forum, but I’ll cut the to chase. My 2012 Mito 1.3 jtdm 85 has suddenly broken down and won’t turn on. It felt like the battery at first, but there were no signs of it and now all warning lights on the dashboard blink randomly (or not), including the headlights. It dosnt...
  16. Alfa 147, 156 & GT
    Hello all, I’ve had to trickle charge my battery a lot lately and put it down to not a lot of car use due to current times (COVID-19 for those looking back at older posts in years to come like I seem to do lol) Anyway I drove a good 18 mile stretch yesterday though I did excercise the stereo a...
  17. Alfa 159, Brera & Spider
    Hi All, I hope you are well. I wonder if anyone else is familiar with my sudden electrics issue, and has any advice for me. I've had a problem this week with no electrics in my 159, meaning I cannot start it and I cannot lock or unlock the car electronically with the fob. The usual dash lights...
  18. Alfa 159, Brera & Spider
    Morning guys! As the title suggests I have a slight problem... Battery has died in my Brera (Full disclaimer, car has been stuck at a garage during lockdown since the end of March with the battery connected, should've guessed this would happen). They started work on it this week, but went to...
  19. Alfa Giulietta
    I have 12 plate 1.4 Multiair Giulietta and I've found that the battery is going flat - down to 9v over a couple of days or on one occasion overnight after driving it the day before. I've charged the battery three times and its read 12.8v after charging an across the terminals it measures 14.4v...
  20. Alfa Giulietta
    Hi, I have a Giulietta QV Line (1.4TB Multiair) has recently started to give me a bit of trouble. In basic terms, it initially hesitated when trying to start - making a clicking noise several times with lights on the dash flashing. But you could hear it turn over, then it would eventually...
1-20 of 500 Results
Top