Alfa Romeo Forum banner
accumulator
1-19 of 39 Results
  1. Alfa 147, 156 & GT
    Hi all, read a few ancient posts here before writing this and long time lurker. I Got a my04 147 2.0l selespeed and after a quick wash the other day (then the cat jumped on it :curse:) it sat overnight in the garage and I started it up to get a lot of beeping and selespeed failure warning on...
  2. Alfa 147, 156 & GT
    Hi all, having a run of Alfa questions today! wife had an issue with the car yesterday. Flashing in N, no beeps (other than ice on road -37C - see my previous thread), but car just wouldn't start. With some effort I managed to guide her through disconnecting the battery for 10 mins, and it...
  3. Alfa 147, 156 & GT
    Hi All Can anyone recommend a Vacuum Accumulator for running aiding the brakes instead of using the plenum for vacuum . :sonar: or how much vacuum roughly would i need. as im thinking of keeping the hose connected to the plenum for the vacuum when throttle closed and on the same line and have...
  4. Alfa 147, 156 & GT
    Hi, has anyone got a selespeed accumulator for Alfa 147, please?
  5. Alfa 147, 156 & GT
    Hi Folks, So i took my accumulator off to see if there was any sign of damage (nothing visable) and there was oil in it. I thought that is normal but i came across a post on another thread/forum; 'if you've been topping up the sele fluid then there must be a leak somewhere. Most likely either...
  6. Alfa 147, 156 & GT
    Hi there, a few years ago I sold my 156 to very nice old chap (in his 70's)who has taken very good care of it since, he's the brother of my neighbour and last week I bumped into him and he mentioned the Alfa had a gearbox fault and the garage had recommended he scrap the car. He was pretty upset...
  7. Alfa 147, 156 & GT
    Just have done subject, previously the pump was working on every13sec. Engine off, key in MAR. After changing to a new one it is 20 MINUTES!!! A massive improvement. What is the time for the pump from going low to max pressure? I have a bad feeling i must dismantle the pump...couple of secs, but...
  8. Alfa 147, 156 & GT
    Trying to do some preventive maintenance on my sillyspeed. No problems, but just to be ahead of it and keep it healthy! I have checked the clutch travel, and it's at 30.5 mm, so that needs adjustment. But I don't know if the free version of MES can be used to do clutch calibration? I have also...
  9. Alfa 164 & 166
    Hello guys (and girls :) ) I bought Alfa Romeo 166, one of my dreams. I treat it like a baby, I changed all filters etc and decided to change accumulator to new one :/ After that computer ask me for ICS code, here is a photo's of screen: http://imageshack.us/scaled/landing/443/1mpe.jpg...
  10. Alfa 147, 156 & GT
    Hi there,I'm new to this site and new to alfa romeo,I've got a 147 selespeed and it's dropping into neutral when I stop at traffic or lights,and won't go in gear again,I've bin told it's the accumulator is this true and is it a big job? Many thanks
  11. Alfa 147, 156 & GT
    Just wondering if any kind soul could help me decide whether my 156 selespeed accumulator or pump is defective and if so, where would be the best place to purchase a new one? Problem: Strange gear change problems, most notably refusing to go into reverse and also dropping into neutral when...
  12. Alfa 147, 156 & GT
    Hi all, I drive an Alfa Romeo 147 selespeed European car of the Year 2002 I have lost patience with the my local Alfa stealer ahem *dealer .. He wants to replace every component in the car. I knew my selespeed system was on the blink but he said no codes came up, funnily enough he recomended...
  13. Alfa 147, 156 & GT
    Hi, I'm from Thailand. I just want to know about the accumulator. As I found on the accumulator "92BAR/0.35L." stamped on it's housing. As we known the system pressure is just only 45-55 BAR. So, how does the hydraulic oil filled up the accumulator which higher pressure than the system...
  14. Alfa 147, 156 & GT
    Hello All. I have a 2000 156 2.0 Selespeed. And it seems I need an accumulator change. I live in North London. Would you be able to recommend a garage to do the work for me please? Or anyone with suitable equipment with experience of this issue and wants earn some extra money!!! I live in...
  15. Alfa 147, 156 & GT
    Hi Folks, Have read a great deal on here, and really appreciate all the helpful posts. I have recently bought a 2001 156 2.0 TS Selespeed with 86K on the clock - it's my first Alfa, and loving it. I've replaced the front upper arms and the droplinks and all has been well, but the Selespeed...
  16. South Africa
    Hi guys.as a fellow alfa driver I really need your help.I have a 147 selespeed.I just had the gearbox and selespeed pump replaced and the car is running but for one issue,its drops into neutral when stationary.the problem lies with the accumulator on the accuator.not holding presssure and hence...
  17. Alfa 147, 156 & GT
    Having my selespeed going into limp mode with error P1769 pump relay blocked. I don't think its the relay or the pump though as they seem to run OK. I suspect the accumulator, as now it has to pump with every gear change as the pressure immediately drop to 20 Bar with an actuation. Then goes up...
  18. Alfa 147, 156 & GT
    Hey guys i purchased an obd2 cable on ebay and successfully connected it to my laptop with the demo of alfa diag. Although you can see a limited amount of stuff on alfa diag and the main reason that i purchased the cable was to check the pressure. My first question is can you check the pressure...
  19. Alfa 147, 156 & GT
    Hello I've got a problem with my selespeed and Ive read every thread I think but cant find a solution. I cant get a gear any more which started as an intermittent fault at start up and occasionally whilst driving. The relay clicks when i open the door but the pump doesnt prime. I disconnected...
1-19 of 39 Results
Top