Alfa Romeo Forum banner

accelleration

  1. Mscf on hard accelleration.

    Alfa GTA
    Pulled onto A3 and acellerated quickly to 80mphish. MacFarlane flashed on and off 3 or 4 times in succession. Any ideas?
  2. hissing on accelleration, shakey at speed, shakey when braking

    Alfa 147, 156 & GT
    So....after a year of neglecting my alfa because i have zero spare time ever....she has now decided to bite me in the ass :) Over the last few weeks i have noticed things start to deteriorate, and still failed to sort anything. So now I think the car has decided to force my hand to take more...
  3. Sluggish accelleration ?

    Alfa 147, 156 & GT
    Hi All, My JTD has started to become a bit of a pain recently, more often then not on the first run of the day. The revs have become very slow to get going, when pulling away from a standstill, almost to the point where you wonder if it's actually going to move......not good when pulling out...
  4. EOBD Warning Light - V6 - hard accelleration

    Alfa GTV & 916 Spider
    Help from those who know needed. The EOBD light comes on when I accelerate hard in my GTV P2 V6 24v. At the same time I get an immediate reduction in power - it feels like a limiter has cut in. The light then stays on for about 24 hours, then stays off when I start the car, until the next time...
  5. 156 1.8TS Accelleration Problem

    Alfa 147, 156 & GT
    Hi, I have an intermitten problem with my Alfa 156 1.8TS. On acceleration it dies, almost stalls, but if you ease of accelerator and then accelerate again it will go OK. It is intermittent, fine some days, and then not for some. Disconnecting the MAF makes no difference. When you first start up...
  6. 2.4 jtd cutting out under accelleration

    Introduce Yourself
    hello can any body help please,i recently purchased a low mileage 156 2.4 jtd saloon and have experienced problems with the engine cutting out sometimes when accellerating with the throttle pedal fully depressed,it seems worse in 2nd or 3rd gear and the engine will not resart unless the igniton...
  7. 156 2.0TS -Screech under accelleration when cold

    General Alfa Discussion
    I have a 156 2.0 TS (2001 reg) with 21k miles. The feels perfectly okay, when it is cold I hear a slight screeching sound while accellerating through low revs (e.g. pulling away). Once the car is warm this goes away completely. It sounds like a belt problem of some kind. When the car is warm...
Top