Alfa Romeo Forum banner
absence

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-9 of 9 Results
  1. East Anglia
    Hello all you guys in the East Anglia area (and anyone else for that matter). I've not been in forum for just over a year now, the reason is that I lost my lovely T Spark. I began to have problems with the engine suddenly cutting out, then one day while the car was parked - and without any...
  2. Alfa 33, Sud & Sprint
    ....I have an Alfasud back in my life. I purchased an '88 Sprint yesterday and drove it 200 miles home. If I could post pic's I would but I'm not sure as a newbie I can? I have already plundered this forum for information and I expect I will be on here asking for advice and contacts as I...
  3. Alfa GTA
    My GTA has been parked up for the last month. No real reason, just it was parked in the drive in a difficult location (behind the delivery of sand, a trailer and a transit!), and what with the rubbish weather and our roads where I live it just didn't get used. Also have a transit van now...
  4. Alfa 147, 156 & GT
    Hi guy, I have experience with "Error due to absence of suitable conditions" on my 156 when I tried to calibrate the system with FES. Cold/hot engine will got the same result. What is the problem? What parameters needed in order to calibrate a selespeed system. My system pressure is normal...
  5. General Alfa Discussion
    Really missing my Brera. Hurry up part from Italy:(
  6. Alfa 147, 156 & GT
    Hi I would be gratefull for any advice, I have just bought a Alfa 156 2.4 jtd sportwagon of ebay and despite assurances that the car was good, a freind picked it up from England after a ryan air flight and the ferry back to France. When I accelerate past 3000 revs the engine management light...
  7. Introduce Yourself
    Hi everyone. I just picked up a used Alfa 159 Sportwagon - my first Alfa for many years. Historically, back in the '90s, I'd owned 3 previous Alfas in succession - a 3.0 75; arguably the last of the 'real' (I prefer the term 'traditional') Alfas and a cracking good drive (when it worked :) ). A...
  8. Alfa GTA
    ..because I bl**dy well miss my GTA! :lol: Been about 2 months now since its gone, replaced with the daily drive being a tired, 150k mile Audi A3 "Sport" (irony) with wobbly suspension and lacking in any charm at all. "Dull" comes to mind. Although having petrol consumption that starts with a...
  9. Motoring Images
    I thought I'd post this: Consider it my belated Christmas card to you all:D
1-9 of 9 Results
Top