Alfa Romeo Forum banner

abnormal

  1. Alfa Brera abnormal tyre wear

    Alfa 159, Brera & 946 Spider
    I posted in February 2012 about abnormal tyre wear on my Alfa Brera and I was directed to a thread which listed 1000+ owners complaining about a similar problem. I have been writing to AR over the past couple of months but have just been brushed aside and they are blaming me for the problem! I...
  2. abnormal tyre wear

    Alfa MiTo
    Hi All, The Mito went in for a service recently and we were told that the tracking was out causing tyre wear on the front driver side tyre. Went to a tyre centre that I regularly use and he categorically said it was not the tracking, probably the camber is off. Anyone had a similar problem...
  3. EBC warning light abnormal

    Alfa 147, 156 & GT
    Hi All. Has anyone had this? Its on my 147 ?? Keeps coming up on the display and beeps to.Its getting annoying. :) Thanks. Wayne.
  4. Abnormal engine rotation during warm up

    Alfa 147, 156 & GT
    Hello, I have recently bought an 156 2.0 TS 1999 and this is my first post in alfaowner forum. Glad to be here! This is the problem I have: When engine is cold, after startup it goes to about 1200 rpms, maybe 1 minute later, little by little revs reduce to 900 (guess this is normal operation)...
  5. Abnormal Cold Starts

    Alfa 147, 156 & GT
    Howzit. :) Long time reader, first time poster. ;) I'm having a problem with my 147 2.0TS: Often when I start my car when the engine is cold, it sounds really rough until it settles into idle. By rough ("weak" would be a better term), I mean that it takes longer to kick-over and sounds like...
  6. 159 Q4 abnormal tyre wear

    Alfa 159, Brera & 946 Spider
    Hi, I have a 159 Q4. Last week I noticed the right front tyre had cut through to the steel on the inside. The front left is on its way. I have done 14,000km's. The dealer hasn't heard of any problems with alignment but doesn't have any 159's with that many km's to compare. Has anyone heard...
  7. Abnormal Oil usage...?

    Alfa 147, 156 & GT
    Bought my 147 Selespeed 3 weeks ago. The dealer said they use a lot of oil and to to check it weekly. I have been doing this. When i got the car home on day one, the oil was registering on the max at the dipstick. However 3 weeks on it is at min. Is this normal for the 2.0TS? How much oil...
Top