Alfa Romeo Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-10 of 10 Results
  1. Engines (TS, JTS, JTD & V6)
    Hi everyone Recently been playing round in my 1.6 147, going up through the gears and have noticed a sharp whining noise occurring at 5000rpm on the dot and then going back to normal engine noise up to the red line. I'm thinking it may be the cambelt but am not too sure as i only have limited...
  2. Alfa 164 & 166
    My V6 has a sort of hesitancy at 5000rpm, like a misfire or something for about a second, then it carries on up teh rev range. Seems to happen in all gears. My first thought is that the MAF might be knackered (the fuel consumption seems to be a bit worse, too) but I don't know whether that...
  3. Engines (TS, JTS, JTD & V6)
    Hi guys, hopefully not a problem! My engine whines at 5000+ RPM, i hardly take it that high so just noticed it. When i say whine, it sounds like a turbo, but my cars is a 2.0 twinny! Any ideas what it could be or is it normal, i tried to record it but didnt come out well. Thanks
  4. Alfa 147, 156 & GT
    Hi, I recently bought a 156 lovely car. 2000 year 83000 miles 1.8 engine The timingbelt was changed at 67000 miles . Every time I go over 5000rpm in any gear the engine sounds like its going to explode with a loud banging resonating from under the hood. Below 5000 its smooth and quiet. Any...
  5. Alfa GTV & 916 Spider
    Can anyone advise. My Spider holds back over 5000 rpm but performs perfectly well below that. I've had a Lambda sensor changed but that didn't make any difference. It is quite marked as soon as the revs hit 5000.
  6. Alfa 147, 156 & GT
    Hi, I am having problems with my 147 1.6. It seems to misfire a little, have loss in power/acceleration, it doesn't want to rev passed 5000rpm. I have changed the spark plugs, and now also changed the coil packs. Mechanics don't really have an idea! Can it be the mass air flow, or the...
  7. Alfa 147, 156 & GT
    It might just be me but my 156 2.0 twinspark seems to run out of power at about 5000rpm and can't get anywhere near the redline. As I'm new to alfas I don't know if this is normal or is there a problem I should be looking for. Cheers Norm
  8. Alfa 147, 156 & GT
    my 1998 156 v6 has all of a sudden developed a real lack of power and hesitation under 5000rpm. once she hits 5000rpm she starts to pull as she used to. i thought it might have been the spark plugs so i swapped them for a nice new set of ngk platinum plugs off of ebay. the change of plugs has...
  9. Engines (TS, JTS, JTD & V6)
    When my engine reaches 5000rpm in any gear there is a loud exhaust resonating sound from the engine. I discovered the baffle had gone in my rear box but having this replaced has not cured the problem. Engine is smooth at idle and no excessive noise at low speeds.. Any ideas?
  10. Alfa 147, 156 & GT
    Hi again guys. Right today was the first chance ive had to drive my new alfa since receiving it last week. (sorting out tax, insurance). Im smitten, i love the sound and the handling. Had a few looks off other drivers, one guy who was behind me in an audi S3 looked intrested. Prob to do with...
1-10 of 10 Results
Top