Alfa Romeo Forum banner

20l

  1. Engines (TS, JTS, JTD & V6)
    Hi guys, needing your help in identifying this noise which sounds internal & more prominent at idle, my car seems to be running fine apart from this noise which has got me stumped. I have removed timing belt cover to check for faulty tensioners and pulleys but all seems fine. I have also...
  2. Alfa Giulia
    Has anyone done this? Think some tuners can remove the function of pumping heat into Cat upon startup until warm. Have an aftermarket exhaust and happy with sound except on cold start when it sounds too much. Have you heard of any alfa tuners who have done this on Giulia or other models? Is...
  3. Alfa 147, 156 & GT
    Hi there, i have a small problem with the car, replaced the battery in the key fob and now unable to use the central locking not working. Any help would be muchly appreciated.
  4. Alfa GTV & 916 Spider
    Hi had the battery go flat or appear to be after a long run! left car for approx 1 hour returned and it started no problem, when home checked charging voltage its around 13.6 volts . decided to remove battery for a charge and found it wet on all its sides?. changed battery for another no...
  5. Alfa 145 & 146
    Hi, im looking a Oil Pump for rebuild the whole engine of my Alfa Romero 145 2.0L Engine. Looking some store that sell internationally the pump. In argentina cost 450USD :/
  6. Alfa 159, Brera & 946 Spider
    Just bought a blow off valve greddy rz where dose it go any pics
  7. Alfa 159, Brera & 946 Spider
    Just bought a blow off valve greddy rz where dose it go any pics
  8. Alfa 159, Brera & 946 Spider
    Recently Bought my 2010 159ti and I was thinking of getting it remapped. The car currently sits at 70000. Is it worth it and where would be the best place to go in central/north Scotland? I'm also wanting to upgrade the exhaust but have been told by some car friends to upgrade the air intake as...
  9. Introduce Yourself
    Hi there, Im glad to be part of this forum. I'm 26, father of an 2and a half yrs boy and recently owner of an 2003 Alfa Romeo SW 2.0L gas JTS. Hello from Romania!!!
  10. Alfa Giulietta
    Start the car when engine is warm (possibly after regen or mid regen) and it runs like a bag of spanners. Turn it off and then restart and all is fine. No eml or stored codes. Anyone else had this?
  11. Alfa GTV & 916 Spider
    My 1999 GTV 2.0 tb runs for thirty seconds (exactly) then dies, check engine(injector) light comes on. Restarts immediately, no problem.
  12. Alfa 147, 156 & GT
    Hi Guy's, Please can you help me locate a couple of Coil Packs for my Bella. The OEM Part Nr. 467 947 82 Bosch Part Nr. 0221 604 103, local agent quoted me a ridiculous price of R1546.82 excl. Vat. If anyone out there has got a few or know where I can get them cheaper please let me know...
  13. Alfa 147, 156 & GT
    Hi everyone, Pleeeease, please, please help.me guys!!! My 156 JTS aircon not cooling. I:ve installed gas, checked for leaks(no leaks), compressor kicks in but aircon still not cooling. Can someone, anyone who has had the experience share/help with a solution.* I.live in the Lowveld...
  14. South Africa
    Hi everyone, Pleeeease, please, please help.me guys!!! My 156 JTS aircon not cooling. I:ve installed gas, checked for leaks(no leaks), compressor kicks in but aircon still not cooling. Can someone, anyone who has had the experience share/help with a solution. I.live in the Lowveld...
  15. Alfa 147, 156 & GT
    Hi everyone, So i'm really enjoying my 156, but I seem to be having a problem with my gearbox. When driving and changing gears from 1st to 5th, no problems, but when slowing down to stop at a robot for instance, as she changes down from 5th to 1st, she "snaps" into 2nd & 1st gears. 5th, 4th &...
  16. South Africa
    Hi everyone, So i'm really enjoying my 156, but I seem to be having a problem with my gearbox. When driving and changing gears from 1st to 5th, no problems, but when slowing down to stop at a robot for instance, as she changes down from 5th to 1st, she "snaps" into 2nd & 1st gears. 5th, 4th &...
  17. Engines (TS, JTS, JTD & V6)
    Hi guys, After repairing my starter yesterday, I took my car for a drive. Noticed a tappet pinging noise while driving in traffic especially when engine is hot. The heat guage was normal (90°).* Also noticed it before at that temp. Its Ok on low revs but pinging starts as soon as I floor it a...
  18. South Africa
    Hi Everyone. Im fairly new to this forum. Been Noticing a tappet pinging noise while driving in traffic especially when engine is hot. The heat guage is on 90° to 95° Its Ok on low revs but pinging starts as soon as I floor it a bit.* When engine has cooled down, its fine no pinging...
  19. Alfa 147, 156 & GT
    Hi guys, After repairing my starter yesterday, I took my car for a drive. Noticed a tappet pinging noise while driving in traffic especially when engine is hot. The heat guage was normal (90°). Also noticed it before at that temp. Its Ok on low revs but pinging starts as soon as I floor it a...
  20. Alfa 147, 156 & GT
    Hello everyone After a lot of mucking around I finally got my Selespeed issues resolved and now it starts on the key but then it stops again as though the fuel pump power is switching off. Anybody out there with a manual who can help me locate the relay? Cheers from Australia
Top