Loss of torque and power after decat.?! Help - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 
Thread Tools
(Post Link) post #1 of 7 Old 08-04-16 Thread Starter
Status: -
AO Member
 
Dmitrijs's Avatar
 
Join Date: Oct 2014
Location: Ireland
County: Kildare
Posts: 36
Loss of torque and power after decat.?! Help

Hi guys! yesterday have installed free flow pipes instead of back box silencer( car was remapped before this mod) and also have second cat replaced with free flow few months ago,so before installation of free flow instead of back box silencer car was more lively and more torque as well,so do i need to remap again to sort it out? Thanks
Dmitrijs is offline  
Sponsored Links
Advertisement
 
Status: -
AO Silver Member
 
typos1's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: Dorset
Posts: 3,775

Member car:

147 Ducati Corse

Probably - the car has been mapped with the standard exhaust in place, you should always map AFTER doing exhaust mods really. Soz if you paid out loads and you gotta pay out loads again.
typos1 is offline  
(Post Link) post #3 of 7 Old 10-04-16 Thread Starter
Status: -
AO Member
 
Dmitrijs's Avatar
 
Join Date: Oct 2014
Location: Ireland
County: Kildare
Posts: 36
Quote:
Originally Posted by typos1 View Post
Probably - the car has been mapped with the standard exhaust in place, you should always map AFTER doing exhaust mods really. Soz if you paid out loads and you gotta pay out loads again.
Yes you right mate,my best option for now is leave this issue until i have all mods done,then custom map finally
Dmitrijs is offline  
Status: fix it till it's broken
AO Member
 
Black-Sheep's Avatar
 
Join Date: Jul 2008
Location: Germany
County: Sachsen
Posts: 562

Member car:

Delta III 1.9 TT

As your car is turbo it most likely some sensor fault. Have you disconnected anything and might be forgotten to put it back? (or damaged a wire?).

I had a 1.9 JTDM which had lust it's exhaust right after the turbine.... and that thing was instant on Spool and power (just a tad to noisy). There is simply no way that a free flow exhaust will seriously hamper a JTD engine without a remap - there must be some sensor info missing for the ecu so it's in some kind of limp mode. (or your free flow stuff is not free flow)

Selling a Brembo Upgrade for 156's, Project Mu Pads (New) and fitting brake lines (new).

link to the thread
Black-Sheep is offline  
Status: -
AO Silver Member
 
typos1's Avatar
 
Join Date: Mar 2008
Location: United Kingdom
County: Dorset
Posts: 3,775

Member car:

147 Ducati Corse

He HAS a remap though,black sheep . . .
typos1 is offline  
Status: -
AO Member
 
Join Date: Sep 2015
County: -
Posts: 30
I had a re map then put the pre-cat de-cat on and it made it better on 1.9 cdti fiat engine
rob99 is offline  
(Post Link) post #7 of 7 Old 10-04-16 Thread Starter
Status: -
AO Member
 
Dmitrijs's Avatar
 
Join Date: Oct 2014
Location: Ireland
County: Kildare
Posts: 36
Thanks guys yes my free flow is a proper freeflow with 72mm pipes straight from main cat,there is only one thing left for this mod -replace main cat with downpipe and custom map on dyno
Dmitrijs is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
decat , loss , power , torque

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome