GQV MAP boost sensor testing - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 
Thread Tools
(Post Link) post #1 of 4 Old 16-11-15 Thread Starter
Status: -
AO Member
 
twanspider's Avatar
 
Join Date: Oct 2010
Location: Malta
County: -
Posts: 428
GQV MAP boost sensor testing

I have had haphazard P0240 error Turbo/Supercharger Boost Sensor B circuit Range/Performance only when I floor the car.

I have removed the MAP sensor from the engine (clip still attached) and with ignition on (engine not running) I have 1.54V from signal wirer. The ECU is sending 5.10 V from the other wire. Is this normal for the signal to be at 1.54V ?

I thought the signal was suppose to be more or less equal to the supply voltage the ECU is sending ie 5V . When I suck the pipe the voltage at signal does decrease from 1.54 to 1.3V

I'm suspecting the MAP sensor is faulty. Any thoughts before I go ahead and trash out 50 quid for a replacement ?


P.S I have a Spider tuning box and have reduced power but still got erro

cheers
twanspider is offline  
Sponsored Links
Advertisement
 
Status: To GTB or not to GTB?
AO Silver Member
 
TribesMan's Avatar
 
Join Date: Nov 2007
Location: Slovenia
County: -
Posts: 2,289
That seems about right.

When you have removed MAP sensor from the engine it detects atmospheric pressure of 1bar.
I don't have exact linearisation map from this ECU, and I don't know what MAP sensor is used in this engine. But 1.54V is probably around 1bar.
And if you suck on it, you create vacuum, so that is perfectly fine if the voltage reading drops.
TribesMan is offline  
(Post Link) post #3 of 4 Old 16-11-15 Thread Starter
Status: -
AO Member
 
twanspider's Avatar
 
Join Date: Oct 2010
Location: Malta
County: -
Posts: 428
I was unsure as all the videos Ive seen on you tube all showed that the voltage from the signal was close to 5v. Hence mine being 1.54 makes me unsure if I have a faulty sensor
twanspider is offline  
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
the signal is variable depending on pressure.
Cuore_Sportivo_155 is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
boost , gqv , map , sensor , testing

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome