Alfa 156 1.9jtd gt2256v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 
Thread Tools
(Post Link) post #1 of 17 Old 08-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Alfa 156 1.9jtd gt2256v

Hi everyone, after this upgrade on my 156 now i have an issue regarding boost pressure at 1500-3000rpm, it doesnt reach the desired boost no matter what a friend of mine (who does the map editing) and i do.
In the upgrade is concluded next: gt2256v turbo from AR166 euro3, 3bar map sensor.
Everything is seted up like it must be, the turbo is tested on a bench, map sensor is working perfect.
Im attaching the latest log to see exatly whats happening.
What could it be?
Attached Files
File Type: xls sale 156 log.xls (29.0 KB, 34 views)
Pittatore is offline  
Sponsored Links
Advertisement
 
Status: To GTB or not to GTB?
AO Silver Member
 
TribesMan's Avatar
 
Join Date: Nov 2007
Location: Slovenia
County: -
Posts: 2,289
Well hard to say, without seeing the map...

But most probably just down to bad VNT mapping. But you must know spool will never be as good as with stock turbo. Don't expect much more than 1bar boost before 2000rpm...
TribesMan is offline  
(Post Link) post #3 of 17 Old 08-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Here s the map
http://www.filedropper.com/salebgturbo5351517_1
Could You please look at it and suggesed something?
Pittatore is offline  
Status: -
AO Member
 
Join Date: May 2012
Location: United Kingdom
County: Hampshire
Posts: 517

Member car:

1.9CDTI 16v

If you get a decent data logger, it should be able to capture VNT solenoid duty and that would help much more. Looking at it though, I think your friend is not very good at mapping and did not change one of the boost limiters, there is a table of boost limit values and also a single vales boost limit. Both would be set at 2500mb as standard.
nutron is offline  
Status: To GTB or not to GTB?
AO Silver Member
 
TribesMan's Avatar
 
Join Date: Nov 2007
Location: Slovenia
County: -
Posts: 2,289
Try to shorten VNT rod by 1 turn of the screw and report back...

BTW, how much smoke do you get with those settings?
It looks very extreme, it should smoke like a pig...
TribesMan is offline  
(Post Link) post #6 of 17 Old 10-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

To be honest I wouldnt touch the turbo since the setup its done(factory values for the 2.4 jtd) properly by the Turbo service.
It has smoke just before the turbo comes at about 3000rpm after that no smoke.
Pittatore is offline  
Status: To GTB or not to GTB?
AO Silver Member
 
TribesMan's Avatar
 
Join Date: Nov 2007
Location: Slovenia
County: -
Posts: 2,289
Well, that is your only chance really, VNT is opened as much as it can be in the ECU.

I would suggest you to at least try it, you can set it back then if it makes no difference.

If turbo was rebuilt then there is 50:50 chance the settings are not 100% correct...
TribesMan is offline  
(Post Link) post #8 of 17 Old 10-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Well I will see, must mark the origin position of the rod.
The turbo was not rebuild, there were no need for it, just a setup to factory values because I bought it as used part.
Pittatore is offline  
Status: -
AO Member
 
Join Date: Jul 2012
Location: Bulgaria
County: Sofia
Posts: 170
Check all the hoses are attached properly and not leaking.
pyle is offline  
(Post Link) post #10 of 17 Old 14-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Today finally I managed to do logs and setting up the WG rod
Attached are 2 logs before and after shorting up the rod by 1 circle
Any better? No, still the same. What I have captured is that the rod is a little bit loosten, let say its not in tense.
Attached Files
File Type: xls sale log before shorten up the wg rod.xls (17.5 KB, 12 views)
File Type: xls sale log after shorten up the wg rod.xls (18.0 KB, 12 views)
Pittatore is offline  
Status: -
AO Member
 
Join Date: May 2012
Location: United Kingdom
County: Hampshire
Posts: 517

Member car:

1.9CDTI 16v

Your log shows so little data it is almost worthless. You need a decent log with all the variables, rail px, fuel temp, oat temp, boost temp, atmospheric px, vnt duty, swirl actuator duty, and so on...
nutron is offline  
(Post Link) post #12 of 17 Old 15-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Here is another log after turning the WG rod by one more turn.
Attached Files
File Type: xls sale log wg setup by 2 turns.xls (27.0 KB, 15 views)
Pittatore is offline  
(Post Link) post #13 of 17 Old 16-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Looking at the latest log I see the overboost at 3016rpm but Im confused what can cause the huge Boost dropdown after hitting the boost limiter?
Anybody can advice something?
Pittatore is offline  
Status: no pain, no gain
AO Silver Member
 
yan.ko's Avatar
 
Join Date: May 2010
Location: Czech Republic
County: Moravskoslezský
Posts: 1,951
Garage
boost pressure PID controller probably (next to the torn hose)
yan.ko is offline  
(Post Link) post #15 of 17 Old 19-07-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Here is a new log, I ve gone a little extreme and shortened up the rod by another 3 turns (6 in total)
and still I cant get boost from 2000-2800rpm and it smokes at these rpms, it doesnt has sence shorting the wg rod anymore
Vacum hoses checked, all fine.
Attached Files
File Type: xls sale log wg setup by 6 turns.xls (26.5 KB, 11 views)
Pittatore is offline  
Status: -
AO Member
 
Join Date: May 2012
Location: United Kingdom
County: Hampshire
Posts: 517

Member car:

1.9CDTI 16v

Mate of mine just fitted a GTB2562VKLR ball bearing unit to his 1.9CDTI and it hits 38psi at 3000rpm, try fitting one of those
nutron is offline  
(Post Link) post #17 of 17 Old 08-08-15 Thread Starter
Status: -
AO Member
 
Join Date: Jan 2009
Location: Serbia
County: -
Posts: 43

Member car:

Alfa Romeo155 V6

Update:
Changed the boost to 2.75 and done some logs before and after mounting a straght pipe 60mm exhaust but its still struggling to achive boost from 2000-2800rpm
Anybody any idea?
Attached Files
File Type: xls sale log 2,75 before.xls (26.5 KB, 14 views)
File Type: xls sale log straight pipe 2,75 after.xls (29.0 KB, 12 views)
Pittatore is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
156 , 19jtd , alfa , gt2256v

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome