italian box - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 
Thread Tools
(Post Link) post #1 of 8 Old 31-07-13 Thread Starter
Status: -
AO Member
 
action84's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: West Sussex
Posts: 322
italian box

tried fitting Italian box this morning all connected up correctly as far as I could tell and the engine wouldn't start. Anyone have any ideas what the problem could be
action84 is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 8 Old 31-07-13 Thread Starter
Status: -
AO Member
 
action84's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: West Sussex
Posts: 322
als have mscf error pop up
action84 is offline  
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
one of the sensors connected to the box is likely not reading now, which is why you get a MSCF error. Or you knocked another sensor while fitting the box.

I'm not familiar with the "italian box", but I do know an unconnected rail pressure sensor, which all boxes connect to, causes a failure to start...
Cuore_Sportivo_155 is offline  
(Post Link) post #4 of 8 Old 31-07-13 Thread Starter
Status: -
AO Member
 
action84's Avatar
 
Join Date: Sep 2011
Location: United Kingdom
County: West Sussex
Posts: 322
I have disconnected it now wouldn't start at all with it connected
action84 is offline  
Status: playing kill by numbers
AO Gold Member
 
Join Date: Feb 2005
Location: Belgium
County: Down in the Park
Posts: 8,786
I'm guessing the box is faulty or is not intended for your engine
Cuore_Sportivo_155 is offline  
Status: -
Newbie
 
Join Date: Sep 2013
County: -
Posts: 1

Member car:

145

The Italian Box - Beware!

Quote:
Originally Posted by action84 View Post
tried fitting Italian box this morning all connected up correctly as far as I could tell and the engine wouldn't start. Anyone have any ideas what the problem could be
Hi

I bought an Italian Box via Ebay. It arrived and was faulty. I sent it back and was promised a replacement upon providing a tracking number. The replacement never arrived and they then promised a refund which also never happened after many promises and weeks. Ebay are investigating the company and I have mow provided my bank with all the email promises and ebay correspondence to get my money back.

The owner is luigi and he is a liar. BEWARE!!
vinsvolkswagen is offline  
Status: Smitten with the Busso
AO Silver Member
 
Alfadisiac's Avatar
 
Join Date: Apr 2011
Location: United Kingdom
County: Wrexham
Posts: 1,286
Garage
I bought one for my 1.9 before I had it remapped properly.
I never had any problems, worked out of the box no problem but car was VERY smoky.
I still have it lying around if somebody wants it for postage cost...
Alfadisiac is offline  
Status: -
AO Member
 
Join Date: Oct 2009
Location: Portugal
County: Coimbra
Posts: 53

Member car:

Alfa Romeo GT

Quote:
Originally Posted by vinsvolkswagen View Post
Hi

I bought an Italian Box via Ebay. It arrived and was faulty. I sent it back and was promised a replacement upon providing a tracking number. The replacement never arrived and they then promised a refund which also never happened after many promises and weeks. Ebay are investigating the company and I have mow provided my bank with all the email promises and ebay correspondence to get my money back.

The owner is luigi and he is a liar. BEWARE!!
Funny, i had the EXACTLY the same problem. Definitely not the serious seller i had dealt with. Won´t buy from them again.
blayde is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
box , italian

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome