Driveshaft problem 16v - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 
Thread Tools
(Post Link) post #1 of 2 Old 04-02-18 Thread Starter
Status: -
AO Member
 
yondaime's Avatar
 
Join Date: Jan 2015
Location: ADIYAMAN
County: TURKEY
Posts: 48
Driveshaft problem 16v

Hello, I want to ask a question over this.

I have a pretty tuned 147 16v 1.9 jtd Q2 with stage 2 clutches(bronze+kevlar pads), gt2052s hybrid turbo, 2.5 " fullback downpipe exhaust, Bmc Dia air filter, Hg motorsports 8.2 liters intercooler, decatted and egr off. Peak boost is about 22 psi and we think that it's about 210 hp (it's a soft-moderate map with nearly no smoke)

These are done nearly 30k kms ago. But I have a problem about my driveshafts. Original ones were repaired before these things done. An axle maker guy said that original shafts wont stand that torque. So a custom one should be made. So something other produced with different spider system (I don't know if I'm spelling it true)... Yet one year later (TODAY) while on cruise, car didn't push any power to wheels and I have seen that shaft was cutted like it was done by a saw.

What's the solution here? Should I buy brand new shafts? Or reproduced this one with something else?

How can your faster cars stand that torque? Any way I can find a competition shaft?
yondaime is offline  
Sponsored Links
Advertisement
 
Status: Trying to Run
AO Member
 
emre2blue's Avatar
 
Join Date: Aug 2009
Location: Turkey
County: Istanbul
Posts: 559
Hi, from Turkey, also

I think original shafts can hold that much boost and HP, but the max torque rpm should be above 2000rpm. All the people that I talk and listen, told me stay away from 2000rpm range. After that you are free to go. If the MAP has too much torque opened below 2000rpm and near it, gives hard times to axels.

Call me if you need help..
emre2blue is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
16v , driveshaft , problem

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome