2004 Alfa Spider Lusso - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 
Thread Tools
(Post Link) post #1 of 1 Old 28-06-17 Thread Starter
Status: -
Newbie
 
Join Date: Jun 2017
County: -
Posts: 2
2004 Alfa Spider Lusso

I have a 2004 Spider Lusso which has a couple of problems that aren't able to be fixed at a local level here in Australia.

When slowing to a traffic light the car develops a harsh kangaroo hop under 40 KMH or so in low gear and whilst idling at the lights I'm getting an infrequent missing.

The service team have installed new air flow, plugs and coils, fuel pressure regulator, throttle body and injectors have been flushed. These have failed to fix the problem.

There are no fault codes on the computer.

It has been suggested that injectors be replaced, the labour would be high to pull engine out for this, a new accelerator potentiometer and check and clean all engine sensors and earthing on account of bad connections might drop the voltage to 6 volts or so that could cause the problems but not register a fault code? It's a 2 litre JTS engine.

Please help as we are clueless on our next move. These problems ruin the driving of an otherwise beautiful car !

My email [email protected]

Cheers
Peter T Hughes is offline  
Sponsored Links
Advertisement
 
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
2004 , alfa , lusso , spider

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome