Update as ive been away - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 4Likes
  • 2 Post By mirlock
  • 1 Post By gibot123
  • 1 Post By mirlock
 
Thread Tools
(Post Link) post #1 of 4 Old 04-04-17 Thread Starter
Status: Working Hard On 156 Veloce 3.0 Turbo Project
AO Silver Member
 
mirlock's Avatar
 
Join Date: Mar 2014
Location: United Kingdom
County: Northamptonshire
Posts: 1,309
Update as ive been away

Been away for a while with not much done to project due to family illness . But never the less i should be back on track with the building .
I have got all the engine connected and have just run all the cables and hoses through to the cabin (pic shows just before hoses done)
here is a pic so far but just need a tidy up ( ignore the umbrella disk its a template for an alfa sticker going on it )

Any way here is a photo and i will update as i get things sorted but so far it runs sweet very very fast revving with the new cams .
Attached Images
File Type: jpg 20170326_174935.jpg (154.3 KB, 25 views)
emre2blue and maxiboy wales like this.

All spares parts for 156 and 147 being sold that i will not be using (cheap) nothing too small ask what you want , willing to post world wide Phone 07922123242 Ask for Neil and say Mark said to phone .

Download link for Alfa 156's http://www.filedropper.com/alfaelearn
mirlock is offline  
Sponsored Links
Advertisement
 
Status: got a new 159 jtdm
AO Silver Member
 
gibot123's Avatar
 
Join Date: Aug 2013
Location: United Kingdom
County: East Sussex
Posts: 2,259
Garage
Hi mate glad to hear your still about.
That motor looks fantastic
I'm so missing my v6 , gone over to the darkside of the diesel!!! No I don't know why
maxiboy wales likes this.
gibot123 is offline  
Status: -
AO Silver Member
 
Join Date: Nov 2013
Location: United Kingdom
County: Carmarthenshire
Posts: 3,981

Member car:

Alfa 156 Gta

Glad your still going ahead
maxiboy wales is offline  
(Post Link) post #4 of 4 Old 07-04-17 Thread Starter
Status: Working Hard On 156 Veloce 3.0 Turbo Project
AO Silver Member
 
mirlock's Avatar
 
Join Date: Mar 2014
Location: United Kingdom
County: Northamptonshire
Posts: 1,309
Thanks guys , its been hard not being able to do anything and being so far out in the sticks not being able to get internet or phone signal.

But i am happy now the engine is done and not have to take it out again because i feel i need to add something.
Only problem i have is alternator it got refurbed and now its in its not charging but most likely a bad earth or something i shall address it when i feel like it.

Ive just added new steering gaiters and track control arms so thats every gaither and bush and bearing done besides front bearings as they were new just before i got the car and are good.

Ive added 3 extra gauges oil temp / pressure and AFR

Only real pain in the back side thing i have todo before starting the body mods is i originally fitted a stock alfa intercooler but got a bargain of a larger alloy Abarth intercooler for only £20 so i had to fit that but it got to be moved as it is in the way of the headlights , I should be able to drop it a little so the headlight rear clears it.

Ive also fitted 3 thermo fan relays 1 thats switches oil cooler fan and 2 for intercooler fans just to make sure it gets plenty of air flow 1st 1 switches of 2 small fans for a little air flow then i have a Delta high flow fan which i think is about 5000-10000 rpm which i had from a old computer server i had a way back . ive only done this as the intercooler is fitted side ways and wont have direct fresh air flow.



Anyway sorry its taking so long its mainly because of budget and everything i have the for the car has be gained via a bargain from auction wins or having to make something i need out of something else. (besides things that just cant be made by me or be bought cheap then i just have to save )

Thanks to everyone who has been helping along the way and im sure i will be asking some more advice before then end .

Thanks Gertie for helping me solve the brake vacuum issue . in the end i added a 1 way flow valve and a vacuum chamber and it works very well as can still gets a good vacuum when not on boost and gets saved

will update more later as things go which should be faster now

pics of vacuum chamber below & yes its all dirty but ill clean it all good when finished
Attached Images
File Type: jpg chamber.jpg (177.8 KB, 9 views)
File Type: jpg 20170406_181814.jpg (170.0 KB, 7 views)
maxiboy wales likes this.

Last edited by mirlock; 07-04-17 at 14:52.
mirlock is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
update

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome