Need to pick someones brains - Alfa Romeo Forum
You are currently unregistered, register for more features.    
Tuning & Upgrades Discuss performance enhancements for your Alfa Romeo

 
Thread Tools
(Post Link) post #1 of 2 Old 02-04-17 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2016
County: -
Posts: 137
Need to pick someones brains

Right ive put engine back together and in car upgraded cams were fitted along with belt etc etc.

On starting i now seem to have a noisy tappet what i need to know is before i start pulling it apart i would like people to list what could make this happen.

Example if a cam was slightly out would this happen.
or would timing need to be tweaked or ecu reset

it didnt tap before and its a bug bear for me i hate tapping noise
As a point its the rear bank that has noisy tappet

another thing that may be connected is on revving the engine it revs high fast but seems sticky to decrease in revs. Just to add the Engine starts flawlessly 1 turn of key with no throttle

thanks for any help for me to ponder over


Car 156 2.5 with 3.0 Engine
Fast Road Cams

Last edited by Overkill; 02-04-17 at 18:12.
Overkill is offline  
Sponsored Links
Advertisement
 
(Post Link) post #2 of 2 Old 03-04-17 Thread Starter
Status: -
AO Member
 
Join Date: Nov 2016
County: -
Posts: 137
Update..

Pretty much sorted now i did BMW lifter bleed trick and a lot lot better.
And the slow down reving was a vacuum pipe not connected
Overkill is offline  
Reply

Go Back   Alfa Romeo Forum > Supported Alfa Romeo Models > Technical & Vehicle Assistance > Tuning & Upgrades

Tags
brains , pick , someones

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome