My Passport external memory problem - Alfa Romeo Forum
You are currently unregistered, register for more features.    
The Technology Section A place to discuss technology & gadgets.

 
Thread Tools
(Post Link) post #1 of 3 Old 07-05-16 Thread Starter
Status: Not my PM
AO Platinum Member
 
AlfaDrivingFan's Avatar
 
Join Date: Aug 2009
Location: European Union
Posts: 44,636
My Passport external memory problem

My mum has one of these My Passport 500GB external memory drives, stores photos and stuff on it. She used it when her PC was running Windows 7, she since upgraded to Windows 10 and the My Passport now refuses to work.

I have no clue what to do so any advice would be welcome.

Thanks in advance
AlfaDrivingFan is offline  
Sponsored Links
Advertisement
 
Status: T-5 Days to Unicorn Paradise
AO Platinum Member
 
TheGrimJeeper's Avatar
 
Join Date: Sep 2009
Location: France
County: Riviera
Posts: 38,319
Try it on another machine.

Then start checking drivers etc on the W10.
TheGrimJeeper is offline  
(Post Link) post #3 of 3 Old 07-05-16 Thread Starter
Status: Not my PM
AO Platinum Member
 
AlfaDrivingFan's Avatar
 
Join Date: Aug 2009
Location: European Union
Posts: 44,636
Firing up an even older PC that runs XP to see if it will run on that.
AlfaDrivingFan is offline  
Reply

Go Back   Alfa Romeo Forum > Misc Lounges > Community Discussions > The Technology Section

Tags
external , memory , passport , problem

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

 
For the best viewing experience please update your browser to Google Chrome